Page 20 of 22 FirstFirst ... 101516171819202122 LastLast
Results 381 to 400 of 433
  1. #381  
    Im inserting exactly this:

    # -*- mode: shell-script; -*-
    description "Overclock to 600MHz + SmartReflex"
    author "Alex Markson"
    version 1.0

    start on stopped finish
    stop on runlevel [!2]

    console none

    script

    # SmartReflex
    # "SmartReflex™ driver allows for auto-compensation of VDD1 and
    # VDD2 voltages (around the voltages specified by current OPP)
    # by analyzing the silicon characteristics, temperature, voltage etc"
    #
    # Enable SmartReflex
    echo -n 1 > /sys/power/sr_vdd1_autocomp
    echo -n 1 > /sys/power/sr_vdd2_autocomp

    # according to the OEM shell script in /etc/miniboot.sh
    # this seems like it needs to be set twice to make sure ?
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

    end script
  2. #382  
    Quote Originally Posted by gtkansan View Post
    So im a newb with linux and obviously cant get this to work on reboot. I have tried both the wiki methods of scaling, and smart reflex. I make a file with the command (as root) vi /etc/event.d/overclock

    Then I insert the text with a copy-past command and save the file with escape then :wq.

    I reboot and the file obviously doesn't run, my time in state always stays the same as it did before... I can manually change the frequency max with the echo .... max_Freq command, but it wont stick on reboot. Any help would be appreciated. Thank you
    Again, SmartReflex is not a frequency scaling method. It's a built in voltage regulation feature of the OMAP chip. Your time in state should NOT change -- the processor speed should be fixed at whatever you set it to in your startup script. To check that SmartReflex was properly enabled, you can cat /sys/power/sr_vdd1_autocomp and /sys/power/sr_vdd2_autocomp to confirm that they are both set to 1.
  3. #383  
    Part of that is the extra part of the script to allow for the scaling_setspeed to be set to 600000. Since this is not occuring (according to the time in state), it is fair to assume that the file is never run correct? I will ssh in shortly to see if the sr_vdd2_autocomp etc are set to one, but my guess is that they arent.
  4. #384  
    How can I safely make CPU-Scaling stick on reboot? I know there are a variety of methods. But, I didn't use Sudo or Putty or Nano or anything. I just followed the directions to Telnet into my Pre, entered the appropriate commands for rooting, dropped elysian's CPU-Scaling file into my Pre folder on the desktop, keyed in the commands to activate and that was it.

    Are there any commands I can enter, just like those I used to set up scaling, that will make it stick? No Putty, No Nano, No Sudo, No dropbear or any other thing I don't understand or fear putting on my phone. Just key commands from a terminal? It seems, if that's all I needed to turn it on, it should be all I need to keep it on.

    Thanks!
  5. #385  
    Quote Originally Posted by gtkansan View Post
    Part of that is the extra part of the script to allow for the scaling_setspeed to be set to 600000. Since this is not occuring (according to the time in state), it is fair to assume that the file is never run correct? I will ssh in shortly to see if the sr_vdd2_autocomp etc are set to one, but my guess is that they arent.
    Either there is a bug in your script (perhaps not pasted correctly) or you have something else in your boot scripts that is overwriting the settings.
  6. #386  
    I double checked and it is exactly the way i copied it in... I even tried ch-mod +x to make it executable. Man this is strange and annoying
  7. #387  
    Is there a way to see what the order files are loaded in the /etc/event.d folder? I assume that something is just coming along and undoing what I did... i guess.... I called the file powersave so maybe this is just too early (how are they loaded, in what order?). Is there a way to say 'load this last"?
  8. #388  
    Why would you make it executable? I've never done that when setting this stuff up.
  9. #389  
    Just trying anything I can think of... I have no idea why it wont run.
  10. marwp's Avatar
    Posts
    8 Posts
    Global Posts
    9 Global Posts
    #390  
    How did you creat the file? Did you make it in notepad then transger o ypur Pre? Did you cut and past into VI or Nano? Sometimes windows adds extra chariters at the end of lines and stuff that you can't see. Try re-creating it on the Pre in VI (type it all out....no cit and paste). Don't forget to sudo -i and open (and close) your file system (mount -o remount,rw /).
  11. #391  
    Quote Originally Posted by marpol View Post
    How did you creat the file? Did you make it in notepad then transger o ypur Pre? Did you cut and past into VI or Nano? Sometimes windows adds extra chariters at the end of lines and stuff that you can't see. Try re-creating it on the Pre in VI (type it all out....no cit and paste). Don't forget to sudo -i and open (and close) your file system (mount -o remount,rw /).
    I was logged in as root and made the file system writeable

    then typed "vi /etc/event.d/powersave"

    This took me into the vi editor, I entered the text manually (and copied another time) then hit "esc :wq" to save and exit the file

    What do you mean by sudo -i?
  12. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #392  
    Quote Originally Posted by gtkansan View Post
    I was logged in as root and made the file system writeable

    then typed "vi /etc/event.d/powersave"

    This took me into the vi editor, I entered the text manually (and copied another time) then hit "esc :wq" to save and exit the file

    What do you mean by sudo -i?
    Trying adding .sh to your file (ex. powersave.sh) That's what i had to do to make it work.
  13. #393  
    Quote Originally Posted by as4life View Post
    Trying adding .sh to your file (ex. powersave.sh) That's what i had to do to make it work.
    Nope. Didnt solve it either... erg.
  14. marwp's Avatar
    Posts
    8 Posts
    Global Posts
    9 Global Posts
    #394  
    Quote Originally Posted by gtkansan View Post
    I was logged in as root and made the file system writeable

    then typed "vi /etc/event.d/powersave"

    This took me into the vi editor, I entered the text manually (and copied another time) then hit "esc :wq" to save and exit the file

    What do you mean by sudo -i?
    If you log into your back door you need to then become root. sudo -i makes you root. Sounds like you already logged is as root though.
  15. #395  
    I logged in through usbnet ssh and ran "sudo su" to become root.
  16. marwp's Avatar
    Posts
    8 Posts
    Global Posts
    9 Global Posts
    #396  
    Quote Originally Posted by gtkansan View Post
    Nope. Didnt solve it either... erg.
    gtkansan,

    Have you tried running this on the fly? ie. From the root prompt type in:

    echo -n 1 > /sys/power/sr_vdd1_autocomp
    echo -n 1 > /sys/power/sr_vdd2_autocomp
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

    and then verify that it works:

    cat /sys/power/sr_vdd1_autocomp
    cat /sys/power/sr_vdd2_autocomp

    Both should be 1

    cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state


    This will set SmartReflex and your cpu freq to 6000000 until you reboot. If you just want to play around with it this is a better way to do it.....incase you crash just reboot and your back to stock. Then once you have it the way you like add your script.
  17. #397  
    I have indeed run it as root, and verified that it works. I just cant make it stick on reboot
  18. #398  
    Are you sure you don't have another script that you've installed that's undoing/overwriting your settings?

    The only other thing I can think of is that my script is named "opt-overclock", not "powersave". I don't know if filename affects the order in which boot scripts are run but it's worth a try. I can definitely confirm that execute permissions are not required -- mine has 644 permissions.
  19. #399  
    i tried renaming it to opt-overclock, and opt-overclock.sh and still nothing
  20. diomark's Avatar
    Posts
    752 Posts
    Global Posts
    770 Global Posts
    #400  
    My pre runs pretty well w/ smartreflex locked at 600mhz.. but it does use more battery when streaming..

    What I would love is a program which would lock it at 500/smart reflex when using a2dp with the screen off, but bump it up when using a2dp with the screen on.. (with perhaps an option to stay at 500mhz if not using a2dp?)

    Anyone up for it? The pre is too sluggish while using an a2dp bluetooth stereo headset without being at 600mhz.. (but drains too fast at 600mhz while streaming..) no reason for it to be at 600mhz when the screen is off.

    -mark

Posting Permissions