Page 16 of 22 FirstFirst ... 61112131415161718192021 ... LastLast
Results 301 to 320 of 433
  1. #301  
    So if I copy and paste the smartflex code on noinc, will it work. I heard it crashes. Can someone show me their code that they used for smartflex with on demand off... Maybe so I can just copy and paste into event.d
  2. #302  
    NVM, I see they updated the wiki with it so Ill see how it does, and if I still have EVDO afterwards...
  3. #303  
    Seems to work fine since the reboot, evdo is up and running...

    Did a quick time_in_state and its mostly at 600... tested out a few apps..

    Just letting it charge now... Hopefully the smartflex without scaling will be a nice addition...
  4. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #304  
    Quote Originally Posted by DNic View Post
    I put in exactly what he had in his script @ blog.noinc.com/?p=124
    Weird.

    What do you get when you run the following?
    sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq

    And:

    sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

    I get 600000 for both.

    And my time in state right after a reboot:
    600000 23845
    550000 763
    500000 172
    250000 0
    125000 0

    Basically it shows the CPU is ran at 500mhz and 550mhz while booting, then after the event.d script executes it's up to 600mhz...
  5. DNic's Avatar
    Posts
    570 Posts
    Global Posts
    599 Global Posts
    #305  
    Quote Originally Posted by VitViper View Post
    Weird.

    What do you get when you run the following?
    sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq

    And:

    sudo cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

    I get 600000 for both.

    And my time in state right after a reboot:
    600000 23845
    550000 763
    500000 172
    250000 0
    125000 0

    Basically it shows the CPU is ran at 500mhz and 550mhz while booting, then after the event.d script executes it's up to 600mhz...
    I get 500000 for both. I double checked the file I created in event.d and it seems correct.

    Edit: I deleted the file and typed it in and now it shows 600000 for both. Weird.
    Last edited by DNic; 07/07/2009 at 07:31 PM.
  6. #306  
    Quote Originally Posted by Elysian893 View Post
    Bah, my USB port isn't working now, its going to charge only mode...

    edit: fixed, just had to reboot the pc.
    So, over 5 hours later, and I've only used 15% battery life with scaling at 600 and the vdd2 setting set. I think thats pretty good, only 3% per hour.
  7. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #307  
    Quote Originally Posted by DNic View Post
    I get 500000 for both. I double checked the file I created in event.d and it seems correct.

    Edit: I deleted the file and typed it in and now it shows 600000 for both. Weird.
    Weird indeed...

    Quote Originally Posted by Elysian893 View Post
    So, over 5 hours later, and I've only used 15% battery life with scaling at 600 and the vdd2 setting set. I think thats pretty good, only 3% per hour.
    You must be just idling...

    BTW, battery life is definitely MUCH better in better reception areas. I wish we could adjust the polling frequency... I bet that's eating up juice when reception is low.
  8. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #308  
    so let me get this straight, if i enable smartflex, my phone will not scale but run on 600mhz? Also, i will have to delete the cpu-scaling "sticky" script from /etc/event.d since ondemand doesn't work with smartflex?
  9. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #309  
    Quote Originally Posted by as4life View Post
    so let me get this straight, if i enable smartflex, my phone will not scale but run on 600mhz? Also, i will have to delete the cpu-scaling "sticky" script from /etc/event.d since ondemand doesn't work with smartflex?
    You are correct on all counts.
  10. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #310  
    Quote Originally Posted by as4life View Post
    so let me get this straight, if i enable smartflex, my phone will not scale but run on 600mhz? Also, i will have to delete the cpu-scaling "sticky" script from /etc/event.d since ondemand doesn't work with smartflex?
    Quote Originally Posted by VitViper View Post
    You are correct on all counts.
    I'm kinda new to this but how does smartflex save battery life if its always running on 600mhz compared to ondemand scaling?
  11. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #311  
    Quote Originally Posted by as4life View Post
    I'm kinda new to this but how does smartflex save battery life if its always running on 600mhz compared to ondemand scaling?
    It scales voltages. Lower voltages == lower battery consumption == cooler device.
  12. as4life's Avatar
    Posts
    577 Posts
    Global Posts
    733 Global Posts
    #312  
    Quote Originally Posted by VitViper View Post
    It scales voltages. Lower voltages == lower battery consumption == cooler device.
    sold! i guess it doesn't hurt to try. Thanks!
  13. VitViper's Avatar
    Posts
    83 Posts
    Global Posts
    102 Global Posts
    #313  
    Quote Originally Posted by as4life View Post
    sold! i guess it doesn't hurt to try. Thanks!
    Best way to try this out is to leave the script out... Just run the commands as root to enable 600mhz and smartflex. So if the phone does crash, the next boot up things go back to normal. Once you're happy with the results, put it in a script.
  14. #314  
    I wonder if the best approach to using smartflex would be to have an app for it, just to enable or disable, and change the freq 600-550, etc.

    Seems like it would be the best option, other than doing it through SSH, and avoids making it enabled on bootup.

    How hard would this be?

    edit: looks like the "app" would have a pre-requisite of the webosinternals services, like in this thread: Tweak: Turn on LED when text message is received

    (can't link in posts yet)
    Last edited by hmagoo; 07/07/2009 at 11:24 PM.
  15. #315  
    How do I know that the SmartReflex is actually running?

    My results from:
    Code:
    cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
    Show:
    Code:
    600000 985769
    550000 763
    500000 172
    250000 0
    125000 0
    Which shows that it's now running consistently at 600MHz but how can I be sure that SmartReflex is enabled? Is it a service of Linux or what? I am not familiar with what this technology is; or understanding how what I did enabled/installed it.
  16. #316  
    PS:.. put in the script to run smartflex locked at 600. Runs perfectly but I've found a few things that get hinked up on my end...

    I tried to take a few pics on the camera tonight; app works great but every so often it would freeze while in the camera mode... so if i moved the phone, it would be stuck on the same screen for say 7 seconds, then unfreeze. Same when i took the pic and wanted to upload to facebook...

    I loaded the photos app FROM camera, and when I went to shuffle through some of the photos I just took, it froze on a picture, and I had to wait like 20 seconds before it Unfroze and I could use the phone again...

    Weird...

    Any body else have any problems yet?
  17. wprater's Avatar
    Posts
    240 Posts
    Global Posts
    251 Global Posts
    #317  
    Im running 1.0.4 and using SmartFlex plus overclock to 600.

    I noticed the script mentions the bug in /etc/miniboot.sh , the bug referenced is not called out there, but rather /etc/init.d/bootmisc.sh

    Code:
    #
    # Set default cpufreq (BUG: need to set twice!)
    #
    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
    echo 500000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
    So I modified my event.d smartflex script to set the CPU to 500 then 600, incase the values needed to be different when setting it twice, like the example above.
  18. #318  
    Do you happen to get the same thing with your camera app open, just open it up and keep moving your pre around the room, mine will freeze up within 2 minutes... stay frozen for 5-10 seconds, then unfreeze...

    Its enough for me to not like smartflex until everythings worked out...
  19. wprater's Avatar
    Posts
    240 Posts
    Global Posts
    251 Global Posts
    #319  
    Quote Originally Posted by scizzy View Post
    Do you happen to get the same thing with your camera app open, just open it up and keep moving your pre around the room, mine will freeze up within 2 minutes... stay frozen for 5-10 seconds, then unfreeze...

    Its enough for me to not like smartflex until everythings worked out...
    not sure, i'd never have my camera app open that long.. :-p

    Why don't you try to keep smartflex on, but don't overclock? Set the CPU to 500000
  20. #320  
    Ill try that, then step it up to 550... thanks for the tip...

Posting Permissions