Page 11 of 22 FirstFirst ... 67891011121314151621 ... LastLast
Results 201 to 220 of 433
  1. #201  
    now it is 2.5 hours batter is about 85%. Let me look for yours and streaming again.

    I did not see it switching much under 500


    root@castle:
    600000 0
    550000 313231
    500000 246
    250000 0
    125000 0
    "Who really needs to multitask on their phone." - PRE-rock
  2. #202  
    So 550 with smarflex seems to do the magic!

    Very nice, keep up the good work.....


    I have asked this before, and will ask it again....

    Can anyone make a video comparison of how fast it runs, with smartflex on at 550, compared to the regular......


    Thank you
  3. #203  
    2an Pandora for about 36 min batery went from 89 to 79.
  4. #204  
    Quote Originally Posted by huytrang90 View Post
    2an Pandora for about 36 min batery went from 89 to 79.
    So virtually on par with my first Pre with no scaling or voltage regulation, just as suspected. CPU scaling really helps with Pandora, until it crashes
  5. #205  
    I'm trying the smartflex @ 550. If it's on par with stock, then so be it. I find myself on the fence w.r.t. the BSoD under cpu scaling. When it happens to me, it really bothers me. But then again, not having battery isn't nice either.

    So I'm willing to try it.
  6. #206  
    Quote Originally Posted by mu7efcer View Post
    I'm trying the smartflex @ 550. If it's on par with stock, then so be it. I find myself on the fence w.r.t. the BSoD under cpu scaling. When it happens to me, it really bothers me. But then again, not having battery isn't nice either.

    So I'm willing to try it.
    I've found my phone completely useable with scaling@600mhz besides Pandora, and I don't need Pandora at work, since I have all of my music on my work PC, and just put it on shuffle using the Zune software, so I'm pretty sure for now I'm just going to stick with 600+scaling. 550+smartreflex wasn't any faster or slower than 600 scaled, and I need the battery life, I'm not always near a charger.
  7. #207  
    I'm in the same boat as Elysian, I just use my phone for non-multimedia about 95% of the time. I also have a iPod Nano with 18 hours of battery so I would use that over my phone.

    Unfortunately, this isn't the perfect set up but the benefit of extra battery more than makes up for the occasional hard reset when traveling and may be hard to come by a outlet for long periods.
  8. #208  
    I did not see much different compare with befor applying smartflex. However_ stats show that it is running at 550 now. So I'm going to keep it for now then after couple days I can try to push it higher if it works out.

    The app switching is a bit more responsive but I have no way to scientifically verify it.

    More info:It seems to stay fix at 550.
    Last edited by huytrang90; 06/26/2009 at 09:43 PM.
  9. rmxdave's Avatar
    Posts
    87 Posts
    Global Posts
    88 Global Posts
    #209  
    So who's been testing the 550 Smartflex for a few days now? I haven't even rooted my Pre yet but I would if the smartflex improves speed and/or saves battery. Any crashes yet?
  10. #210  
    I have major issues. The pre dev wiki instructions don't work for me. Any of the commands (checking available speeds, set frequency max, turn on scaling) give me a 'does not exist' return. Anyone know what to do? I've run as root in developer mode, and as a privaledged user in ssh and still no luck... I REALLY want to try this! Any suggestions welcome.
  11. #211  
    My phone has been stable all weekend, scaling@600. loving the battery life too.
  12. #212  
    Specifically (from post 210) ANY command involving cpufreq# gives me a does not exist error... any ideas folks?
  13. #213  
    Hi there... Im wondering what exactly I need to do within putty to make a new file in
    /etc/event.d/cpu-scaling

    such as this one from the wiki

    # Enables cpu scaling

    start on stopped finish
    stop on runlevel [!2]

    console none

    script
    echo "600000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo "30" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    end script

    ---------------------------------------------


    .... Im wondering what the easiest way to accomplish this is..?

    I enabled scaling using the ondemand governer and root@castle:/sys/devices/system/cpu/cpu0/cpufreq# echo 600000 > ./scaling_max_freq
    ...to limit my pre to 600 mhz max

    Im just looking to be able to lock it in for after resets and all... Thanks for your time, and sorry about the long PM..
    I am using Putty currently

    Zachary


    BTW.. This was supposed to be a PM to Elysian893 however I cant send PMs yet. Thanks again!
  14. #214  
    Quote Originally Posted by SMKOUT333 View Post
    Hi there... Im wondering what exactly I need to do within putty to make a new file in
    /etc/event.d/cpu-scaling

    such as this one from the wiki

    # Enables cpu scaling

    start on stopped finish
    stop on runlevel [!2]

    console none

    script
    echo "600000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo "30" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    end script

    ---------------------------------------------


    .... Im wondering what the easiest way to accomplish this is..?

    I enabled scaling using the ondemand governer and root@castle:/sys/devices/system/cpu/cpu0/cpufreq# echo 600000 > ./scaling_max_freq
    ...to limit my pre to 600 mhz max

    Im just looking to be able to lock it in for after resets and all... Thanks for your time, and sorry about the long PM..
    I am using Putty currently

    Zachary


    BTW.. This was supposed to be a PM to Elysian893 however I cant send PMs yet. Thanks again!
    Assuming you did the optware wiki, install nano using this command:

    /opt/bin/ipkg-opt install nano

    It'll install to /opt/bin/ so your next step is this, while either logged in as root, or a superuser

    /opt/bin/nano /etc/event.d/cpu-scaling

    Put all that stuff into the file, and press Ctrl-O to write out the file, and you're done, reboot your phone and try it out.
  15. rposa's Avatar
    Posts
    264 Posts
    Global Posts
    266 Global Posts
    #215  
    I had this on my phone for 2 days. Saturday morning I did it - didn't charge it all day Saturday (minimal usage) no charge Sat night, used sparingly Sunday and still had 60%.

    Last night (Sunday night) I rebooted it before I put it on the charger (touchstone). Turned the light off (nightlight mode). This AM it was blazing hot (well, pretty darn warm) to the touch, backlight only on, took a battery out to reset. Battery was mostly dead despite being on the stone.

    Got up, undid the hack, rebooted, put it on USB charge and it's been fine. But whoa. Not recommended!
  16. #216  
    Quote Originally Posted by rposa View Post
    I had this on my phone for 2 days. Saturday morning I did it - didn't charge it all day Saturday (minimal usage) no charge Sat night, used sparingly Sunday and still had 60%.

    Last night (Sunday night) I rebooted it before I put it on the charger (touchstone). Turned the light off (nightlight mode). This AM it was blazing hot (well, pretty darn warm) to the touch, backlight only on, took a battery out to reset. Battery was mostly dead despite being on the stone.

    Got up, undid the hack, rebooted, put it on USB charge and it's been fine. But whoa. Not recommended!
    You're not the first to have issues with it with the Touchstone. I tried a Touchstone yesterday with no issue though.

    I'm glad to find that with the 1.0.4 update, it didn't mess with the cpu-scaling file in /etc/event.d. I wonder if they did anything that might make cpu-scaling work better, thatd be nice...
  17. #217  
    I am now getting a file cant be found error for everything even the scaling the bin/sh :blah blah file cant be found... Also can you let me know how to delete my script I made so I can make it again. Am I doing something wrong as root now. I am in Telnet with USB and Developer mode On currently and I have done all the optware steps...

    When I open up putty and type in : /sys/devices/system/cpu/cpu0/cpufreq# echo ondemand > ./scaling_governor
    I get a cannot be found error...
    when I type in : /sys/devices/system/cpu/cpu0/cpufreq# echo 600000 > ./scaling_max_freq
    I get the same thing as well... Any help is appreciated.. I apologize for being new to linux and asking so many questions. Thanks again for your time.
  18. #218  
    Quote Originally Posted by SMKOUT333 View Post
    I am now getting a file cant be found error for everything even the scaling the bin/sh :blah blah file cant be found... Also can you let me know how to delete my script I made so I can make it again. Am I doing something wrong as root now. I am in Telnet with USB and Developer mode On currently and I have done all the optware steps...

    When I open up putty and type in : /sys/devices/system/cpu/cpu0/cpufreq# echo ondemand > ./scaling_governor
    I get a cannot be found error...
    when I type in : /sys/devices/system/cpu/cpu0/cpufreq# echo 600000 > ./scaling_max_freq
    I get the same thing as well... Any help is appreciated.. I apologize for being new to linux and asking so many questions. Thanks again for your time.
    You shouldn't be typing all that in, you should be changing to the directory that the wiki shows, which is

    /sys/devices/system/cpu/cpu0/cpufreq/
    /sys/devices/system/cpu/cpu0/cpufreq/ondemand/
    /sys/devices/system/cpu/cpu0/cpufreq/stats/

    Alternatively, instead of messing with that, just make the cpu-scaling file in /etc/event.d/, and copy and paste the end of the wiki into it. Then you can cd /sys/devices/system/cpu/cpu0/cpufreq/stats/ and type "more time_in_state" minus the quotes, and see that its in the proper frequency. Try not to make it harder than it needs to be.
  19. #219  
    I got scaling enabled, I can check how much is being used and when via Cat, however I cant get it to stick after a reboot still? I made the file cpu-scaling, apparently I made a few somehow .saves or something they called themselves... :S how can I delete them using putty? or is there another easier way to make it stick...sorry for all the questions.. I think I am starting to get the hang of it.. Ive already noticed better battery life Not horribly increased performance though, but it seems a tiny bit snappier at times Thanks again, you've been a huge help!
  20. #220  
    OK. I can't make cpu-scaling stick upon reboot. I'm doing everything I need to, to establish cpu-scaling, and it's testing out as working, before I go further.

    Then per your directions, I return to my root directory, and

    cd /etc/event.d

    1) mount -o remount,rw / (I tried this as both ...rw/ and ...rw / to see if it made any difference)

    2) cd /etc/event.d (mount -o remount,rw / actually returns me to "/etc/event.d"

    3) vi cpu-scaling

    paste this code into the file:

    Code:
    # Enables cpu scaling
    
    start on stopped finish
    stop on runlevel [!2]
    
    console none
    
    respawn
    
    script
        echo "500000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
        echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    end script
    4) reboot the device and the cpu scaling settings should be set.

    NOTE: there is no way command to "save" after pasting the code block. So I just turned off my phone and turned it back on again.

    What am I missing?

    Thanks!

Posting Permissions