Page 1 of 3 123 LastLast
Results 1 to 20 of 58
  1.    #1  
    Hey everyone! I got home from a party last night and decided to root my Palm at 2AM. By 6 AM, I finally figured it all out and made some of the changes people found. Got WinSCP to work as well! This site and all the people in the community rock

    I'm currently trying to do the graphical shell to access SSH from the Pre's browser. I'm following instructions from the wiki.

    Kinda stuck on a part and hoping someone could point me in the right direction.

    On step 5 where I have to generate a certificate, it's saying not found. What am I missing? I extracted WebShell and I looked inside and see a make_certificate.cfg and make_certificate.sh.

    I have sudo enabled.

    Thanks in advance!
  2. #2  
    try adding the .sh ./make_certificate.sh

    of course I don't have it working yet, I get an error when I try to go to the page.

    I ran into a lot of problems trying to get that part, finally this ended up working for me, and this is what I got

    sudo ./make_certificate

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    Password:
  3.    #3  
    Gah, it's no use. I tried adding the .sh and now I get:

    -sh: ./make_certificate.sh: Permission Denied

    If I do sudo ./make_certificate, I get command not found. HEADACHE! I know I set the root to rw, so that can't be the problem. There's a greater power at work and I need to overcom it!
  4. #4  
    I'm getting the same issue with this... not sure what I'm missing.


    however... the README.TXT says this.... are we missing somthing...

    OpenSSL < is this installed?
    PyopenSSL < how about this?

    Installation

    It is very easy to set up WebShell.

    First, you need to make sure python 2.3 or later and OpenSSL are
    installed on your system. You will also have to install the
    pyOpenSSL python extensions to OpenSSL.

    Next, you need to generate a server certificate. From the WebShell
    directory enter this command to quickly generate a certificate:

    ./make_certificate.sh

    Now issue this command to run the server:

    ./webshell.py

    To make sure that everything went well, go to this URL in your
    browser:

    https://127.0.0.1:8022
  5.    #5  
    Hmm, the wiki didn't say "read the readme.txt". LOL

    I have Python installed, but not PyopenSSL or OpenSSL. I'll give those a shot and try again.
  6. #6  
    Ok I got it!

    I went into the file and looked around...

    Code:
    root@castle:/opt/share/webshell# cat ./make_certificate.sh
    #! /bin/sh
    umask 077
    openssl req  -config "make_certificate.cfg" -keyout "webshell.pem" -newkey rsa:1024 -nodes -x509 -days 365 -out "webshell.pem"
    I then copied this text and pasted it... it ran..
    Code:
    openssl req  -config "make_certificate.cfg" -keyout "webshell.pem" -newkey rsa:1024 -nodes -x509 -days 365 -out "webshell.pem"
    Code:
    root@castle:/opt/share/webshell# openssl req  -config "make_certificate.cfg" -ke
    yout "webshell.pem" -newkey rsa:1024 -nodes -x509 -days 365 -out "webshell.pem"
    Generating a 1024 bit RSA private key
    ....................++++++
    .......................++++++
    writing new private key to 'webshell.pem'
    -----
    root@castle:/opt/share/webshell# ls
    README.txt            make_certificate.sh   webshell.py
    make_certificate.cfg  webshell.pem          www
    I then copied the file to the internal storage

    Code:
    root@castle:/opt/share/webshell# cp webshell.pem /media/internal

    I then went into my Pre via the GUI and went into

    Device Info
    More info
    Tap the prefrences option at the top
    Certificate Manager
    select Webshell.pem
    select Trust Certificate!
    Reboot
    Boom! your done.
  7. Kaerey's Avatar
    Posts
    539 Posts
    Global Posts
    540 Global Posts
    #7  
    Quote Originally Posted by i700plus View Post

    I then went into my Pre via the GUI and went into

    Device Info
    More info
    Tap the prefrences option at the top
    Certificate Manager
    select Webshell.pem
    select Trust Certificate!
    Reboot
    Boom! your done.
    I didn't even do this step and it works just fine.
    8MB Visor --> Treo 300 --> Treo 650 --> Treo 800w --> Palm Pre
    All devices obtained within first week of launch
  8. #8  
    Quote Originally Posted by Kimleng View Post
    Hmm, the wiki didn't say "read the readme.txt". LOL

    I have Python installed, but not PyopenSSL or OpenSSL. I'll give those a shot and try again.
    I think openssl was already installed. You dont need Pyopenssl if you do --ssl-disable so you can skip the make certificate part.
  9. #9  
    Quote Originally Posted by i700plus View Post
    I'm getting the same issue with this... not sure what I'm missing.


    however... the README.TXT says this.... are we missing somthing...

    OpenSSL < is this installed?
    PyopenSSL < how about this?

    Installation

    It is very easy to set up WebShell.

    First, you need to make sure python 2.3 or later and OpenSSL are
    installed on your system. You will also have to install the
    pyOpenSSL python extensions to OpenSSL.

    Next, you need to generate a server certificate. From the WebShell
    directory enter this command to quickly generate a certificate:

    ./make_certificate.sh

    Now issue this command to run the server:

    ./webshell.py

    To make sure that everything went well, go to this URL in your
    browser:

    https://127.0.0.1:8022
    That will only work if your ssh port is 22. Also, you will have to restart it once you reboot.
  10. #10  
    for some reason I keep getting dissconected at a screen that says.

    "host 'localhost' is not in the trusted hosts file"

    any ideas?
  11.    #11  
    Running into the same problem. It asks me if I wanna continue, and I hit yes. Then I get disconnected because my key couldn't be validated.
    pkill LunaSysMgr
    That's quickly becoming my most used command. lol
  12. #12  
    Quote Originally Posted by i700plus View Post
    for some reason I keep getting dissconected at a screen that says.

    "host 'localhost' is not in the trusted hosts file"

    any ideas?
    Try sshing into your pre from your computer.
    Then,
    ssh -p 222 localhost
    type in y or yes(whichever it asks)

    Post what it says.
  13.    #13  
    OK, here's my error:

    /opt/bin/ssh: connection to me@localhost:222 exited: Didn't validate host key
    I'm guessing this is related to the certificate part.
  14. #14  
    root@castle:/opt/bin# ssh -p 222 localhost
    root@localhost's password:


    mine keeps prompting me for roots password... i never set one up other than my user. leaving it blank doesn't work and using my password doesn't work.
  15. #15  
    Quote Originally Posted by i700plus View Post
    root@castle:/opt/bin# ssh -p 222 localhost
    root@localhost's password:


    mine keeps prompting me for roots password... i never set one up other than my user. leaving it blank doesn't work and using my password doesn't work.
    You cant ssh in as root. use your normal user name.
  16. #16  
    Quote Originally Posted by Kimleng View Post
    OK, here's my error:



    I'm guessing this is related to the certificate part.
    give me the ssh command you used. include the prompt please.
  17. #17  
    Here is my output

    Code:
    i700plus@castle:/opt/bin$ ./ssh -p 222 localhost
    
    Host 'localhost' is not in the trusted hosts file.
    (fingerprint md5 f2:f2:d0:7e:b7:6f:23:79:b8:3a:2d:75:57:67:20:dc)
    Do you want to continue connecting? (y/n) y
    i700plus@localhost's password:
    i700plus@castle:~$
  18.    #18  
    Nevermind. I got in. I copied the webshell.pem to the root and reloaded and it somehow did the trick. Sweet!!!!!! Fully operational!

    Last edited by Kimleng; 06/15/2009 at 02:11 PM. Reason: Added a pic
  19. #19  
    Quote Originally Posted by i700plus View Post
    Here is my output

    Code:
    i700plus@castle:/opt/bin$ ./ssh -p 222 localhost
    
    Host 'localhost' is not in the trusted hosts file.
    (fingerprint md5 f2:f2:d0:7e:b7:6f:23:79:b8:3a:2d:75:57:67:20:dc)
    Do you want to continue connecting? (y/n) y
    i700plus@localhost's password:
    i700plus@castle:~$
    So that means it worked. Now try the webshell again.
  20. #20  
    Same here! Thanks a ton!
Page 1 of 3 123 LastLast

Posting Permissions