Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 58
  1. #21  
    now who wants to make it look nice on the pre
  2. #22  
    I'm having a small issue though, my Pre wants to capitalize the first letter of everything i type in the console.... any way to disable that?
  3.    #23  
    Now to make the background a non-OS X Jaguar background.
  4. #24  
    Quote Originally Posted by i700plus View Post
    I'm having a small issue though, my Pre wants to capitalize the first letter of everything i type in the console.... any way to disable that?
    you can use the onscreen keyboard. i just use backspace, it dont bother me enough to want to change it.
  5.    #25  
    Quote Originally Posted by i700plus View Post
    I'm having a small issue though, my Pre wants to capitalize the first letter of everything i type in the console.... any way to disable that?
    lol yeah it's kind of annoying. I have to keep backspacing the first letter to make it lowercase. There isn't an option to change this, yet.
  6.    #26  


    I like my terminal windows with a solid color. So there's a background I used if anyone wants it. The background.jpg file is in this location:

    root@castle:/var/home/root# cd /opt/share/webshell/www
    Just replace it via SFTP or move the file to the Pre via USB and copy it from /media/internal to that location.

    Clear browser cache and reboot device when finished.

    I don't like how the page renders when it's in portrait mode. There's some crap half way down the screen. I suspect that that's due to the CSS/HTML. I'm gonna go through and see if I can fix that to make it look better on the Pre.
  7. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #27  
    wonder what the heck i'm doing wrong here. i get the panther background, then when i try to type it shows a big black box in the middle and "Disconnected" in white text. I tried running through the wiki steps exactly and then added the certificate as mentioned in this thread..
    http://phwelo.mobi
    for any questions or to send a donation: phwelo@gmail.com
  8.    #28  
    Quote Originally Posted by phwelo View Post
    wonder what the heck i'm doing wrong here. i get the panther background, then when i try to type it shows a big black box in the middle and "Disconnected" in white text. I tried running through the wiki steps exactly and then added the certificate as mentioned in this thread..
    Welcome to my pains of yesterday

    Something could be wrong in your start up script. Can you paste that?
  9. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #29  
    Quote Originally Posted by Kimleng View Post
    Welcome to my pains of yesterday

    Something could be wrong in your start up script. Can you paste that?
    by that do you mean /etc/event.d/webos-webshell ? if so:

    start on stopped finish
    stop on runlevel [!2]

    console none

    respawn

    exec /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l
    http://phwelo.mobi
    for any questions or to send a donation: phwelo@gmail.com
  10. #30  
    did you follow the tutorial?
    did you reboot?
  11. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #31  
    i rebooted a second time and now i'm getting this:

    http://phwelo.mobi
    for any questions or to send a donation: phwelo@gmail.com
  12. #32  
    exec /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l

    Wheres the rest of the command?
  13. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #33  
    start on stopped finish
    stop on runlevel [!2]

    console none

    respawn

    exec /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l $phwelo localhost" --ssl-disable


    ^^^
    Actually i did have that, just being stupid with copy/paste when i posted it the first time. i followed the tutorial word for word earlier today, and then after the update i deleted /etc/event.d/webos-webshell as well as the /opt/share/webshell directory and attempted to start over.
    http://phwelo.mobi
    for any questions or to send a donation: phwelo@gmail.com
  14. #34  
    exec /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l phwelo localhost" --ssl-disable

    is the correct line
  15.    #35  
    Quote Originally Posted by whoiswhois View Post
    exec /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l phwelo localhost" --ssl-disable

    is the correct line
    Yeah, I figured out that the wiki had a typo there and didn't include the space, so I just threw it in there. Looks like the wiki has been updated. Newcomers shouldn't be confused by it now.
  16. #36  
    i dont think you need a space
  17. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #37  
    hm after adding that space it seems like it can't get to the page at http://127.0.0.1:8022 at all.. :\
    http://phwelo.mobi
    for any questions or to send a donation: phwelo@gmail.com
  18. #38  
    did you type in the exact line i gave you?
    exec /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l phwelo localhost" --ssl-disable
  19. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #39  
    Quote Originally Posted by whoiswhois View Post
    did you type in the exact line i gave you?
    exec /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l phwelo localhost" --ssl-disable
    yeah i actually copied and pasted - could you recommend how i would start the process over to try to "start fresh" as it were?
    http://phwelo.mobi
    for any questions or to send a donation: phwelo@gmail.com
  20. #40  
    Run this command on your pre:
    /opt/bin/python /opt/share/webshell/webshell.py -c "/opt/bin/ssh -p 222 -l phwelo localhost" --ssl-disable

    See if that prints any errors
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions