Page 5 of 17 FirstFirst 1234567891015 ... LastLast
Results 81 to 100 of 325
  1. #81  
    Quote Originally Posted by Sonic-NKT View Post
    not even novaterm? Thats HARDCORE!!!
    Nothing. I've downloaded the debiansmall from webos internals, then with WinRar I've unrared directly to the pre (using it as an usb drive).

    Then I've made all the things on the instructions and this last steps with your help. thanks

    I'm having just one problem:

    With notepad i've created gameboy.sh, sended it to usbdrive /media/internal and then to /media/cf using Terminal app.

    When i manually type:
    export SDL_VIDEODRIVER="directfb"
    export SDL_NOMOUSE=1
    sdlgnuboy --scale=2 --density=2 --bind q quit --bind u +up --bind h +left --bind k +right --bind j +down YOURROMFILE.GB

    All is working. But when I try to ./gameboy rom.gbc

    export ROM=$1
    export SDL_VIDEODRIVER="directfb"
    export SDL_NOMOUSE=1
    sdlgnuboy --scale=2 --density=2 --bind q quit --bind u +up --bind h +left --bind k +right --bind j +down $ROM

    I get this error:
    not a valid identifierort
    SDL: Could't initialze SDL: No available video driver
    Signal11


    Any clue?
    Last edited by glorifiedg; 12/03/2009 at 01:06 PM.
  2. #82  
    try putting
    #!/bin/sh
    at the beginning of the "gameboy" script
  3. #83  
    Anyone know if there is a volume option?
  4. #84  
    you would have to set the volume for the debian system, but i dont know if this is possible and if it is i dont know how


    PS:
    i almost perfected my scripts now for the gnuboy...
    i only have to type in the terminal app "gnuboy rom.gb" and it starts the desired game.
    if i have time on the weekend i will write a detailed tutorial
  5. #85  
    Quote Originally Posted by Sonic-NKT View Post
    try putting at the beginning of the "gameboy" script
    #!/bin/sh
    export ROM=$1
    export SDL_VIDEODRIVER="directfb"
    export SDL_NOMOUSE=1
    sdlgnuboy --scale=2 --density=2 --bind q quit --bind u +up --bind h +left --bind k +right --bind j +down $ROM

    It gives the error: sh: ./gameboy.sh : /bin/sh^M: bad interpreter: No such file or directory

    I opened the .sh in vi and the odd thing is that in the final of each line there is ^M
    :S
  6. #86  
    try using another editor or edit the file in vi... remove all ^M
  7. #87  
    Quote Originally Posted by Sonic-NKT View Post
    try using another editor or edit the file in vi... remove all ^M
    Used nano and the ^M don't apear anymore. Still getting the same errors. :S
  8. jonsdad's Avatar
    Posts
    98 Posts
    Global Posts
    109 Global Posts
    #88  
    Quote Originally Posted by Tag234 View Post
    nm! i solved my own issue by adding a save directory and now it auto loads the saves.

    If anyones looking:do mkdir save in your debian chroot, then add --savedir=/save/ to the startup command of sdlgnuboy...

    As far as starting the game goes:
    bind a,b,start and select with:

    --bind X +a
    --bind X +b
    --bind X +start
    --bind X +select

    Replace X with whatever pre key you would like to use, my current setup is

    W is up, A is left, S is down, D is right, K is B, L is A, G is start, H is select

    EDIT: This saving problem was probably caused by the fact that i put my 'gameboy' script in /usr/local/bin of my debian chroot. This allows you to just type 'gameboy ROMNAME' to run the script instead of ./gameboy....
    I still can't start the game. Select seems to work since it toggles the 1/2 player(s).

    Any other suggestions?

    Another thing. The bottom half of the screen is messed up.

    UPDATE:

    The mortal combat works. Perhaps, it's the ROM for the Mario and Yoshi.
    Last edited by jonsdad; 12/03/2009 at 03:01 PM.
  9. #89  
    Bottom half is the screen is like that because it is scaling it to resolution of Gameboy. .

    Also just an FYI for everyone if you include the --sound=0 option it will turn off the sound so you can play more inconspicously. .
  10. #90  
    Quote Originally Posted by glorifiedg View Post
    Used nano and the ^M don't apear anymore. Still getting the same errors. :S
    Ive had that ^M error for other scripts, all you have to do is open that script in vi and hover over the ^M and press x. Itll get rid of em OR (this is what i did because i got this error with files on my desktop) open with gedit or notepad and goto the beginning of a line, backspace til it blends the top and bottom and then seperate the lines again.... Got rid of the character for me
  11. #91  
    Quote Originally Posted by jonsdad View Post
    I still can't start the game. Select seems to work since it toggles the 1/2 player(s).

    Any other suggestions?

    Another thing. The bottom half of the screen is messed up.
    Try a different game, Ive had issues with certain games so maybe Mortal Kombat isnt supported?
  12. #92  
    Quote Originally Posted by Tag234 View Post
    Ive had that ^M error for other scripts, all you have to do is open that script in vi and hover over the ^M and press x. Itll get rid of em OR (this is what i did because i got this error with files on my desktop) open with gedit or notepad and goto the beginning of a line, backspace til it blends the top and bottom and then seperate the lines again.... Got rid of the character for me
    It worked! Thanks.

    Moving to Nes emulator now.

    Im getting an error on apt-get, perhaps some server is down?
  13. #93  
    Hmm... With some further testing I noticed that the color on my Pre aren't the same as the original.

    I this video we're watching Pokemon yellow right? In that pikachu image that circles on his face appears as blue on my Pre.

    This isnt normal right?
  14. #94  
    Quote Originally Posted by glorifiedg View Post
    Hmm... With some further testing I noticed that the color on my Pre aren't the same as the original.

    I this video we're watching Pokemon yellow right? In that pikachu image that circles on his face appears as blue on my Pre.

    This isnt normal right?
    Did you change the pixelformat= line in the directfbrc file.
    I believe the DirectFB setup has the format set as pixelformat=ARGB
    and needs to be changed to pixelformat=RGB16 according to gnuboy Wiki for correct color reproduction..
  15. #95  
    Perfect my friend! Thanks again.
  16. #96  
    Does some one knows if there is a gameboy advanced emulator for debian that we could try to run this way?
  17. #97  
    VisualBoyAdvance, perhaps?
  18. #98  
    visualboyadvance supports directFB with the same SDL_VIDEODRIVER... im going to try and see if i can get this working...
  19. #99  
    Quote Originally Posted by Tag234 View Post
    visualboyadvance supports directFB with the same SDL_VIDEODRIVER... im going to try and see if i can get this working...
    That would be nice!
  20. #100  
    success!! Visualboyadvance works but it runs very slowly... Give it a shot for yourself:

    get into debian chroot
    apt-get install visualboyadvance
    vi /etc/VisualBoyAdvance.cfg

    Scroll down and change the setting so its a GBA emulator, Change Save directory if youd like...

    Use the GNUboy launch script but modify the actual line that started sdlgnuboy to:

    vba $ROM

    Im gonna keep playing with it and see if i cant get it to run quicker, right now its so slow that its unplayable...

    EDIT: btw this caused my phone to crash upon starting a game but it did seem to have sound and displayed colors correctly. My phone got to the game menu and i didnt have or know how to setup buttons so i couldnt get in but the orangekey seemed to freeze my phone and required a hard reset.
Page 5 of 17 FirstFirst 1234567891015 ... LastLast

Posting Permissions