Page 10 of 20 FirstFirst ... 56789101112131415 ... LastLast
Results 181 to 200 of 388
  1. #181  
    How it works is the program either calls the script with the "on" or "off" parameter. That script won't work as it doesn't take those Parameters. The original script assumes that you have an usbnet link up and you have either A) gave your machine and static ip with the correct settings or B) turned on DHCP on the phone to configure your computer.
  2. #182  
    one other thing I would check, just incase permissions didn't carry over. Restore the original tether.sh script and then run:

    chmod 755 /usr/palm/applications/com.microbolt.app.tether/app/scripts/tether.sh
  3. #183  
    Quote Originally Posted by microbolt View Post
    How it works is the program either calls the script with the "on" or "off" parameter. That script won't work as it doesn't take those Parameters. The original script assumes that you have an usbnet link up and you have either A) gave your machine and static ip with the correct settings or B) turned on DHCP on the phone to configure your computer.
    when i manually run the script i was using my usbnet works fine so all the settings must be correct. looking at your script it does the same thing as the one i was using so i didnt even replace it. im giong to try to see if the permissions are correct that might be it
  4. #184  
    that did it

    chmod 755 /usr/palm/applications/com.microbolt.app.tether/app/scripts/tether.sh

    (so i shouldnt have to run that command anymore even after i restart?)

    you guys rock
  5. #185  
    Quote Originally Posted by jack87 View Post
    when i manually run the script i was using my usbnet works fine so all the settings must be correct. looking at your script it does the same thing as the one i was using so i didnt even replace it. im giong to try to see if the permissions are correct that might be it
    Actually I think I just figured out what was going on with you. Did you install the flashlight app located at:
    my flashlight [requires-rooting]

    This app needs it as I am using his service to execute commands from within the gui. Probably all you need to do is install it and the tether app will start working.
  6. #186  
    Quote Originally Posted by jack87 View Post
    that did it

    chmod 755 /usr/palm/applications/com.microbolt.app.tether/app/scripts/tether.sh

    (so i shouldnt have to run that command anymore even after i restart?)

    you guys rock
    Nope the chmod you will only have to run once
  7. #187  
    Quote Originally Posted by microbolt View Post
    Actually I think I just figured out what was going on with you. Did you install the flashlight app located at:
    forums.precentral.net/homebrew-apps/187407-my-flashlight-requires-rooting.html

    This app needs it as I am using his service to execute commands from within the gui. Probably all you need to do is install it and the tether app will start working.
    ya ive had that installed.. haha i kept on asking in the thread for someone to help write a program using the flashlight app as a templete i would but i didnt know where to start. haha as soon as i saw you had done it.. it was perfect.

    um it feels good just hitting an on off switch for tethering rather then running the commands manually.

    maybe the permissions weren't set in place because i installed it via winscp copy and paste. never did run the chmod command. i just wasnt paying enough attention to your first post.
  8. #188  
    microbolt here is a question for you. is there anyway to make a script that will automaticaly set up the pre into a wifi access point. i have not done anything with wifi tethering yet. or would i have to do some of the steps for wifi tethering first then run jhoff's app
  9. #189  
    when i use jhoff's app with your script i had no luck there either i did run

    chmod 755 /usr/palm/applications/com.app.tether/app/scripts/tether.sh

    in case permissions werent set but still nothing is it because his doesnt use the pregame stuff from the flashlight app
  10. #190  
    If you replace the tether.sh with jhoff's script it will create and Adhoc network with the ssid "PreNet" automatically. Tomorrow I'll add an option for "Enable Adhoc" into this app. So that you can do it either way without modifying scripts.
  11. #191  
    Quote Originally Posted by jack87 View Post
    when i use jhoff's app with your script i had no luck there either i did run

    chmod 755 /usr/palm/applications/com.app.tether/app/scripts/tether.sh

    in case permissions werent set but still nothing is it because his doesnt use the pregame stuff from the flashlight app
    What does it say when you try to run the script manually?

    /usr/palm/applications/com.microbolt.app.tether/app/scripts/tether.sh on
    (On an side note too you left out part of the path. Not sure if thats why its not working for you)
  12. #192  
    Quote Originally Posted by microbolt View Post
    What does it say when you try to run the script manually?



    (On an side note too you left out part of the path. Not sure if thats why its not working for you)
    well your script with your app works great. but your script with his app does not work at all. hum i wonder if i could make a app by just renaming some directories and put his script in it.

    update:
    so i tried just redoing your app and changing the name and putting his tether.sh script but had no luck at all i changed the app name to com.wfi.app.tether) i went into every file and changed everything that was microbolt to wifi. is there something i might be missing? hum also what would be the way to enable permissions for that app? i tried... ( chmod 755 /usr/palm/applications/com.wifi.app.tether/app/scripts/tether.sh )
  13. #193  
    To clarify, mine uses the org.webosinternals.shell service, not the flashlight app service. I did it this way because I already have org.webosinternals.commander to give me a terminal, and I don't want to have another extra service such as the one from the flashlight app running.

    (And from what I understand, the prelease service from the flashlight app evolved into the org.webosinternals.shell anyway).

    I've updated the post with the link to have a guide as well:

    http://forums.precentral.net/showthread.php?p=1715453


    Sounds like it's because of both the fact you don't have org.webosinternals.shell installed, and you have the app installed to /usr/palm/applications when all third-party applications go to /var/usr/palm/applications.
  14. #194  
    Quote Originally Posted by jhoff80 View Post
    To clarify, mine uses the org.webosinternals.shell service, not the flashlight app service. I did it this way because I already have org.webosinternals.commander to give me a terminal, and I don't want to have another extra service such as the one from the flashlight app running.

    (And from what I understand, the prelease service from the flashlight app evolved into the org.webosinternals.shell anyway).

    I've updated the post with the link to have a guide as well:

    http://forums.precentral.net/showthread.php?p=1715453


    Sounds like it's because of both the fact you don't have org.webosinternals.shell installed, and you have the app installed to /usr/palm/applications when all third-party applications go to /var/usr/palm/applications.
    HUMM maybe the directory matters but using the other app in the ust/palm/ directory i seems to be working.. i basicly took his app and put your script in it.. in theory i guess it should work but its not. anyway time to go out drinking haha perhaps tomorrow i will install the webshell (which i have done before but stopps working after reboot worth a shot again) then isntall your app and i guess that will do the trick thanks guys
  15. #195  
    Quote Originally Posted by jhoff80 View Post
    To clarify, mine uses the org.webosinternals.shell service, not the flashlight app service. I did it this way because I already have org.webosinternals.commander to give me a terminal, and I don't want to have another extra service such as the one from the flashlight app running.

    (And from what I understand, the prelease service from the flashlight app evolved into the org.webosinternals.shell anyway).

    I've updated the post with the link to have a guide as well:

    http://forums.precentral.net/showthread.php?p=1715453


    Sounds like it's because of both the fact you don't have org.webosinternals.shell installed, and you have the app installed to /usr/palm/applications when all third-party applications go to /var/usr/palm/applications.
    Wow, I didn't even see that post. And the worst part is it was right above mine. I spent all this time reinventing the wheel, lol. I didn't post that app trying to replace yours. I had completely missed it. I removed mine since there is already an solution out there
  16. #196  
    Quote Originally Posted by jack87 View Post
    HUMM maybe the directory matters but using the other app in the ust/palm/ directory i seems to be working.. i basicly took his app and put your script in it.. in theory i guess it should work but its not. anyway time to go out drinking haha perhaps tomorrow i will install the webshell (which i have done before but stopps working after reboot worth a shot again) then isntall your app and i guess that will do the trick thanks guys
    The newest version of the shell auto starts on a reboot.

    As for the directory mattering with mine, yes it does because the switch on calls the app by the full directory, so if it's not in /var/usr/palm/applications/com.app.tether/app/scripts it never finds it and never executes it. Besides that, as a matter of convention third-party apps just need to go in /var/ , not the least reason being so that they can be deletable.
  17. #197  
    Quote Originally Posted by microbolt View Post
    Wow, I didn't even see that post. And the worst part is it was right above mine. I spent all this time reinventing the wheel, lol. I didn't post that app trying to replace yours. I had completely missed it. I removed mine since there is already an solution out there
    No big deal, the more solutions the better. I'm not the best coder anyway, I sort of just patched it together by looking at the flashlight app and the commander app, so yours might work better anyway.
  18. #198  
    For the record as soon as I downloaded jhoff's app within 20sec microbolts app was posted. I had better luck with microbolts app but jhoff just explained to me why I had issues with his... Myfault user error also didn't know bout the webshell app working now . So tomorrow I will see what happens fyi for usb net microbolts's app works like a charm
  19. peazley's Avatar
    Posts
    5 Posts
    Global Posts
    10 Global Posts
    #199  
    in reply to jhoff80's app.

    Has anyone gotten USBnet to work with OSX 10.5? I have the program installed... Just cannot see it on my mac
  20. #200  
    Theres already two tether apps?

    Almost ready, just need to get a good path for the tether.sh script.
    Attached Images Attached Images
Page 10 of 20 FirstFirst ... 56789101112131415 ... LastLast

Posting Permissions