Results 1 to 16 of 16
  1.    #1  
    In attempt to figure out what is wrong with the YouTube app on webOS, I went searching to find files, and I saw something interesting. I remembered that Yahoo and Google both changed over from SHA1 to SHA256. I went into com.palm.youtube/jsjsjs/$crypto$ $and$ $found$ $a$ $js$ $file$ $called$ $SHA1$ $which$ $is$ $no$ $longer$ $in$ $use$ $by$ $Google$. $Could$ $the$ $fact$ $that$ $the$ $Youtube$ $app$ $is$ $attempting$ $to$ $pull$ $SHA1$ $intead$ $of$ $SHA256$ $be$ $the$ $problem$? $I$ $have$ $very$ $little$ $knowledge$ $of$ $SHA$, $so$ $I$ $have$ $no$ $idea$ $how$ $to$ $fix$ $it$, $just$ $reporting$ $what$ $I$ $see$.
  2. #2  
    what problem are you having with the you tube app?
  3. #3  
    The original youtube app don't work anymore. Search turns up zero results. So like using just type launch and search youtube is useless now. That's my experience anyway.
  4.    #4  
    Quote Originally Posted by laingman View Post
    The original youtube app don't work anymore. Search turns up zero results. So like using just type launch and search youtube is useless now. That's my experience anyway.
    I know it's all broken, but would there be a way to fix it?
    Tungsten E, Palm T|X, Treo 700p, Pixi, Pre Plus, Pre 2, HP TouchPad 16GB, LG G2, Samsung Gear 2 Neo, LG G Flex2 Volcano Red, Samsung Gear Live, LG Smart TV 32LF595B
  5. #5  
    Quote Originally Posted by Andrew Hunt View Post
    I know it's all broken, but would there be a way to fix it?
    Well the website one like in 2.4 works good. So just bookmark that and add to launcher. Maybe there is a way to add that as a launch and search option manually. What version webos you using?

    Edit: I haven't used 2.4 in a while so I am not sure what problems exist with that version
    Last edited by laingman; 03/03/2015 at 08:03 PM.
  6.    #6  
    Quote Originally Posted by laingman View Post
    Well the website one like in 2.4 works good. So just bookmark that and add to launcher. Maybe there is a way to add that as a launch and search option manually. What version webos you using?

    Edit: I haven't used 2.4 in a while so I am not sure what problems exist with that version
    I've got webOS 1.4.5.1, 2.1.x, and 3.0.5 which never had an actual YouTube app. I really want to try and make the old app usable. Have I bitten off more than I can chew? lol
    Tungsten E, Palm T|X, Treo 700p, Pixi, Pre Plus, Pre 2, HP TouchPad 16GB, LG G2, Samsung Gear 2 Neo, LG G Flex2 Volcano Red, Samsung Gear Live, LG Smart TV 32LF595B
  7. #7  
    It sort of works, but often requires multiple requests to play anything. I opened the app (which just opens the browser to youtube), searched and played back. Tapping the result opens the actual player. I took 4 tries to get it playing (2.2.4).
    [Patch] webOS 2: Fix low YouTube quality
    Perhaps you can look at what the patch is doing and improve it?
    The certificate idea is interesting, but doesn't explain why videos will usually play if you are persistent. I assumed it was a clunky way to find the best resolution. Could it be a secure connection downgrade to get to playback?
    Last edited by Preemptive; 03/03/2015 at 10:03 PM.
  8. #8  
    I have no youtube playback or quality problems with 2.1 using this bookmark: https://m.youtube.com/?use_blazer=1&tsp=1 which is what 2.4 uses I think

    Only the app itself can't search
    Last edited by laingman; 03/03/2015 at 09:32 PM.
  9.    #9  
    I'm talking about the actual youtube app found on webOS 1.x and 2.0 and 2.1. The browser works fine.
    Tungsten E, Palm T|X, Treo 700p, Pixi, Pre Plus, Pre 2, HP TouchPad 16GB, LG G2, Samsung Gear 2 Neo, LG G Flex2 Volcano Red, Samsung Gear Live, LG Smart TV 32LF595B
  10. #10  
    Quote Originally Posted by Andrew Hunt View Post
    I'm talking about the actual youtube app found on webOS 1.x and 2.0 and 2.1. The browser works fine.
    Yeah. No one has ever attempted to fix it as far as I know
  11. #11  
    http://pivotce.com/2013/10/03/tip-yo...-webos-1-x2-x/

    -- Sent from my Palm Pre3 using Forums
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  12. #12  
    I applied those changes to the old Palm youtube app and pulled it off the device and repacakged it. After removing the system version with ipkg remove com.palm.app.youtube you can install the app. works pretty well
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  13. #13  
    I just tried with my YouTube2 version (for pre3) and search still works with JustType and in app.

    Docs for patching and extracting from old webOSDoctors can be found in the install folder of ProjectMacaw (/media/cryptofs/apps/usr/palm/applications/net.minego.phnx/misc/)

    If you do that for Pre3 then you can change the preference setting in ProjectMacaw to use that YouTube2 app instead of the standard YouTube app when clicking on links.

    Baldric
    Ps. Use/install at your own risk. No support given

    -- Sent from my Palm Pre3 using Forums
  14. #14  
    Did not know there was work on the search issue. I recall installing a patch long ago but gave up because something else went wrong. I'll take another look soon. Thanks to all the des of course
  15. #15  
    Quote Originally Posted by Alan Morford View Post
    I applied those changes to the old Palm youtube app and pulled it off the device and repacakged it. After removing the system version with ipkg remove com.palm.app.youtube you can install the app. works pretty well
    How is the playback? Multiple attempts? Or works every time? I'm on 2.2.4 so I assume I have the browser link type. There's no Just Type option.
  16.    #16  
    I got the patch working only on my Pre Plus.
    Tungsten E, Palm T|X, Treo 700p, Pixi, Pre Plus, Pre 2, HP TouchPad 16GB, LG G2, Samsung Gear 2 Neo, LG G Flex2 Volcano Red, Samsung Gear Live, LG Smart TV 32LF595B

Similar Threads

  1. How can i disable auto load youtube page into youtube app on veer[2.2.4]
    By silentwind in forum Open webOS General Discussion
    Replies: 0
    Last Post: 03/03/2012, 11:55 AM
  2. YouTube - Unable to Signin into Youtube App
    By SDTRI619 in forum webOS Apps & Games
    Replies: 2
    Last Post: 09/17/2010, 11:41 AM
  3. youtube not searching certain words (the youtube app)
    By balla2g2 in forum webOS Apps & Games
    Replies: 3
    Last Post: 07/08/2010, 09:10 PM
  4. Replies: 1
    Last Post: 12/22/2009, 02:27 PM
  5. YouTube Solution Found (at the risk of redundancy)
    By volwrath in forum Palm Windows Mobile Devices & Apps
    Replies: 0
    Last Post: 05/27/2007, 08:32 AM

Posting Permissions