Page 1 of 4 1234 LastLast
Results 1 to 20 of 68
Like Tree27Likes
  1.    #1  
    Just tried to sign in to Facebook from my Pre3 and got a "401" error with a message about development mode.

    Checking my profile via a browser, there's nothing odd there - except that I'm sure I used to have a Facebook for WebOS app authorised on Facebook. I can't seem to find it any more.

    Is my mind playing tricks, or has the back-end of the WebOS Facebook app. been withdrawn as part of the big HP shutdown ?
    Psion 3a, 3c, 3mx, Handspring Visor Deluxe, Treo 180, Treo 600, Centro, Pre, Touchpad, Pre3, Blackberry Passport (sorry!)
  2. vgg
    vgg is offline
    vgg's Avatar
    Posts
    83 Posts
    #2  
    Quote Originally Posted by marshalla99 View Post
    Just tried to sign in to Facebook from my Pre3 and got a "401" error with a message about development mode.

    Checking my profile via a browser, there's nothing odd there - except that I'm sure I used to have a Facebook for WebOS app authorised on Facebook. I can't seem to find it any more.

    Is my mind playing tricks, or has the back-end of the WebOS Facebook app. been withdrawn as part of the big HP shutdown ?
    Same problem here - I've just spent the weekend activating my brothers new pre3 and restoring from his old pre3, and I thought I know what would be a good idea, I'll spring clean my current pre3. Everything when fine until I tried to log in to my facebook account and I get the same error message. I can log in to facebook via m.facebook.com on the phone but the app won't let me log in either. My brothers pre2 facebook app is still working however. A visit to the facebook support page and all they have is help for android or iphones....
    Could be an API change at facebook which is not allowing our outdated app to register with the site perhaps. I believe a similar occurance in 2012 according to a quick scan of the forums...
  3. #3  
    Original thread here: Facebook account login is broken
  4.    #4  
    Quote Originally Posted by Remy X View Post
    Original thread here: Facebook account login is broken
    Not quite the same - that's about SSLV3 - my query is about the "Facebook for HP WebOS" app that I think used to be present on Facebook. If Facebook/HP have removed it, no SSL-related fixes will improve the situation.

    Searching on here suggests my memory is not playing tricks, and that a similar problem was seen in November 2012 - but cleared up shortly thereafter : Facebook Connectivity Issues (Connection Problem, Only App Owner Developer Mode)
    Psion 3a, 3c, 3mx, Handspring Visor Deluxe, Treo 180, Treo 600, Centro, Pre, Touchpad, Pre3, Blackberry Passport (sorry!)
  5. #5  
    I think both threads are flip sides of the same coin. The main issue that Facebook has ceased to maintain its webOS app due to the fact that HP has EoL-ed Palm cloud services. Facebook thinks our phones are junk now and will disappear off the face of the earth come Jan 15th.

    The SSL3 downgrade (aka POODLE) attack was likely the last straw, and it's up to us to make a backup of the Facebook app and patch it to use TLS over SSL when interacting with Facebook. It could also be that Facebook revoked the webOS API key if there was one. We'll need to investigate this a little more thoroughly


    Edit: Could it be that i've misunderstood you and there's an online-only web "app" that you used to go to on the Facebook website?
    hayduke7 likes this.
  6.    #6  
    Quote Originally Posted by Remy X View Post
    I think both threads are flip sides of the same coin. The main issue that Facebook has ceased to maintain its webOS app due to the fact that HP has EoL-ed Palm cloud services. Facebook thinks our phones are junk now and will disappear off the face of the earth come Jan 15th.

    The SSL3 downgrade (aka POODLE) attack was likely the last straw, and it's up to us to make a backup of the Facebook app and patch it to use TLS over SSL when interacting with Facebook. It could also be that Facebook revoked the webOS API key if there was one. We'll need to investigate this a little more thoroughly


    Edit: Could it be that i've misunderstood you and there's an online-only web "app" that you used to go to on the Facebook website?
    No online-only web app., just the usual Facebook mobile app. infrastructure which looks, to me, like it needs both the front-end app. on the mobile device and a back-end, at Facebook, to enable communications. This back-end is what is authorised to post through the user's profile.

    It looks like Facebook have removed the Facebook for HP WebOS back-end completely, probably as they retired all the other old back-ends to force the switch to the two new apps. (Facebook and Messenger) on other platforms.

    Since we no longer have any official support from anyone for Facebook, I think it's permanently dead as an app.

    Even if it does come back to life, the Facebook V1 API is due to be retired at the end of April 2015, and that's guaranteed to kill it.
    Last edited by marshalla99; 10/21/2014 at 05:10 PM.
    Psion 3a, 3c, 3mx, Handspring Visor Deluxe, Treo 180, Treo 600, Centro, Pre, Touchpad, Pre3, Blackberry Passport (sorry!)
    Remy X likes this.
  7. #7  
    I've also noticed I can't post photos from the facebook app, but worse than that all the photos I've previously posted are gone! In the mobile uploads album it says '75 photos' but when you click it, it's empty.
    I also don't see the facebook for webos app in the app list. I can understand if facebook removes support for the old app, but removing all the content (which is just standard photos and status updates)?
  8. #8  
    Quote Originally Posted by hangover#WN View Post
    I've also noticed I can't post photos from the facebook app, but worse than that all the photos I've previously posted are gone! In the mobile uploads album it says '75 photos' but when you click it, it's empty.
    I also don't see the facebook for webos app in the app list. I can understand if facebook removes support for the old app, but removing all the content (which is just standard photos and status updates)?
    Sounds like we need to complain about it ASAP. Also, there's a way to download your "facebook archive", that's supposed to still contain deleted stuff, before it's flushed out of the system.

    We need to make a big deal out of this, because taking down photos is simply unacceptable


    Hey, maybe we can make a tech site write about it on a slow day. THEN they'll restore our stuff
    Grabber5.0 and marshalla99 like this.
  9. #9  
    Quote Originally Posted by Remy X View Post
    Sounds like we need to complain about it ASAP. Also, there's a way to download your "facebook archive", that's supposed to still contain deleted stuff, before it's flushed out of the system.

    We need to make a big deal out of this, because taking down photos is simply unacceptable


    Hey, maybe we can make a tech site write about it on a slow day. THEN they'll restore our stuff
    I used facebook "report a problem" form. I suggest others do as well...
  10. #10  
    Quote Originally Posted by hangover#WN View Post
    I used facebook "report a problem" form. I suggest others do as well...
    I reported a problem to Facebook just now.

    (I posted status updates from tents in the Himalayas in 2010, you know; but they're not in my timeline at the moment. This totally sucks!)
  11. #11  
    just reported the problem on facebook too... removing the photos again facebook? isn't it enough that the webos facebook app does not work anymore? is it necessary to remove all evidence of webOS?
    Dell Axim X5 -> Palm Tungsten T -> Palm Tungsten T3 -> Palm Tungsten T -> Palm Treo Pro + MicroSD 4GB -> Palm Pre 2 (Lost it) -> Palm Pixi Plus -> Palm Pre 2 -> HP Veer -> Palm Pre 2 -> HP Pre 3
  12. #12  
    Quote Originally Posted by guilledil View Post
    just reported the problem on facebook too... removing the photos again facebook? isn't it enough that the webos facebook app does not work anymore? is it necessary to remove all evidence of webOS?
    Fortunately they are not actually gone, so when they fix it, they will appear again. This is at least the second if not third time this has happened.
    Remy X likes this.
  13. dianaml's Avatar
    Posts
    49 Posts
    Global Posts
    53 Global Posts
    #13  
    ok so I thought this was just an issue with me installing my old veer profile on a newer veer...now that I'm reading you all are having fb issues too I think its more on fb's side because up until 1 week ago I was able to sign into fb from my treo 680...tried to upgrade to galaxy s5 active but the phone couldn't decide it it wanted me to swipe or hit a button, so returned it... Went back to 680 and couldn't log in fb which it why I decide to take my dads barely used veer ..ugh and still can't log in
  14. #14  
    I thought I was not affected, because when I start the facebook tablet app, I don't get any errors - BUT - when I checked my photos I noticed, that the ones I uploaded with my pre are gone as well.
    The album with the correct number of pics is there, but when I open it, it is empty.
    Nothing important, but annoying.

    UW
    Handspring Visor -> Palm Centro -> HP Pre 3 / HP TP 4G -> amazon fire phone 64GB
  15. #15  
    Please report it to them and ask them to restore the app.
    Remy X likes this.
  16. #16  
    Quote Originally Posted by Grabber5.0 View Post
    Please report it to them and ask them to restore the app.
    Right - done!
    Handspring Visor -> Palm Centro -> HP Pre 3 / HP TP 4G -> amazon fire phone 64GB
  17. #17  
    I found something else more infuriating - you know how we've talked about downloading your data from Facebook? Well guess what - the content is missing from the download too!

    I just submitted a more detailed bug report with screen shots under 3 separate categories to try to get visibility. I should have included a link to this thread and the previous ones I guess.

    I guess I have to report this in multiple places so someone will fix it. I (and many others) have been using the webOS Facebook app for years. I have uploaded many photos and made status updates and comments using the app over the years. The 'Facebook for HP webOS' app has once again mysteriously been removed from Facebook. This has happened several times over the last couple of years. When this happens, the content is suddenly invisible to everyone, including the users that posted it! I know it is still there, because when this happened previously, once the app was restored, the content was visible again. This is also evident when viewing photo albums - one particular album in my profile, titled 'Arkansas 2010' is listed as having 20 photos in it, but when you open it, the page says it is empty. I downloaded all of my Facebook content, and all of these hidden photos are not present in the downloaded data - this is particularly concerning - that means if we try to download our data to protect it, it's not even present in the downloaded files!

    Originally webOS, and the Facebook app, were branded under Palm, I think it was just called Facebook for webOS, and later after HP purchased Palm, the content from the app started being marked with 'Facebook for HP webOS'. The content I uploaded from a Palm-branded phone is not affected, and does not seem to be tagged as having been uploaded by a non-Facebook app. I and the other remaining devoted webOS holdouts, request/politely demand, that you restore the Facebook for HP webOS app and permissions and stop removing it. Our content is being unfairly blocked. Please let us continue to use our preferred Facebook apps (both phone and tablet versions).
    Remy X and HerrSchwarz5 like this.
  18. vgg
    vgg is offline
    vgg's Avatar
    Posts
    83 Posts
    #18  
    Quote Originally Posted by vgg View Post
    Same problem here - I've just spent the weekend activating my brothers new pre3 and restoring from his old pre3, and I thought I know what would be a good idea, I'll spring clean my current pre3. Everything when fine until I tried to log in to my facebook account and I get the same error message. I can log in to facebook via m.facebook.com on the phone but the app won't let me log in either. My brothers pre2 facebook app is still working however. A visit to the facebook support page and all they have is help for android or iphones....
    Could be an API change at facebook which is not allowing our outdated app to register with the site perhaps. I believe a similar occurance in 2012 according to a quick scan of the forums...
    Today I booted up my old pre3 and was able to access the facebook app as I didn't have to log in. Does anypne know what databases etc I should copy over to my new pre3 so that I don't have to log in and therefore use the facebook app on my new phone?

    cheers

    v2
  19.    #19  
    I'm not sure that reporting to Facebook with a request to reinstate will work. Mainly because I think that HP have pulled the app. as part of the preparations to drop us all.
    Psion 3a, 3c, 3mx, Handspring Visor Deluxe, Treo 180, Treo 600, Centro, Pre, Touchpad, Pre3, Blackberry Passport (sorry!)
  20. #20  
    I'm not giving up.

    Since my old content from my webOS 1.x days is still there, I installed the Facebook app onto my old Sprint Pre, and I can't log in - it gives me some kind of account manager error. I tried restoring my save/restore archive from 2012, and it fails to restore, but I don't get any useful errors. Anyone here still using the Facebook app on 1.4.5?
Page 1 of 4 1234 LastLast

Similar Threads

  1. facebook problems
    By Mjclaypool in forum Palm Pre and Pre Plus
    Replies: 24
    Last Post: 08/17/2011, 04:06 AM
  2. Facebook Problems
    By Malkozaine in forum Palm Pre and Pre Plus
    Replies: 0
    Last Post: 07/25/2011, 01:06 PM
  3. 2.1 on VZW Pre+ facebook problems
    By bobmcbobman in forum webOS Discussion Lounge
    Replies: 3
    Last Post: 04/25/2011, 01:28 PM
  4. Facebook app problems.
    By jasonculp in forum webOS Apps & Games
    Replies: 2
    Last Post: 01/14/2011, 01:51 PM
  5. Facebook problems
    By therock86 in forum webOS Synergy and Synchronization
    Replies: 2
    Last Post: 01/12/2010, 02:01 AM

Posting Permissions