Results 1 to 9 of 9
  1.    #1  
    Hi,

    I'm trying to use navit for navigation. I've set the destination and in the menu there's "Stop navigation". But I can't see any route painted on the map. What am I doing wrong?

    Thanks

    /note: I might have limited access to internet and reply with delay during the next days
  2. briest's Avatar
    Posts
    133 Posts
    Global Posts
    134 Global Posts
    #2  
    Maybe Navit is still calculating route? It can take a fair amount of time for longer trips (in some cases, forever or too long to wait :/ ). Also, without fix it will only pretend to navigate.
  3.    #3  
    Quote Originally Posted by briest View Post
    Maybe Navit is still calculating route? It can take a fair amount of time for longer trips (in some cases, forever or too long to wait :/ ). Also, without fix it will only pretend to navigate.
    I have an a-gps fix. How can I check whether it's still calculating. I'm calculating a less than 400 km trip.
  4. #4  
    maybe the "follow car" option is off and its just not centering the display on the current location?

    are the maps installed correctly?
    did it work previously then suddenly stopped or has it always done that for you.
    Touchpad Keyboard Themes - >> Click Me <<
  5.    #5  
    Quote Originally Posted by geekpeter View Post
    maybe the "follow car" option is off and its just not centering the display on the current location?

    are the maps installed correctly?
    did it work previously then suddenly stopped or has it always done that for you.
    A very short route did work... But a longer route (Lublin-Pyrzowice [Poland]) doesn't work at all after a couple of hours
  6. #6  
    maybe your map is just missing the areas needed for the longer route?

    check your map or replace with an update making sure it covers the area you need.

    Navit :: Planet Extractor
    Touchpad Keyboard Themes - >> Click Me <<
  7.    #7  
    Quote Originally Posted by geekpeter View Post
    maybe your map is just missing the areas needed for the longer route?

    check your map or replace with an update making sure it covers the area you need.

    Navit :: Planet Extractor
    I've downloaded the map for whole Poland with the Navit Maps app
  8. #8  
    Quote Originally Posted by marmistrz View Post
    I've downloaded the map for whole Poland with the Navit Maps app
    This can happen when there is a break (discontinuity) in the underlying OSM map. Highway 101 is a major north-south highway that runs through most of California. There was a portion that was under construction in the small city of Santa Rosa for several years. During this time, the OSM map in the area of construction did not show that the rerouted portion of the freeway was open for traffic. As a result, Navit could only find a route up to the point of defect, and then once you got beyond it a new route to your final destination. For whatever reason it could not create a route that ran through the area of the map defect. I think most of the information for OSM here in California comes from the county and city GIS databases and with the recent budget cutbacks, maintaining these was not a high priority. Eventually this glitch got fixed and Navit can once again map routes that involve going through the newly realigned area of 101.

    You will likely find that if you asked Navit to route to an intermediate destination (you will have to find what works by trial and error) that Navit works just fine up to that point and again then again once beyond it. Further, you should be able to route even a multi-hundred kilometer route in seconds (I just had Navit calc an 800 km route and it took 7 seconds on my FrankenPre with no overclocking).

    Unfortunately the only real solution is to have someone with OSM editing rights identify and fix the problem. I looked into doing that and downloaded the OSM editing tools but using them is nontrivial. You might try posting on one of their volunteer forums and see if you can get someone's attention once you can identify where the area of the problem is.

    Best of luck.
  9. #9  
    I absolutely agree with PeterMacSF. Navit on webOS currently doesn't have any display for showing that it is calculating a route, so you must have patience. And yes, it can happen that it gets stuck in the middle of route calculation.If I remember correctly I saw somewhere that this is a known bug.
    But after using it for more than one and a half years I only encountered some 2 or 3 times such behavior.
    I would suggest you calculating a route to a waypoint on the halfway and depending on the outcome, halving further down one or the other route part. If you find the place where something is wrong on the map maybe you can post on some forum on openstreetmap.org, or maybe you can register yourself on the webpage and fix it. There are multiple tools, one of them Potlatch is a Flash based one which is quite usable for small fixes.
    Or you can tell me, and I'll try to fix it (I already have done a few fixes/contributions to OSM).
    This is the power of open source: if you find something bad, you have the possibility to correct it.

Similar Threads

  1. Replies: 28
    Last Post: 10/08/2011, 06:31 PM
  2. Anyone go the Walmart route
    By lilmexx323 in forum Palm Pre and Pre Plus
    Replies: 18
    Last Post: 06/15/2009, 04:00 PM
  3. GPS Softare, remembering route speed and route traveled
    By lacir in forum Palm OS Devices & Apps
    Replies: 11
    Last Post: 04/18/2006, 06:04 PM
  4. GSM on Route 80??
    By misctwo in forum North American Carriers (GSM)
    Replies: 6
    Last Post: 08/16/2004, 11:19 PM
  5. Route Planning??
    By CYMagic in forum Palm OS Devices & Apps
    Replies: 7
    Last Post: 05/13/2000, 06:53 PM

Posting Permissions