webOS Nation Forums >  Stuff for your webOS Device >  webOS Apps & Games > ICloud - the security certificate is not valid for domain
ICloud - the security certificate is not valid for domain
  Reply
 
Thread Tools Display Modes
Old 12/19/2012, 10:01 AM   #1 (permalink)
Member
 
Posts: 57
The email app keeps complaining about iCloud's security certificate, how can I fix it or is it not fixable?

John

-- Sent from my TouchPad using Communities
__________________
Handspring Visor -> Treo 650 -> Centro -> Pre Plus -> Developer Day Pre 2
32Gb Touchpad, 32Gb Touchpad 4G w/ CM10 onboard
Pre 3 waiting in the wings for a good reason to switch
jbates is offline   Reply With Quote
Old 12/19/2012, 04:10 PM   #2 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
Does it give you options on viewing the certificate? They might have switched servers or the certificate might have expired.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 12/19/2012, 04:37 PM   #3 (permalink)
Member
 
Posts: 125
Configure the account with thunderbird. Then export the certificate and put it on your phone. Import cert and you should be fine.
nichtwirklich is offline   Reply With Quote
Old 12/19/2012, 10:22 PM   #4 (permalink)
Member
 
Posts: 315
What server address are you using? It should be imap.mail.me.com for incoming and smtp.mail.me.com for outgoing.
greenoyster is offline   Reply With Quote
Old 12/20/2012, 12:53 PM   #5 (permalink)
Member
 
ArigatoMrTalboto's Avatar
 
Posts: 17
I was seeing this exact same issue intermittently on the Pre 3 that I just got, but have had no problems with iCloud mail on my Pre 2, setup with a separate Synergy profile.

I believe that I had initially setup the iCloud acct on the Pre 3 using the default mail settings, rather than inputting them manually, so I deleted the iCloud acct, and then recreated it with manual settings, using those listed at

iCloud: Mail server information

...and so far I've not had any certificate errors... Give it a try!
ArigatoMrTalboto is offline   Reply With Quote
Old 01/09/2013, 09:30 AM   #6 (permalink)
Member
 
Posts: 57
So I haven't spent much time working out the certificate problem on the Touchpad since I just got a new laptop and it has consumed a lot of my time.

What I did find funny / sad is I tried to set up my iCloud account in the Mail app in OSX 10.8.2 and it would not work as an iCloud account, I had to set it up as an IMAP account and I get a server certificate error there as well. Something about mail.mac.com on the certificate while the new address is mail.me.com.

You would think Apple could get their act together and at least make it work on their systems.
jbates is offline   Reply With Quote
Old 01/09/2013, 11:46 AM   #7 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,136
*.mac.com was what they used before MobileMe. You should probably update the domain to me.com, since .mac is the archaic name for the service.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0