Page 12 of 142 FirstFirst ... 278910111213141516172262112 ... LastLast
Results 221 to 240 of 2831
Like Tree737Likes
  1. #221  
    Quote Originally Posted by SebastianHa View Post
    Interesting finding.

    I just noticed the following: I only tried the app in the emulator when writing my post and there the root partition is mounted rw. On a productive device it normally is mounted ro. Therefore this line should fail and should not have any effect. I tested it on my Touchpad and there the app was not able to create the file. So it should not be a problem on normal devices. But I wonder how this line can solve problems with the Pre3.

    @amoralico did you try it without this line on a pre3? As far as I can see it should have no effect there, too. I think this line just does nothing at all.

    If this is the fact I take everything back about the security issue but the line should still be removed. Sorry for confusing you all.
    he already wrote that the line has no effect and will be removed in the next version.
  2. #222  
    Quote Originally Posted by Loiter View Post
    If it is possible for a future release, maybe the option to send a message with enter?
    I'm used to it from the messaging app.
    Maybe Enter = Send Message, Orange+Enter = New line

    That's how I configured my desktop messenger Miranda.
  3. #223  
    Quote Originally Posted by gizmo21 View Post
    he already wrote that the line has no effect and will be removed in the next version.
    Oh, did not see it, sorry.
  4. #224  
    I just found out the ultimate way to troll your Android friends...

    Open both Whatsapp and GTalk side by side, and enable Advanced Gesture to switch apps.

    When talking to them ALTERNATE BETWEEN THE TWO SYSTEMS, and watch them try to multitask on Android.

    I just tried this on a friend.
    bigdoby, capape, Loiter and 6 others like this.
  5. #225  
    Last night, while having data radios off, and MojoWhatsApp still running, battery was drained from 20% to zero in a couple of hours. Normally, when I shut all data radios off, my battery lasts four times that, because things like e-mail and such, while running, do nothing. Do you think that your app still attempts connections, thus wasting battery?

    Also, I'd like to know what do those little icons mean in the conversations. Message undelivered, delivered, friend online or not? And a final little detail: Could you render text in a bigger font? At least, same size as the regular messaging app.

    All in all, great work!
    Pre 3 on GSM Jazztel: UberKernel, Muffle logging & friends, Mode Switcher, Advanced System Menus & Prefs, and then some more.

    Proudly choosing the loser side since 1982: Commodore VIC-20, C-64, Amiga 1000 & 3000, bPlan Pegasos & MorphOS, Psion Revo, Palm Pre...
  6. #226  
    Quote Originally Posted by jcmarcos View Post
    battery was drained from 20% to zero in a couple of hours. Normally, when I shut all data radios off, my battery lasts four times that
    Same here with a pre3.
  7. #227  
    Quote Originally Posted by jcmarcos View Post
    Last night, while having data radios off, and MojoWhatsApp still running, battery was drained from 20% to zero in a couple of hours. Normally, when I shut all data radios off, my battery lasts four times that, because things like e-mail and such, while running, do nothing. Do you think that your app still attempts connections, thus wasting battery?

    Also, I'd like to know what do those little icons mean in the conversations. Message undelivered, delivered, friend online or not? And a final little detail: Could you render text in a bigger font? At least, same size as the regular messaging app.
    My Battery drains a lot faster, too. With Radios on. So the App seems to be very consuming.

    Icons:
    Green Check Mark: Message Delivered.
    Green Circle w/White Check Mark: Message read.

    online/offline is not (yet?) available for us.

    For the font size, I like it this way. Maybe we can have an option in the preferences for the size? Like Small, Medium, Large?

    Same for the enter-function. I prefer to have a new line function rather than a send on enter. Could be set thru preferences, too.
  8. #228  
    Quote Originally Posted by CH3CK4 View Post
    Same here with a pre3.
    Same here.
    Wanted to ask about his but I guess it's a common 'issue'. I think I'll just use this when I need it and not leave it on permanently, no big deal.
    Was sucked into Palm when I bought the glorious Treo650, somehow subsequent phones didn't live up to expectations.
  9. #229  
    guys this is the first alpha and power drain seems to be known issue:
    http://forums.webosnation.com/webos-...ml#post3353482

    - Due to the fact that is an hybrid app, the plugin has to be associated to a webos 'stage'. So, the only way to run it in background is minimizing as a dashboard stage.
    - Another problem I found is that webos blocks socket connections when device goes slepp after a few minutes. So, you cannot receive or send messages after wake up. To only way to keep awake device all the time is to use Power Manager service, but it really drains battery life. For this reason I added in preferences the possibility of choosing reconnection intervals when app is in backgroud (dashboard).
  10. #230  
    Quote Originally Posted by amoralico View Post
    The link was corrupted. I have updated it.
    https://github.com/amoralico/mojowhatsup/downloads
    Thank you a lot amoralico but it still doesn't work on my pixi plus... :-(
    I did try to install it both from webos quick install and from preware, but I have the same risult: white screen and nothing else.
    I did try to open it again and again or restart the phone, but nothing.
    The only thing I can say (if it is useful) is that when I see the "details" of the ipk installed I see that I have downloaded 1.2 mega (the real size of the program), but the "installed" size is only 1.7kb... I don't know if it means something....

    Now I know that the ipk is developed in webos framework 2.1 so it will NEVER run on a pixi (that has webos 1.4.5).... Hope that someone can do something.... Please help all the pixi users..... :-(

    Thank you amoralico and you all for your great work.
    Last edited by gigiolandia; 09/25/2012 at 05:45 AM.
  11. #231  
    Quote Originally Posted by gizmo21 View Post
    guys this is the first alpha and power drain seems to be known issue
    Sure but... To me it seems it drains more battery when data radios are off, than when they are on (?!). As if the app didn't care about checking connectivity, and entered some kind of vicious loop when it's not available.

    Disclaimer: I could be wrong and, actually, would love being so.
    Pre 3 on GSM Jazztel: UberKernel, Muffle logging & friends, Mode Switcher, Advanced System Menus & Prefs, and then some more.

    Proudly choosing the loser side since 1982: Commodore VIC-20, C-64, Amiga 1000 & 3000, bPlan Pegasos & MorphOS, Psion Revo, Palm Pre...
  12.    #232  
    Quote Originally Posted by jcmarcos View Post
    Last night, while having data radios off, and MojoWhatsApp still running, battery was drained from 20% to zero in a couple of hours. Normally, when I shut all data radios off, my battery lasts four times that, because things like e-mail and such, while running, do nothing. Do you think that your app still attempts connections, thus wasting battery?

    Also, I'd like to know what do those little icons mean in the conversations. Message undelivered, delivered, friend online or not? And a final little detail: Could you render text in a bigger font? At least, same size as the regular messaging app.

    All in all, great work!
    A note about battery drain:
    When app is open (card view) I keep the device awake all the time (due to the blocked socket problem) and this consumes battery faster even when screen is off.
    Reconnection intervals are taken into account only when app is in "background" (dahsboard view).
    So, if you are not going to use the app for a while I recomend to put it in dashboard view with a reconnecting interval set. Notice that if you selected "as items arrive" for background it will consume a lot of battery too due to the same reason I said before.

    Even better if you shut radios off I recomend to exit the app.

    For a next version I will take into account if internet connection is availabe or not. If it is not available the device won't try to reconnect until network is available again. Maybe this solution will increase battery life.
    somline and jcmarcos like this.
  13. #233  
    Think I found a problem on my Pre2: The first day of usage was okay, but now when I flip the MWU task off the screen and the icon at the bottom appears... it seems it doesn't check for messages anymore. Interval is set at 15, tells me no messages. When I hit that icon the App should App, but it doesn't. Instead, the Icon disappears.

    Now I open the App again, and receive instantly messages that have a time stamp back to the point where the App was minimized to the icon.

    Another thing: Sometimes flipping the card off the screen doesn't give me the icon, the App is just away then.
  14. #234  
    Quote Originally Posted by hux View Post
    Think I found a problem on my Pre2: The first day of usage was okay, but now when I flip the MWU task off the screen and the icon at the bottom appears... it seems it doesn't check for messages anymore. Interval is set at 15, tells me no messages. When I hit that icon the App should App, but it doesn't. Instead, the Icon disappears.

    Now I open the App again, and receive instantly messages that have a time stamp back to the point where the App was minimized to the icon.

    Another thing: Sometimes flipping the card off the screen doesn't give me the icon, the App is just away then.
    This happened to me once last night... Any debugging logs needed?
  15. #235  
    Working in Pre- w/ WebOs 2.1

    Thanks !!!
  16. #236  
    Quote Originally Posted by ToniCipriani View Post
    This happened to me once last night... Any debugging logs needed?
    Yup I had this a number of times too on my 2.2.4 Veer... I thought I was going mad, but I guess it's a bug?
  17. #237  
    Do I miss some green light anywhere to see if I'm connected at the moment? Even if I disable my WLAN+Data connection I only see the message that there are no unread messages.
  18. #238  
    Quote Originally Posted by fjmacias View Post
    ¿A que bug con las notificaciones te refieres? lo poco que lo he utilizado por ahora no me ha dado problemas.
    Cuando cierras la aplicación lanzando la carta aparece una notificación de "no hay mensajes nuevos". Si intentas ignorar la con un "swipe" , la notificación desaparece pero la aplicación se abre de nuevo. Las notificaciones deberían aparecer sólo cuando hay mensajes nuevos y deberían poder ignorarse.


    When you close the application throwing the card apears a notification of "no new messages". If you try to ignore swipping it out, the notification disappears but the application is reopened. The notifications should appear only when new messages and should be able to be ignored.
  19.    #239  
    Quote Originally Posted by HelmutsKohl View Post
    Do I miss some green light anywhere to see if I'm connected at the moment? Even if I disable my WLAN+Data connection I only see the message that there are no unread messages.
    Always assume that you are connected, but due to the problem of blocking sockets when the device sleeps, the connection is lost. The problem is that is not possible to know when the operating system blocks the connection. That's because I added reconection intervals.

    It may seem a shoddy solution, but the only one I've found to keep the connection alive.
  20.    #240  
    Quote Originally Posted by amoralico View Post
    Always assume that you are connected, but due to the problem of blocking sockets when the device sleeps, the connection is lost. The problem is that is not possible to know when the operating system blocks the connection. That's because I added reconection intervals.

    It may seem a shoddy solution, but the only one I've found to keep the connection alive.
    Other solution is to keep the device always awake with option "as items arrive", as I said a several times it really drains battery life. I'm opened to any other better solution. May be a Webos expert can iluminate us about this.

Tags for this Thread

Posting Permissions