webOS Nation Forums >  Stuff for your webOS Device >  webOS Apps & Games > Accidentally Deleted My Photo App
Accidentally Deleted My Photo App
  Reply
 
Thread Tools Display Modes
Old 02/08/2012, 02:53 PM   #1 (permalink)
Member
 
Posts: 13
So I managed to delete the native Photos And Video app. How do I get it back?

When I do get the app back, I also have another issue with it....All of my album artwork for music on my TP shows up in the Photos And Video app. There are hundreds of them; So many in fact that it makes finding my "real" photos and photo albums difficult. Is there some way to make it so these music artwork files don't show up in the app?
san76er is offline   Reply With Quote
Old 02/08/2012, 03:22 PM   #2 (permalink)
Homebrew Developer
 
fxspec06's Avatar
 
Posts: 1,663
You have to download the webOS doctor for your device and extract webOS.tar, locate the photos application inside, package it using Jason's IPK packager or other tool, then install using webOS Quick Install.
__________________
Neo Enyo 2.0 Twitter App: NOW AVAILABLE | WON REVIEW
clearview - clear card app for HP TOUCHPAD
Wild'n Video Poker - AVAILABLE FOR ALL WEBOS DEVICES! | follow for latest updates - @fxspec06

fxspec06 is offline   Reply With Quote
Thanked By: san76er
Old 02/08/2012, 03:32 PM   #3 (permalink)
Member
 
Posts: 13
Thanks, I'll give that a try.
san76er is offline   Reply With Quote
Old 02/08/2012, 04:27 PM   #4 (permalink)
Member
 
Posts: 13
Thanks again, the photo app is back now.

Any ideas about the music artwork issue?
san76er is offline   Reply With Quote
Old 02/08/2012, 04:34 PM   #5 (permalink)
 
HelloNNNewman's Avatar
 
Posts: 15,900
Are you running webOS 3.0.5, or an earlier version? 3.0.5 should have fixed many of these artwork issues.... otherwise, check out the following thread:

How to get AlbumArt out of Photo's
__________________



Network Moderator | Mobile Nations Rules
HelloNNNewman is offline   Reply With Quote
Thanked By: san76er
Old 02/08/2012, 04:38 PM   #6 (permalink)
Member
 
Posts: 13
Yes v3.05. Thanks for the link, I'll check it out.
san76er is offline   Reply With Quote
Old 02/08/2012, 04:53 PM   #7 (permalink)
Member
 
Posts: 13
I'm a little confused by that link. Maybe I'm wrong but that seems like it would completely delete the images from the TP right? I don't think I want to delete the images from the TP (I still want the CD artwork to show in the music player while playing songs) I just don't want all of the images to appear in the Photos And Video app because it is cumbersome to have to scroll through all of them.
san76er is offline   Reply With Quote
Old 02/08/2012, 05:06 PM   #8 (permalink)
Editor-in-Chief
 
Derek Kessler's Avatar
 
Posts: 1,799
The images should be embedded in the MP3 files - the artwork as a separate file shouldn't be needed.
__________________
"'Form follows function' that has been misunderstood. Form and function should be one, joined in a spiritual union."
Frank Lloyd Wright
Derek Kessler is offline   Reply With Quote
Thanked By: san76er
Old 02/08/2012, 05:20 PM   #9 (permalink)
 
HelloNNNewman's Avatar
 
Posts: 15,900
I had the issue with 3.0.4 and used the free MP3Tag app to correct the metadata info for my artwork in my .MP3 files. Try it (it's free) and it should fix the issue for you.
__________________



Network Moderator | Mobile Nations Rules
HelloNNNewman is offline   Reply With Quote
Thanked By: san76er
Old 02/08/2012, 05:37 PM   #10 (permalink)
Member
 
Posts: 13
Quote:
Originally Posted by Derek Kessler View Post
The images should be embedded in the MP3 files - the artwork as a separate file shouldn't be needed.
Good point; I forgot about them being embedded in the tags. I followed the process in the link above and deleted all of the images and rebooted. Now they no longer show up in the Photo/Video app and they still appear in the Music Player(remix) app like they should while the songs play. Everything is perfect.
san76er is offline   Reply With Quote
Old 02/08/2012, 05:50 PM   #11 (permalink)
Member
 
Posts: 13
Quote:
Originally Posted by HelloNNNewman View Post
I had the issue with 3.0.4 and used the free MP3Tag app to correct the metadata info for my artwork in my .MP3 files. Try it (it's free) and it should fix the issue for you.
I actually already have the MP3Tag program and have use it quite a bit in the past. It is fantastic. I have tried out several tag editing programs and it was the best free one that I found.

I started using the free program MediaMonkey though awhile back to manage my music and it does everything that I need (edit tag data, embed artwork to mp3, set mp3 volume level, sync playlists to TP). So I rarely use MP3Tag anymore.
san76er is offline   Reply With Quote
Old 02/08/2012, 09:16 PM   #12 (permalink)
Member
 
Posts: 1,588
Quote:
Originally Posted by san76er View Post
So I managed to delete the native Photos And Video app. How do I get it back?

When I do get the app back, I also have another issue with it....All of my album artwork for music on my TP shows up in the Photos And Video app. There are hundreds of them; So many in fact that it makes finding my "real" photos and photo albums difficult. Is there some way to make it so these music artwork files don't show up in the app?
if one has internalz pro, use it to browse to /usr/palm/ipkgs and click on the ipk to reinstall...
John Steffes is offline   Reply With Quote
Old 02/10/2012, 02:47 PM   #13 (permalink)
Member
 
addiarmadar's Avatar
 
Posts: 1,353
Quote:
Originally Posted by san76er View Post
All of my album artwork for music on my TP shows up in the Photos And Video app. There are hundreds of them; So many in fact that it makes finding my "real" photos and photo albums difficult. Is there some way to make it so these music artwork files don't show up in the app?
To eliminate this issue from ever happening please use the HP Play app from Homepage - hpplay.com . use it to sync your tunes rather than drag and drop via the USB drive mode.
__________________
Try diplomacy first. You can always conquer them later...

www.webos-internals.org, read it, use it, love it, and donate to it.....
addiarmadar is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0