Page 2 of 5 FirstFirst 12345 LastLast
Results 21 to 40 of 81
Like Tree9Likes
  1. #21  
    devwithoutpower,
    so I first ran uninstall.sh which completed without errors, then ran install.sh also without any errors but downloading from Blackboard still doesnt work for me. I can open unsecure pdf files; the downloader app opens, connects, and then opens the pdf. However, when trying to access a pdf from Blackboard, the downloader app opens, and then the gray screen ends with:
    {"error" : "script error" }
    after the url of the file.

    I dont know if this makes a difference but I forgot to back up the files when I originally changed them with your first set of instructions. Therefore, maybe the uninstall.sh patch didnt fully revert them back to normal?
  2. #22  
    devwithoutpower,

    so would you be willing to share either the source or the hybrid binary, with someone who would be wanting to include it into their own app, for specific use of downloading from one particular location? or is it not really suitable for that sort of thing?
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  3.    #23  
    Quote Originally Posted by dconeg View Post
    devwithoutpower,
    so I first ran uninstall.sh which completed without errors, then ran install.sh also without any errors but downloading from Blackboard still doesnt work for me. I can open unsecure pdf files; the downloader app opens, connects, and then opens the pdf. However, when trying to access a pdf from Blackboard, the downloader app opens, and then the gray screen ends with:
    {"error" : "script error" }
    after the url of the file.

    I dont know if this makes a difference but I forgot to back up the files when I originally changed them with your first set of instructions. Therefore, maybe the uninstall.sh patch didnt fully revert them back to normal?
    Your installation is ok ... service (Downloader app) is running as expected

    I am afraid you are the victim of last known issue on my list (see 1st post) ... PM with url and login details ... hopefully I can fix this issue (by escaping problematic characters)
  4.    #24  
    Quote Originally Posted by eblade View Post
    devwithoutpower,

    so would you be willing to share either the source or the hybrid binary, with someone who would be wanting to include it into their own app, for specific use of downloading from one particular location? or is it not really suitable for that sort of thing?
    I have better idea (at least I believe) ... let me think about it for day or two and I will get back to you with details ...
  5. #25  
    Still no luck ...but thanks for working on this. It opens on the side in the download bar but doesnt actually download. Awaiting your updated post.
  6.    #26  
    Quote Originally Posted by touchpadmd1203 View Post
    Still no luck ...but thanks for working on this. It opens on the side in the download bar but doesnt actually download. Awaiting your updated post.
    that means incorrect installation...you should try uninstall/install combo again...and eventually posting log from installation here

    I will update archive with improved version soon, but installation script is the same.
    touchpadmd1203 likes this.
  7. #27  
    A few questions after this thread had been pointed out to me:

    *Is this a stand-alone app, or something patched into the browser - meaning, does this take care of errors downloading in my browser automatically, or do I need to open this app in order to do so?

    *In step 2, it says to connect to the device. What exactly does this mean? Is it as simple as plugging it in in USB mode, navigating to the right folder and double-clicking...or do I need to plug it in to my Linux box and run something from the command line? ( know that this was the case, but the OP had been updated and there was talk of a script, so I wanted to double check.)

    Thanks in advance!
    Last edited by W3idbrewer; 12/08/2011 at 09:25 AM.
  8. #28  
    Hey, Just wanted to start by saying thanks for the fantastic work.

    I've installed v0.0.3 of the patch on my Touchpad (08-12-2011) by running the install.sh through xterm. When I attempt to download pdfs from password protected sites, the downloader starts and says it's downloaded the file but it fails to open. Internalz shows the filesize as 651B for every file I've attempted. It seems like somethings going wrong in the download process. Hope this helps, let me know if there's any logging or debugging that can help.
  9. #29  
    Xterm! A-ha! Now I understand. Never used it, but thankfully, it's standard linux commands.

    Got the patch installed and...crap...what I'm trying to DL comes from an ip address, even though it's through a standard URL. (ie: I'm downloading from www.mydomain.com, but it links to my server at xx.xx.xxx.x:xxxx.)

    I know that the OP says that ip addys don't work right now, but I want to make sure that other stuff is going properly: When I DL, a window pops open and says that it is DLing http:// xx.xx.xxx.x:xxxx/get/epub/book%name%here.epub

    Then, curl: saved to file book%name%here.epub.

    Checking internals, my DL folder has that file (and another I tried) there as 1.08KB, and is obviously not an epub. Is this because of the ip addy, or is there something else going on?
  10.    #30  
    Quote Originally Posted by W3idbrewer View Post
    Xterm! A-ha! Now I understand. Never used it, but thankfully, it's standard linux commands.

    Got the patch installed and...crap...what I'm trying to DL comes from an ip address, even though it's through a standard URL. (ie: I'm downloading from www.mydomain.com, but it links to my server at xx.xx.xxx.x:xxxx.)

    I know that the OP says that ip addys don't work right now, but I want to make sure that other stuff is going properly: When I DL, a window pops open and says that it is DLing http:// xx.xx.xxx.x:xxxx/get/epub/book%name%here.epub

    Then, curl: saved to file book%name%here.epub.

    Checking internals, my DL folder has that file (and another I tried) there as 1.08KB, and is obviously not an epub. Is this because of the ip addy, or is there something else going on?
    Most probably yes - it is known issue that only DNS names works at the moment. IP addresses will work in v0.0.4.... (but of course only if cookies are stored under same ip address as content)
  11. #31  
    Quote Originally Posted by devwithoutpower View Post
    Most probably yes - it is known issue that only DNS names works at the moment. IP addresses will work in v0.0.4.... (but of course only if cookies are stored under same ip address as content)
    Okay...wasn't sure, since it actually "downloaded" a holder file.

    As for the cookies: how do I know?
  12.    #32  
    Quote Originally Posted by moshansky View Post
    Hey, Just wanted to start by saying thanks for the fantastic work.

    I've installed v0.0.3 of the patch on my Touchpad (08-12-2011) by running the install.sh through xterm. When I attempt to download pdfs from password protected sites, the downloader starts and says it's downloaded the file but it fails to open. Internalz shows the filesize as 651B for every file I've attempted. It seems like somethings going wrong in the download process. Hope this helps, let me know if there's any logging or debugging that can help.
    Not all sites will work. Only those that stores your credentials in (non-session) cookies ... like for example this forum...

    If there are some public sites that you are trying to download from and it is not working then you can post link here ... and I can haveaa look if there is anything I can do
  13. #33  
    Quote Originally Posted by devwithoutpower View Post
    Most probably yes - it is known issue that only DNS names works at the moment. IP addresses will work in v0.0.4.... (but of course only if cookies are stored under same ip address as content)
    Do you, by chance, have a public example that I can try to make sure everything works?
  14. #34  
    Quote Originally Posted by devwithoutpower View Post
    I have better idea (at least I believe) ... let me think about it for day or two and I will get back to you with details ...
    Sure thing. I'd like to give it a try to use it with some Google services that won't work properly due to needing to download files via https, as well as I could definitely see someone writing clients for this chalkboard site or whatever it is that everyone is having problems with...
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  15.    #35  
    Quote Originally Posted by W3idbrewer View Post
    Do you, by chance, have a public example that I can try to make sure everything works?
    As mentioned in my previous post - THIS FORUM is public example ... uninstall Downloader app - and try to download attachment from this site ... then install app - and compare results
  16. #36  
    devwithoutpower
    Could you make the program prompt the user to enter username and password? If the cookie isn't found. This could solve the problem with some sites.
  17. #37  
    Quote Originally Posted by devwithoutpower View Post
    As mentioned in my previous post - THIS FORUM is public example ... uninstall Downloader app - and try to download attachment from this site ... then install app - and compare results
    yes, the download from here works fine. I just didn't think this qualified as a secure download.
  18. #38  
    Hi,

    perhaps a stupid question but... Is that "patch" linked to the browser or not? I mean, is that possible to apply it to advanced browser and not to the standard browser ?

    Thanks !
  19.    #39  
    Could someone with access to blackboard based pages check if turning on persistent cookies makes the difference?

    Enabling Persistent Cookies

    I have no way to verify this myself...
  20.    #40  
    Quote Originally Posted by W3idbrewer View Post
    Okay...wasn't sure, since it actually "downloaded" a holder file.

    As for the cookies: how do I know?
    v0.0.4 is ready for testing ... please let me know if it works with your 10.10.100.1:1234 server (or whatever you have...)
Page 2 of 5 FirstFirst 12345 LastLast

Posting Permissions