Results 1 to 10 of 10
  1. h2o826's Avatar
    Posts
    100 Posts
    Global Posts
    105 Global Posts
       #1  
    TO MODs: please dont merge this to the 30 page thread yet, i read every page and knowone goes back there. i even tried reposting there.

    I still cannot connect to my pc via the internet away from my lan. I have followed all of the help from splashtop (How do I connect to my home computer from outside by opening ports on the home router? : Splashtop Remote - Support), forwarded my ports on router, allowed the program through firewall, opened additional ports with firewall, internet discovery w/gmail (does nothing), still nothing.

    Did anyone able to get this to work outside of LAN? please let me know, rdp's are worthless if you cant leave your home or office and use it, (besides being lazy in bed).
  2. #2  
    I can't help with the tech part...but I can connect to home (wireless network) and work (network) via gmail. It didn't work...then magically the next day it did. No idea what's different or how you can do it...just that it *is* possible.
  3. #3  
    Quote Originally Posted by h2o826 View Post
    TO MODs: please dont merge this to the 30 page thread yet, i read every page and knowone goes back there. i even tried reposting there.

    I still cannot connect to my pc via the internet away from my lan. I have followed all of the help from splashtop (How do I connect to my home computer from outside by opening ports on the home router? : Splashtop Remote - Support), forwarded my ports on router, allowed the program through firewall, opened additional ports with firewall, internet discovery w/gmail (does nothing), still nothing.

    Did anyone able to get this to work outside of LAN? please let me know, rdp's are worthless if you cant leave your home or office and use it, (besides being lazy in bed).
    I have it working outside of a LAN but I have a Static IP on the PC i'm using. I can attempt to install it to one of my PC's that are actually not having a static PC
    In a world of droid, Pre does it better.

    Shouldn't we treat this world like the Garden of Eden and avoid the apple at all costs?
  4. #4  
    I can't help with the tech part...but I can connect to home (wireless network) and work (network) via gmail. It didn't work...then magically the next day it did. No idea what's different or how you can do it...just that it *is* possible.
    Same here, I got it working through gmail and it's been working fine ever since. I can log in anytime, from anywhere and access my home pc, using my touchpad. In the app, go into preferences at the top left & sign into your gmail profile for internet discovery. That's all there was to it for me. :-)
  5. h2o826's Avatar
    Posts
    100 Posts
    Global Posts
    105 Global Posts
       #5  
    i am logged in on both ends w/ gmail internet discov n it doesnt find it. kerm, major p, and pit, can you guys please tell me your settings?
  6. N2HPZ's Avatar
    Posts
    39 Posts
    Global Posts
    40 Global Posts
    #6  
    Probably an obvious question, but did you try restarting your touchpad? I had it working fine and then yesterday it would not connect. I did a restart and then it worked.

    Also, the email address I use to log in to google was not an @gmail account. I had to enable gmail and use an @gmail account for discovery to work.
  7. tim k's Avatar
    Posts
    18 Posts
    Global Posts
    35 Global Posts
    #7  
    Did you manually configure the port forwarding or let splashtop do it? Splashtop did mine and it wasn't working. I deleted the one set by splashtop and re-entered the settings manually.

    Add ports 6783, 6784, 6785, and make sure you set them to BOTH (not just TCP which is what the default setting was). Also, make sure the IP address of the local machine is not changing....you may want to set that to static so that in the case of a router restart another machine on the network doesn't grab the local IP that splashtop is looking for.

    If the problem is your IP address changes from your provider, you may need to set up a DNS service..... I've used dyndns previously with good results.
  8. #8  
    if the connection is slow or 3g/not valid wifi etc splashtop is by design told not to allow connections incase of huge 3g bills, the .jsjsjs $for$ $this$ $can$ $be$ $edited$ $so$ $it$ $always$ $connects$ $ofc$, $handy$ $if$ $your$ $connections$ $is$ $being$ $confused$ $with$ $3g$.

    you can edit MainView.jsjsjs in splashtops Src folder.

    scroll down till you see the line/comment

    // Don't support 3G because may charge too much

    there are checks in there to see if your WiFi or not, you can probably change?? proper javascript coder can prolly tell (i only know lua and a few other non web stuff) best but im asuming that the line....

    if (inResponse.wifi.state == "connected"){

    could be changed to something like

    if (inResponse.wifi.state ~= ""){

    to allow the connection checks for internet regardless of connection type, 3g or wifi? then possibly just delete the codeblock farther down for....

    if inResponse.wifi.state == "disconnected"){

    as it wouldnt be required anymore, again tho a proper jsjsjs $coder$ $would$ $know$ $far$ $better$ $than$ $my$ $guess$.
    Last edited by geekpeter; 10/04/2011 at 01:55 PM.
  9. #9  
    i am logged in on both ends w/ gmail internet discov n it doesnt find it. kerm, major p, and pit, can you guys please tell me your settings?
    Which settings are you referring to?
  10. h2o826's Avatar
    Posts
    100 Posts
    Global Posts
    105 Global Posts
       #10  
    miraculously just as most of you suggested or hinted, it just randomly worked. When I tried at the schools horrible WiFi @ 640kbps it failed, then when I tried it again right after, it worked, same thing happen at work w/752kbps WiFi, 1st try no good, second initial works. As long as it works, only usable on a real fast WiFi though.

    thanks all for suggestions n help.

Posting Permissions