Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 80
Like Tree4Likes
  1. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #41  
    I can't get pw-protection working. I started with the 2..4 version on my new TP. Starting the app only gives me the unlock popup. Entering a PW changes nothing.
    i wiped all data and even reinstalled the app. But still the same porblem.
    Importing my data worked fine through, but without protection it's a bit risky.
    nevertheless many thanks for this app!
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  2. #42  
    You just need to enter something on this "unlock popup" and then import your data. If you did that, then you'll see a "WRONG PW" message if you try to type nothing/something wrong into that "unlock popup". It's really not that hard...
  3. jft
    jft is offline
    jft's Avatar
    Posts
    17 Posts
    #43  
    Hi,

    yeah I have to update the app description :/ Thanks @Garfonso for helping newcomers.

    As he already mentioned just enter your new password at the first start of the app and then import your data. Everything is encrypted with your provided password and the encrypted data is stored on the device. The password is "set" if you actually have groups/keys. Subsequent starts of the app try to decrypt your data with the provided password.

    You cannot change the password. But you can clear the KeePassW data using its main menu. Now restart the app, enter a new password and reimport your data to use the new password.

    BTW: Here is version 0.2.5 with the ability to show the encrypted user, password. I will submit this version tomorrow.

    Download: https://dev2day.de/typo3/fileadmin/u..._0.2.5_all.ipk
  4. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #44  
    Thanks for your help @Grafonso
    I tried it exactly this way, but I tried to add a key manually first, which didn't (and still doesn't) work for me.
    Nonetheless it now works for me as Grafonso described with version 0.2.5.
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  5. #45  
    Thanks again for the great app, guys! Every new version is closer to perfect.
    I noticed a minor glitch: If I have to scroll to the last key in a group, when I expand it, it expands below the bottom of the screen. I can't drag the Meta Info or Action buttons up to where I can use them, because they just snap back under the bottom of the screen. I can either drag the bottom "|||" thing left to fill the screen with the keys, or tug it a bit to the right, then I'm able to pull the Action buttons up to where I can use them.
  6. #46  
    Hi jft,

    I'm really happy to see this app in the catalog.

    I've started "to play" with it and set a password, but unfortunately I guess I've done a mistake when typping the password.
    Now everytime I receive the message "WRONG PW".
    I've deleted the app, restarted the Touchpad and reinstaled the app, but the database is certainly still there, password required and still the same message.

    How can I completely remove the database ?

    Regards.
  7. jft
    jft is offline
    jft's Avatar
    Posts
    17 Posts
    #47  
    Hi forumschris

    currently the only way so solve your problem is to use novacom (palm-sdk).

    1. Connect to your device

    novacom -t open tty://

    2. Delete KeePassW's db8 kinds from the shell:

    luna-send -n 1 -a de.dev2day.keepassw.app luna://com.palm.db/delKind '{"id":"de.dev2day.keepassw.keys:2"}'

    luna-send -n 1 -a de.dev2day.keepassw.app luna://com.palm.db/delKind '{"id":"de.dev2day.keepassw.groups:1"}'
  8. #48  
    Thank you jft,

    Not an easy way but I will try this evening.

    Is it this SDK https://developer.palm.com/content/r..._download.html ?

    And after that, I will be carrefull when I'll type the new password .
    Last edited by forumschris; 10/10/2011 at 12:00 AM.
  9. jft
    jft is offline
    jft's Avatar
    Posts
    17 Posts
    #49  
    Yeah, that's it. If you have any problems just contact me via jabber/xmpp --> jft@dev2day.de.
  10. #50  
    There should definitvely be a "Cancel" button in the dialog that asks for the key/password. And if you hit cancel you can clean the database from the main menu and nothing else.
  11. #51  
    @jft, thanks for all, that worked perfectly.

    Could you ask a confirmation when the user types the password for the first time ?
    Last edited by forumschris; 10/10/2011 at 11:42 PM.
  12. jft
    jft is offline
    jft's Avatar
    Posts
    17 Posts
    #52  
    @Garfonso and @forumschris: I will see what I can do

    @all: 0.2.5 hit the app catalog.
  13. #53  
    [QUOTE=jft;3202482@all: 0.2.5 hit the app catalog.[/QUOTE]

    jft,
    I just loaded 0.2.5 of your app. The "Show Credentials" button is exactly what I was hoping for. Thank you!
  14. #54  
    I am missing something that must be right in front of me, but I simply cannot get 2.5 to import the xml! Here are the details:

    1. Installed KeePassW 2.5. Was able to enter a test group and key.
    2. Then cleared EVERYTHING and closed app.
    3. Went to my KeePass 2.16 on the PC and selected Export > XML
    4. Connected TP to PC using USB mode.
    5. Transferred the XML file to TempFiles folder I created.
    6. Disconnected USB mode properly (no 'ouch' error messages, LoL)
    7. Opened KeePassW 2.5 and entered Password, then selected Login. No Groups or Keys showing.
    8. Select Import XML. When I selected "Documents" my XML (940KB) file is there.
    9. I select it, but nothing; just sits there up to 4-5 mins. I then close KeePassW.
    10. Deleted KeePassW using Software Manager. Shutdown and rebooted.
    11. Reinstalled KeePassW from the App Catalog.
    12. Restarted at step 7. Same results, no import data showing!

    I have gone through this thread a couple of times, but cannot see anything I am doing wrong!

    Ideas?

    Thanks!

    Ok, solved problem! I had looked through all my KeePass entries and did not see any empty groups or keys. But just decided to go through the cleanup and remove empty groups/keys anyway, and that solved the issue! I am not sure what happened, but it removed over 300KB (file size) of data, but I don't see anything missing or changed. Anyway, problem solved.

    And this really is a great program! Thanks for all the hard work on it!!
    Last edited by Slickums; 10/14/2011 at 07:08 PM. Reason: Solved Problem
  15. #55  
    Doesn't work. When I try to import the XML just nothing happens. No message, no everything. The keepass db still is empty. What is wrong?
  16. #56  
    Quote Originally Posted by dodnet View Post
    Doesn't work. When I try to import the XML just nothing happens. No message, no everything. The keepass db still is empty. What is wrong?
    Any help with this? I would really need my password db on the TP.
  17. #57  
    Hm.. did you leave it just for some moments? For my db it took some time (like a minute or so) to be imported... maybe yours is real huge and will take some time?

    Or maybe have a look at the XML if you find something that may break the import... maybe you can even have a look at the logs of KeepassW while you import the db?
  18. #58  
    Thanks for your work!

    Would it be possible to make KeePassW run with the Palm Pre (webOS 1.4.5)?

    I'm using KeePass for years now and I would like to get it running with my Pre. It installs fine (downloaded and installed it with Preware installer), but unfortunately it doesn't work:
    1. After rebooting I found the app and was able to start it.
    2. Comes up with a page showing "Groups" in the upper left, a menu "New Key", "New Group", "Import XML ...", "Clear Data ..." and nothing else.
    3. Klicking or zooming into the empty space does nothing.
    a) The "New Key"-Menu does nothing.
    b) The "New Group"-Menu asks for the name of the group, takes input and the popup vanishes when I hit "OK", but the new group does not show anywhere.
    c) When I choose "Import XML ..." (the function that I really need) the program seems to try to open a popup, but the light grey box is empty - no matter where I tap or zoom.
    d) The "Clear Data ..."-Menu asks what to clear, but I don't know if it really clears anything.
    I tried to uninstall, reboot and reinstall the program, but with no luck. I also tried to delete KeePassW's db8 kinds from the shell as written in the post from 10/09/2011 07:44 PM, but it failed because luna-send on the Pre does not support "-a"-option.

    Is it possible to make KeePassW work with Palm Pre? I don't need editing, just export on the desktop and import on the Pre would be great! Any more information needed? Or can I do some beta-testing?

    Thanks in advance!
    Leff
  19. #59  
    The Problem is that the import function does just not work on any phone, right now. I tried to fiddle around a bit to fix that, but I found solution... :-(

    If that is fixed, I'm quite sure 1.4.5 will be a no go. Because this uses the keymanager service, and I'm quite sure that the keymanager did not exist in 1.4.5 or at least it was very different back then. So no chance for 1.4.5 unless you do the complete keystore thing on your own, which would be a major rewrite of the app, I guess.

    Did jft look into reading the real keepass file? Is that possible at all?
  20. #60  
    Thanks for your answer! Though it's really sad that I can't use the app with 1.4.5.
    Would it help to update the pre to 2.1.0 as stated in WebOS 2 Upgrade or will I get stuck at some other point then?
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions