webOS Nation Forums >  Stuff for your webOS Device >  webOS Apps & Games > Port forwarding for PlayOn
Port forwarding for PlayOn
  Reply
 
Thread Tools Display Modes
Old 09/05/2011, 04:06 PM   #1 (permalink)
Member
 
j_grouchy's Avatar
 
Posts: 612
Can't get port forwarding to work on my PC for PlayOn. It sounds like it might not work if you have a dynamic IP...is this correct?

My router is a Belkin F5D8235-4 and I put in all the info that PlayOn tells me to use...but it fails the test every time. Anyone out there have a suggestion or am I just SOL?
j_grouchy is offline   Reply With Quote
Old 09/05/2011, 04:22 PM   #2 (permalink)
Member
 
Posts: 298
dynDNs
__________________
Pre 3
HP touchpad
Uberkernel running @ 1.5 Ghz
doctj is offline   Reply With Quote
Old 09/05/2011, 05:04 PM   #3 (permalink)
Member
 
j_grouchy's Avatar
 
Posts: 612
Quote:
Originally Posted by doctj View Post
Okay...I may be getting out of my depth here. What, exactly, is this you've linked me to and what will it do? Will it affect other devices connecting to my router? I need the full rundown in layman's terms...
j_grouchy is offline   Reply With Quote
Old 09/05/2011, 05:42 PM   #4 (permalink)
 
HelloNNNewman's Avatar
 
Posts: 15,810
Um.. yeah, that wasn't too helpful for the question was it. What DynDNS does is allows you to set up an static IP address for your system. In this case, if an app like PlayOn needs to be watching a specific port for traffic from an app, the router could be set up to watch that port for traffic from that specific static IP address.

I've been trying to set the same thing up for a while now and haven't had much (any) luck. To really try troubleshooting I need to be out of the house and logged into my computer remotely to set things up and test while trying to access PlayOn from my TouchPad. Still trying.....
__________________



Network Moderator | Mobile Nations Rules
HelloNNNewman is offline   Reply With Quote
Old 09/05/2011, 06:24 PM   #5 (permalink)
Member
 
Posts: 255
check out "Works on Wifi but not EVDO/3G" at CommonIssues - ampache-mobile - Some pointers for common issues encountered while setting up Ampache - Ampache Client for the webOS Mobile Operation System - Google Project Hosting

Replace the words "Ampache" in the above "how-to" with "PlayOn"
wilderf is offline   Reply With Quote
Old 09/05/2011, 07:22 PM   #6 (permalink)
Member
 
j_grouchy's Avatar
 
Posts: 612
obviously I am missing some very important setting to make this work. I set up the dyndns thing...there was even an input screen on my router settings site that referenced dyndns, so I figured that was all I needed to do. Well, apparently not. Still won't work. I'm getting fed up. Is there another setting I need to change on my router?
j_grouchy is offline   Reply With Quote
Old 09/05/2011, 07:46 PM   #7 (permalink)
Member
 
Posts: 63
The only port needed by playon to forward is port 57331. I don't know about your router, but on mine it's straight forward. Just set external port 57331 to go my playon server's internal address.
thatdude90210 is offline   Reply With Quote
Old 09/05/2011, 07:54 PM   #8 (permalink)
 
HelloNNNewman's Avatar
 
Posts: 15,810
Quote:
Originally Posted by thatdude90210 View Post
The only port needed by playon to forward is port 57331. I don't know about your router, but on mine it's straight forward. Just set external port 57331 to go my playon server's internal address.
I've tried setting it to the playon server's address listed in PlayOn's Mobile Access/Diagnotic Information tab. But it tells me "The specified port(s) are being used by other configurations." Grrrrrrrrr
__________________



Network Moderator | Mobile Nations Rules

Last edited by HelloNNNewman; 09/05/2011 at 08:08 PM.
HelloNNNewman is offline   Reply With Quote
Old 09/05/2011, 09:02 PM   #9 (permalink)
Member
 
Posts: 63
On my router, Netgear 3500L with tomato firmware, the settings are --

Protocol both TCP and UDP
ext port 57331
int port 57331 (not sure this part is necessary but I put it anyway)
Int address my servers address of 192.169.etc

That's all I needed to get it working.

Btw, you can specify a different port in playon's config if that one's being used.
thatdude90210 is offline   Reply With Quote
Old 09/06/2011, 07:56 AM   #10 (permalink)
Member
 
j_grouchy's Avatar
 
Posts: 612
i have two fields to fill out under each port...just like this:



I put 57331 in all four fields...is that wrong? I've tried it in just the first field on each port, just in the second field...a few different ways. Nothing is working.
j_grouchy is offline   Reply With Quote
Old 09/06/2011, 07:56 AM   #11 (permalink)
Member
 
j_grouchy's Avatar
 
Posts: 612
i have two fields to fill out under each port...just like this:



I put 57331 in all four fields...is that wrong? I've tried it in just the first field on each port, just in the second field...a few different ways. Nothing is working.
j_grouchy is offline   Reply With Quote
Old 09/06/2011, 11:36 AM   #12 (permalink)
Member
 
Posts: 63
Try enabling UPnP on the router first, and then setting Playon's mobile access' router setting to automatic (universal plug and play). Then press that little icon under it next to "UPnP router"
thatdude90210 is offline   Reply With Quote
Old 09/06/2011, 12:34 PM   #13 (permalink)
Member
 
Posts: 255
This is from my link above.

Port Forwarding Guides for PlayOn - PortForward.com

It is a "how to" on opening a port for PlayOn. You will need to select your router model and then skip the ad page to get details for your router model.

If your router's external ip address never changes, you will be done. (like http://209.12.54.12)

If it does change, you will need a service like DynDNS to keep track of your external IP
address. (like http://myipaddress.net)

For security, you may want to map the port number used on your PlayOn server on your local network to a different port number on the Internet side of your router. ( ie.. 8056)

Then, to access your PlayOn server from the Internet, you would use http://209.12.54.12:8056 or http://myipaddress.net:8056.

See my link above for more details.

Last edited by wilderf; 09/06/2011 at 12:39 PM.
wilderf is offline   Reply With Quote
Old 09/06/2011, 05:55 PM   #14 (permalink)
Member
 
j_grouchy's Avatar
 
Posts: 612
Quote:
Originally Posted by wilderf View Post
This is from my link above.

Port Forwarding Guides for PlayOn - PortForward.com

It is a "how to" on opening a port for PlayOn. You will need to select your router model and then skip the ad page to get details for your router model.
I already did all that stuff yesterday. I did it all again today. Still doesn't work. If anyone is familiar with my router and its settings...or if there is something else possibly getting in the way of this working, let me know. Everything everyone has told me to try has not worked so far. All this trouble and I wouldn't even be able to use the service outside my home! WE NEED A NETFLIX APP!!!!!
j_grouchy is offline   Reply With Quote
Old 09/06/2011, 08:17 PM   #15 (permalink)
Member
 
Posts: 255
Quote:
Originally Posted by j_grouchy View Post
I already did all that stuff yesterday. I did it all again today. Still doesn't work. If anyone is familiar with my router and its settings...or if there is something else possibly getting in the way of this working, let me know. Everything everyone has told me to try has not worked so far. All this trouble and I wouldn't even be able to use the service outside my home! WE NEED A NETFLIX APP!!!!!
if you have a firewall running on the PlayOn server, turn it off and see if that works.

another test: you may want to install a tiny http server running on port 80 on your PlayOn server and see if you can pass through your router to get to it. (this will test to make sure your router is doing pass through correctly) see http://en.wikipedia.org/wiki/HTTP_File_Server
wilderf is offline   Reply With Quote
Old 09/07/2011, 07:42 AM   #16 (permalink)
Member
 
Posts: 38
Have you rebooted your router since forwarding the port? Unplug it, let it sit for a minute then plug it back in and try.

Is there a playon app I'm missing somewhere?
prim8 is offline   Reply With Quote
Old 09/07/2011, 11:12 AM   #17 (permalink)
Member
 
Posts: 63
No, there's no playon app. You just need to pair your computer/tablet with your playon server by using the url "m.playon.tv" while on your LAN. Once it's pair, when you go outside of your network, it'll work (once you have the ports forwarded correctly).

I have the playon app on android, and it's exactly the same as going to m.playon.tv.
thatdude90210 is offline   Reply With Quote
Thanked By: prim8
Old 09/07/2011, 02:55 PM   #18 (permalink)
Member
 
Posts: 1
Quote:
Originally Posted by j_grouchy View Post
I already did all that stuff yesterday. I did it all again today. Still doesn't work. If anyone is familiar with my router and its settings...or if there is something else possibly getting in the way of this working, let me know. Everything everyone has told me to try has not worked so far. All this trouble and I wouldn't even be able to use the service outside my home! WE NEED A NETFLIX APP!!!!!
Ok first thing I would do is go into your router's settings under DHCP list and reserve your PlayOn PC's IP Address so that it get's the same one every time. Then go into The Firewall section and just disable it for testing purposes. Then go to the internal Forwarding section and manually enter the Port 57331 and set it to forward in both TCP and UDP to the reserved IP address of your PlayOn PC. Also double check that UPNP is enabled which according to your router's manual it comes enabled by default. Also turn off Windows Firewall for testing as that can be a huge pain in the ****. After you do all of this reboot your router and your pc and then reopen the PlayOn Server and click on the Mobile Access section. Now even though you have UpNP enabled uncheck Automatic and choose Manual and use Port 57331 then Apply and then test again. If that doesn't work then maybe see if there is a firmware update for your router version or a support forum at Belkin for that model and port forwarding. Also just incase you don't have it here is a link to your user manual ...... http://cache-www.belkin.com/support/...00736_0708.pdf
mkenny28 is offline   Reply With Quote
Old 09/08/2011, 02:25 PM   #19 (permalink)
 
HelloNNNewman's Avatar
 
Posts: 15,810
Finally got PlayOn working on the TouchPad outside of my home network!

I didn't need to use DynDns like some have said and it will vary by router type. For me (Netgear router) I kept UPnP enabled (which is enabled by default on that router) and then opened the PlayOn app and chose the "Mobile Access" tab. Enable mobile access and set the port number for 57331.

On the router, I turned Port Triggering ON and set it for TCP/UDP and port 57331. For the IP address, I entered the LAN IP address shown in the PlayOn app under Diagnostic Settings (same tab). I also enabled Port forwarding on the router using TCP/UDP setting with the same IP and port number as above.

Then on the PlayOn app (under the same tab) you click on the link marked "LAN Test Page". If everything is correct, the test page that comes up should say "success" and your account should then be linked to PlayOn.

Save those settings and go to m.playon.tv on your TouchPad (be sure not to be on your home wifi network to test it). This was successful for me.
__________________



Network Moderator | Mobile Nations Rules

Last edited by HelloNNNewman; 09/08/2011 at 06:23 PM.
HelloNNNewman is offline   Reply With Quote
Old 09/18/2011, 01:38 PM   #20 (permalink)
Member
 
Posts: 505
Quote:
Originally Posted by HelloNNNewman View Post
Finally got PlayOn working on the TouchPad outside of my home network!

I didn't need to use DynDns like some have said and it will vary by router type. For me (Netgear router) I kept UPnP enabled (which is enabled by default on that router) and then opened the PlayOn app and chose the "Mobile Access" tab. Enable mobile access and set the port number for 57331.

On the router, I turned Port Triggering ON and set it for TCP/UDP and port 57331. For the IP address, I entered the LAN IP address shown in the PlayOn app under Diagnostic Settings (same tab). I also enabled Port forwarding on the router using TCP/UDP setting with the same IP and port number as above.

Then on the PlayOn app (under the same tab) you click on the link marked "LAN Test Page". If everything is correct, the test page that comes up should say "success" and your account should then be linked to PlayOn.

Save those settings and go to m.playon.tv on your TouchPad (be sure not to be on your home wifi network to test it). This was successful for me.
Hi there. Thanks for your help. I got this to work on my touchpad. I didn't need port triggering ON. I just enabled port forwarding. Thanks a lot.

Update: Ok spoke too soon. This works with only port forwarding only if you are on the same wifi network as the playon pc. port triggering on is required for accessing the playon pc from external networks.
__________________
Sent via HP TouchPad using Forums

Last edited by palmpre06062009; 09/18/2011 at 02:12 PM.
palmpre06062009 is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0