Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 41
Like Tree9Likes
  1. pl212's Avatar
    Posts
    29 Posts
    Global Posts
    30 Global Posts
    #21  
    OK, let's start with the most useful feature: the "Go back to article list" button. This will give you the following button at the bottom of each article page:



    1) Upload list.png (attached to this post) to com.nytimes.reader/images/commands/list.png

    2) Modify the beginning (around line 10) of com.nytimes.reader/app/assistants/article-scene-assistant.jsjsjs:

    Code:
    	this.articleToolItems = {items:[
    NEW ->		{iconPath:"images/commands/list.png", command:"goBack"},
    		{iconPath:"images/commands/email.png", command:"send-email"},
    		{iconPath:"images/commands/sms.png", command:"send-sms"},
    		{iconPath:"images/commands/save.png", command:"save-article"}
    	]};
    3) If you have not already made the changes in jdale's post, above (#15), make another change to com.nytimes.reader/app/assistants/article-scene-assistant.jsjsjs $around$ $line$ #$260$ $or$ $so$:

    Code:
    		if(event.type == Mojo.Event.command) {
    			switch (event.command) {
    NEW ->			case "goBack":
    NEW ->				this.controller.stageController.popScene();
    NEW ->				break;
    			case Mojo.Menu.helpCmd:
    				that.controller.stageController.pushScene('support');
    				break;
    Attached Images Attached Images
    Last edited by pl212; 12/03/2011 at 04:04 PM.
  2. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #22  
    Should those lines have the path as

    Code:
    		{iconPath:"images/commands/list.png", command:"goBack"},
    rather than

    Code:
    		{iconPath:"http://forums.precentral.net/images/commands/list.png", command:"goBack"},
    That matches what I have in the original.

    Also, I noticed at some point I lost the ability to tap the pull-down in the top bar to select a category. It's always set to "Latest News". Is that just me?
  3. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #23  
    Oh, I see. PreCentral is cleverly replacing the text "images / commands / " with their own address (I added spaces to keep it from doing the replacement). That probably makes it easier for them to add images, but it is not so helpful here....

    So in the lines to add, omit everything starting with http: so that the path begins with the word "images".

    In other words, in step two add

    Code:
    		{iconPath:" images / commands / list.png", command:"goBack"},
    except leave out all the spaces between the quotes.
  4. pl212's Avatar
    Posts
    29 Posts
    Global Posts
    30 Global Posts
    #24  
    Jesus, what a horrible bug. I've fixed my post, above, by turning off "parse links in text".

    Thanks for finding that!
    Last edited by pl212; 12/03/2011 at 04:04 PM.
  5. pl212's Avatar
    Posts
    29 Posts
    Global Posts
    30 Global Posts
    #25  
    Quote Originally Posted by jdale View Post
    Also, I noticed at some point I lost the ability to tap the pull-down in the top bar to select a category. It's always set to "Latest News". Is that just me?
    I've noticed that menu is wonky, too, but I don't remember if it was always that way. Here's what works for me: tap on the actual words "Latest News", rather than on the rest of the menu to the right. (To be precise, I think it's the first 320 pixels of the menu which is active.)

    I think this is a remnant of the app's origin on the Pre screen.
  6. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #26  
    Ah, I didn't notice it worked way over there. I am sure you are correct, the sensitive part must be the width of the Pre screen.

    I think the bar is set up in list-assistant.jsjsjs $but$ $can$'$t$ $figure$ $out$ $the$ $details$. $Probably$ $not$ $important$ $enough$ $to$ $work$ $on$.
  7. pl212's Avatar
    Posts
    29 Posts
    Global Posts
    30 Global Posts
    #27  
    The fix for this is to edit line #8 in app/views/list/list-scene.html to remove the width argument:

    Code:
    <div id="section_selector" class="truncating-text" x-mojo-element="ListSelector" style="position: relative; top: -35px; width: 300px;z-index: 1;"></div>
    You should end up with:

    Code:
    <div id="section_selector" class="truncating-text" x-mojo-element="ListSelector" style="position: relative; top: -35px;z-index: 1;"></div>
  8. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #28  
    Perfect.
  9. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #29  
    Ok, I went ahead and packaged up all the changes as a patch. Attached to this post.

    To install it using WebOS QuickInstall, click the + button, then select the patch file, then click Install. This will also restart Luna on the Touchpad so you don't have to do that yourself.

    This does not install the list.png image, you still need to get that into the right folder. With WOSQI, just go to Tools/Send File, pick the list.png file, and fill in this as the destination:

    /media/cryptofs/apps/usr/palm/applications/com.nytimes.reader/images/commands/

    then click Send To Device.
    Attached Files Attached Files
    scottegos2 likes this.
  10. #30  
    Patch works wonderfully. Thank you!
  11. #31  
    Quote Originally Posted by jdale View Post
    Ok, I went ahead and packaged up all the changes as a patch. Attached to this post.

    To install it using WebOS QuickInstall, click the + button, then select the patch file, then click Install. This will also restart Luna on the Touchpad so you don't have to do that yourself.

    This does not install the list.png image, you still need to get that into the right folder. With WOSQI, just go to Tools/Send File, pick the list.png file, and fill in this as the destination:

    /media/cryptofs/apps/usr/palm/applications/com.nytimes.reader/images/commands/

    then click Send To Device.
    where do I find the list.png file? Nevermind. Post#21
    Last edited by joedisaster; 12/20/2011 at 09:55 PM.
  12. #32  
    Awesome! I was able to install on-device using Internalz Pro without hooking up WEBOSQI - quick and easy!
  13. #33  
    I used internalz pro also and it worked perfectly. I was ok with the mojo app with the big emu patch, but this shows me what I've been missing. Thank you.
  14. #34  
    Quote Originally Posted by spotter View Post
    can you please not thread crap.

    #1, my personal politics clash with many of the things the NY Times state on a regular basis

    #2, Even with that, I feel its important to read because its important to understand people whose politics differ from yours

    #3, most importantly, it could be a work of fiction, some people would still want the mojo application to work as best as it can on a touchpad.
    so one's opinion another doesn't agree with is crap. good to know. Thanks for the education.
  15. #35  
    Quote Originally Posted by Midway99 View Post
    so one's opinion another doesn't agree with is crap. good to know. Thanks for the education.
    Go troll somewhere else please.

    I can't wait to get home and see how this works. Thanks in advance!
  16. #36  
    Quote Originally Posted by spotter View Post
    Should it be very difficult to write a patch for the ny times app that lets it work in a full screen mode? Figure it just needs a back button, right?

    This would be much more useful than android/iphone apps as this app hasn't been limited by the ny times
    Is there even a version of this for the TP?
  17. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #37  
    Quote Originally Posted by copasetic View Post
    Is there even a version of this for the TP?
    No, that's why we have the patch. The phone version can still be installed on the TP, and the patch makes it a full-screen app on the TP.
  18. #38  
    still works!

    margin control would be great for this app
    Last edited by n0thng2bdone; 02/04/2012 at 02:45 PM.
  19. #39  
    Yes me too. Anyone know what happened to News Republic? I just did a reset and it didn't come back, and it's no longer in the catalog.

    *Cries*
  20. #40  
    Quote Originally Posted by joedisaster View Post
    I used internalz pro also and it worked perfectly. I was ok with the mojo app with the big emu patch, but this shows me what I've been missing. Thank you.
    How does one install the patch using Internals Pro?
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions