Results 1 to 11 of 11
  1. mcnee's Avatar
    Posts
    64 Posts
    Global Posts
    74 Global Posts
       #1  
    Ok, I have three blogs of my own... I admin a few others... so I'm juiced about having a WordPress app for my new TouchPad.

    But so far in my (somewhat limited) trials of it... I'm rather disappointed.

    I'm going to post some of the issues I'm having to see if others are running in to the same or if it's "just me".

    1) When I start a new post, I tap on the title line... keyboard doesn't kick in. I have to tap in to the post body, get the keyboard, then tap back on Title.

    2) I started a post yesterday, saved it as a draft, then went to my desktop and went to my admin panel... I couldn't find the post. I figured I lost it, so started the post again, using the same title... when I save it, I get the "-2" added to my page slug, indicating my original draft is in there ... somewhere... I go back to the TP app, it's there. I trash it. go back to desktop.. it's not in the trash there... I try to rename my current post to get rid of the -2 and it won't let me, leading me to believe that the one I trashed from my TP is still lingering in the database somewhere... but I can't empty the trash from the app, and it is nowhere to be found when viewed from web panel.

    3) No image editing options other than inserting into a post. Can't change the title it uses in the media library, can't change alignment, can't choose size. When you add an image, it is added to your online media library, but no thumbnails or other sizes are generated.

    Other observations:
    Preview doesn't show yo a formatted preview, doesn't do you any good to see if it "fits" in your site design.
    Tapping an image while in edit mode opens it in web browser, not sure what the reason for this would be?

    1 is a minor bug, hopefully an easy fix that will be taken care of.
    3 I suppose I could live with and just use the App for drafting the text of a post, then going to my desktop (or opening the site in a browser card) to do final formatting and such... but..
    2 - because of this there is no way I can use to to even create a draft. and because of 3, I can't use it to publish a post from the app.

    Now, there are some good things about this app, which is why 2 & 3 are so... frustrating.

    Having a single window I can go to to access all my blogs would be killer.
    What seems to becoming a standard, the 3-pane layout, works great. But right now all I can really use this for is a single place to go moderate comments, and kind of sort of check stats... but even that doesn't seem to be reliable. I use Jet Pack, and while it loads the data fine, it doesn't seem to be able to load the bar chart... and after one test I went back and now it doesn't load anything. Even refreshing doesn't help. Even closing the app and reloading it now doesn't seem to be working.

    So yea, I was excited to hear about the WP app before I got my TP, but right now it really does nothing for me I can't do in the browser, and is really, really, crippled.

    I haven't checked the WP forums or anything yet, but will try to do so later today to make sure WP knows of my thoughts at this point.
    Zoomer > Handspring Deluxe > Treo 90 > Zire71 > LifeDrive > Centro > Pre (yes, still!)
    TouchPad
  2. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #2  
    I've never used a blog before I got my TP so, I quite like it. But I am sure you are right.

    Alan
  3. redmist's Avatar
    Posts
    674 Posts
    Global Posts
    679 Global Posts
    #3  
    Yes the draft bug is the reason I dont use it. I thought I'd lost a lot of work.

    it needs work {polite version}
    Pilot 5000 > Pre > Pre2 > Pre3 > Galaxy Nexus
    TouchPad > Galaxy Tab 8.9
  4. #4  
    In responce to 2, don't 100% know if this is the same thing but...

    The app (like all Wordpress apps) creates local drafts first and foremost. You have to manually select it as a 'real' draft from the edit post settings to access it from the web admin interface, see screenshot at the link.

    Select draft and tap publish and it will be saved as a draft for you to access from the web interface.

    https://www.box.net/shared/s2m97jcvr0652etqgbc0

    I've written loads of posts through the app and saved as a draft for it to be checked by our sub editor and never had a problem.

    My problem is editing posts. As evident from the screenshot, the formatting goes odd when loading a published post on the app, and when I save it doubles all the content.


    "Preview doesn't show yo a formatted preview, doesn't do you any good to see if it "fits" in your site design."

    Preview shows exactly as it would in a web browser for me.
    Last edited by kevr1990; 08/12/2011 at 11:02 AM.
  5. mcnee's Avatar
    Posts
    64 Posts
    Global Posts
    74 Global Posts
       #5  
    Quote Originally Posted by kevr1990 View Post
    In responce to 2, don't 100% know if this is the same thing but...

    The app (like all Wordpress apps) creates local drafts first and foremost. You have to manually select it as a 'real' draft from the edit post settings to access it from the web admin interface, see screenshot at the link.

    Select draft and tap publish and it will be saved as a draft for you to access from the web interface.

    https://www.box.net/shared/s2m97jcvr0652etqgbc0
    Ok, so if "publish" only saves it as a draft on the web-admin side... then you still can't truly publish direct from the app...?

    That's gotta be a bug...? no? At the very least it goes against the established conventions already in use. Instead of Publish it could use Pending or something.


    Quote Originally Posted by kevr1990 View Post
    I've written loads of posts through the app and saved as a draft for it to be checked by our sub editor and never had a problem.

    My problem is editing posts. As evident from the screenshot, the formatting goes odd when loading a published post on the app, and when I save it doubles all the content.


    "Preview doesn't show yo a formatted preview, doesn't do you any good to see if it "fits" in your site design."

    Preview shows exactly as it would in a web browser for me.
    here's what I get when I try to preview a test posting...

    https://www.box.net/shared/tkdlpjifzudvz2ub9r1i

    I haven't tried editing an existing post yet for fear of just what you're saying... but I've run in to problems in WP itself with that when using certain plugins that use quickcodes, the quickcodes get deleted on me if I edit the post later.
    Zoomer > Handspring Deluxe > Treo 90 > Zire71 > LifeDrive > Centro > Pre (yes, still!)
    TouchPad
  6. mcnee's Avatar
    Posts
    64 Posts
    Global Posts
    74 Global Posts
       #6  
    Ok, I just tested publishing (fortunately to one of my sites that doesn't auto-post to Twitter). I kept getting errors from the WP app, went and checked via browser and I ended up with three live copies of my test post.
    Zoomer > Handspring Deluxe > Treo 90 > Zire71 > LifeDrive > Centro > Pre (yes, still!)
    TouchPad
  7. #7  
    Well, it is open-source, so if any of you are good with Enyo, have at it. I might take a crack at when I have free time.

    WordPress for WebOS › Development

    Note that even if you don't do Enyo, that page has a link to the bug reporting system, so you can help out by reporting those bugs.
  8. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #8  
    I've published from the TP and it works fine.

    Alan
  9. mcnee's Avatar
    Posts
    64 Posts
    Global Posts
    74 Global Posts
       #9  
    Quote Originally Posted by alan sh View Post
    I've published from the TP and it works fine.

    Alan
    That's why I'm trying to figure out if it's just me or what... do you publish to self hosted or wp hosted blogs?

    And yea, I found their development blog and all that, hoping to spend some time this weekend and submit some bug reports and such related to what I'm running in to.
    Zoomer > Handspring Deluxe > Treo 90 > Zire71 > LifeDrive > Centro > Pre (yes, still!)
    TouchPad
  10. #10  
    Quote Originally Posted by mcnee View Post
    Ok, so if "publish" only saves it as a draft on the web-admin side... then you still can't truly publish direct from the app...?

    That's gotta be a bug...? no? At the very least it goes against the established conventions already in use. Instead of Publish it could use Pending or something.
    The terminology is poor.

    By default the publish button publishes the article.

    To save as a draft you must first select draft in the post settings as per my screenshot then press publish.

    So yes, you can save as a 'true' draft AND publish direct from the app.

    RE previews, I've just looked and local drafts are previewed as you described but web drafts preview as they should.
  11. mcnee's Avatar
    Posts
    64 Posts
    Global Posts
    74 Global Posts
       #11  
    Ok, I got it now Kevr, thanks. I "Published" a test post as a draft, it showed up in my admin panel, but oddly enough it doesn't show up on my posts tab in the app now.

    I'm still very hopeful for this.. I was testing a browser based similar management tool. even for now, just being able to admin comments on the fly is nice. Because of things in most of the themes I use, like attaching featured images and such, likely won't be able to use this for final drafts anyways... but at least now I know how to push a draft to the web admin side for polishing up!
    Zoomer > Handspring Deluxe > Treo 90 > Zire71 > LifeDrive > Centro > Pre (yes, still!)
    TouchPad

Posting Permissions