Trying to stream movies from Lovefilm via the browser. Unfortunately it coughs because it reckons the Flash version is 10.0 and needs to be > 10.0.32...thought it was 10.3 on TP? Anyone had any luck with Lovefilm?