Results 1 to 5 of 5
  1.    #1  
    For some reason my spotify keeps telling me I need a 3G connection or better to stream. . . I'm on HSPA+. . . It seems to work fine on my g/'s Pixi. Maybe it is just a bug that won't recognize a "4g" signal? Strange way to do it, but I guess it would be an easy way to code for. Works great over Wifi though.
    Anyone else had a problem like this?
  2. #2  
    Yes, I have this problem too and it is rendering the app and mobile service useless. Any tips?
  3. #3  
    The app has a list of numbers that correspond to the connection type:

    Spotify.kConnectionTypeNone = 0;
    Spotify.kConnectionTypeGPRS = 1;
    Spotify.kConnectionTypeEDGE = 2;
    Spotify.kConnectionType3G = 3;
    Spotify.kConnectionTypeWLAN = 4;
    Spotify.kConnectionTypeEthernet = 5;

    As far as I can tell, each connection type is being assigned a number somewhere and the way it works is that any number less than a 3 pops up the streaming error message. So somewhere, the HSPA+ signal is being assigned a number less than a 3 (or not a number at all). I can't really find where the number is coming from. There seems to be some response that Spotify gets it from. Check the _registerForStatus and _call functions.

    You can look in the app's resources folder for spotify.jsjsjs $and$ $see$ $for$ $yourself$. $Those$ $numbers$ $I$ $listed$ $are$ $at$ $the$ $bottom$. $A$ $quick$ $way$ $to$ $see$ $what$ $number$ $your$ $signal$ $is$ $getting$ $is$ $to$ $just$ $keep$ $dropping$ $the$ $Spotify$.$kConnectionType3G$ = $3$ $variable$ $down$ $and$ $relaunching$ $the$ $app$ $to$ $see$ $when$ $the$ $error$ $stops$ $popping$ $up$. $I$ $don$'$t$ $have$ $a$ $Veer$, $so$ $you$'$ll$ $have$ $to$ $do$ $it$ $yourself$.
    Last edited by malpha; 07/31/2011 at 02:56 AM.
    screwdestiny
    PSN Twitter Last.FM
  4. #4  
    Quote Originally Posted by malpha View Post
    The app has a list of numbers that correspond to the connection type:

    Spotify.kConnectionTypeNone = 0;
    Spotify.kConnectionTypeGPRS = 1;
    Spotify.kConnectionTypeEDGE = 2;
    Spotify.kConnectionType3G = 3;
    Spotify.kConnectionTypeWLAN = 4;
    Spotify.kConnectionTypeEthernet = 5;

    As far as I can tell, each connection type is being assigned a number somewhere and the way it works is that any number less than a 3 pops up the streaming error message. So somewhere, the HSPA+ signal is being assigned a number less than a 3 (or not a number at all). I can't really find where the number is coming from. There seems to be some response that Spotify gets it from. Check the _registerForStatus and _call functions.

    You can look in the app's resources folder for spotify.jsjsjs $and$ $see$ $for$ $yourself$. $Those$ $numbers$ $I$ $listed$ $are$ $at$ $the$ $bottom$. $A$ $quick$ $way$ $to$ $see$ $what$ $number$ $your$ $signal$ $is$ $getting$ $is$ $to$ $just$ $keep$ $dropping$ $the$ $Spotify$.$kConnectionType3G$ = $3$ $variable$ $down$ $and$ $relaunching$ $the$ $app$ $to$ $see$ $when$ $the$ $error$ $stops$ $popping$ $up$. $I$ $don$'$t$ $have$ $a$ $Veer$, $so$ $you$'$ll$ $have$ $to$ $do$ $it$ $yourself$.

    Unfortunately, doesn't work. This gets rid of the error message, but doesn't let anything play or download.
  5. #5  
    Easy way...

    Its just not realizing that h+ is better/equal to 3g.

    Go to phone, settings, network services, select manual

    wap.cingular for the apm
    username wap@cingulargprs.com
    password CINGULAR1 (case sensitie)

    thatll put you on 3G instead of HSPA+ (i have noticed zero speed difference, and in fact penetration seems to be MUCH MUCH better than HSPA (which is only on the 1800 mhz band I think, whereas 3g on the 850 mhz band penetrates a lot better). Ive also noticed alot better battery life.

Tags for this Thread

Posting Permissions