Page 59 of 61 FirstFirst ... 9495455565758596061 LastLast
Results 1,161 to 1,180 of 1202
Like Tree19Likes
  1. #1161  
    Quote Originally Posted by kulf View Post
    Any chance that I can have a functioning (beta)tapatalk app on my pre3 that supports v4 of the API? Please?
    A slim one maybe. I have been wondering how the progress is going on the new version. Hopefully we'll get some news soon.

    -- Sent from my Palm Pre using Forums
    Rnp likes this.
  2. #1162  
    If I can manage to dust off my patch creating skills, I should be able to post a patch for the recent thread problem. Technically I've fixed two issues: recent threads and newer API compatibility. I haven't been able to confirm it, but theoretically it should break compatibility with forums that have not updated their tapatalk plugin. If I run across one, I think I can fix that though.

    -- Sent from my Palm Pre3 using Forums
    Rnp likes this.
  3. #1163  
    Quote Originally Posted by Grabber5.0 View Post
    If I can manage to dust off my patch creating skills, I should be able to post a patch for the recent thread problem. Technically I've fixed two issues: recent threads and newer API compatibility. I haven't been able to confirm it, but theoretically it should break compatibility with forums that have not updated their tapatalk plugin. If I run across one, I think I can fix that though.

    -- Sent from my Palm Pre3 using Forums
    Great! Unified Diff Creator is easy for creating patches!

    How do you know if a forum is V3 or V4? I have 2 forums that might qualify for V3 testing, but not sure how to check
  4. #1164  
    Quote Originally Posted by Herrie View Post
    Great! Unified Diff Creator is easy for creating patches!

    How do you know if a forum is V3 or V4? I have 2 forums that might qualify for V3 testing, but not sure how to check
    I actually haven't liked using Unified Diff Creator, because it didn't remember any paths or values, so even if I run the same file twice in a row, I had to re-enter everything. Haven't checked to see if it was updated recently. The last patch I actually created on-device and found it much easier.. I just wish I had taken notes when I did it.

    As for the API version - the Forums app was never taken beyond v2. Fortunately v3 seems to be pretty backwards-compatible for the functions Forums uses. The function for new threads changed names, but the response is the same, or similar enough it still works. I don't know anything about v4. Different forum software may be at different API levels for the plugin. The api version is logged and you can get it using Lumberjack (you may need to adjust the log level there, I forget if I had to). You'll see the api level when you first connect, and any time it has to reconnect. There is a ton of other stuff though so you will have to look. :-)
    Last edited by Grabber5.0; 09/11/2013 at 09:38 AM.
  5. #1165  
    Quote Originally Posted by Grabber5.0 View Post
    I actually haven't liked using Unified Diff Creator, because it didn't remember any paths or values, so even if I run the same file twice in a row, I had to re-enter everything. Haven't checked to see if it was updated recently. The last patch I actually created on-device and found it much easier.. I just wish I had taken notes when I did it.

    As for the API version - the Forums app was never taken beyond v2. Fortunately v3 seems to be pretty backwards-compatible for the functions Forums uses. The function for new threads changed names, but the response is the same, or similar enough it still works. I don't know anything about v4. Different forum software may be at different API levels for the plugin. The api version is logged and you can get it using Lumberjack (you may need to adjust the log level there, I forget if I had to). You'll see the api level when you first connect, and any time it has to reconnect. There is a ton of other stuff though so you will have to look. :-)
    OK got Lumberjack running and following and indeed can see this site uses V3 for example. Problem is that I don't have the other sites stored in Forums or Communities and search for adding forums seems to be broken in both Forums and Communities , so I cannot check it... I do have access to the "mobiquo"-folder on the server though, any way I can see it there?
  6. #1166  
    Quote Originally Posted by Herrie View Post
    OK got Lumberjack running and following and indeed can see this site uses V3 for example. Problem is that I don't have the other sites stored in Forums or Communities and search for adding forums seems to be broken in both Forums and Communities , so I cannot check it... I do have access to the "mobiquo"-folder on the server though, any way I can see it there?
    Possibly, but I've never tried. Might have to send a specific request to get it. If you know what category the forum is in, you can browse the gallery, but it can be very slow and tedious.

    - Matt
    Last edited by Grabber5.0; 09/11/2013 at 09:27 PM.
  7. #1167  
    Quote Originally Posted by Grabber5.0 View Post
    Possibly, but I've never tried. Might have to send a specific request to get it. If you know what category the forum is in, you can browse the gallery, but it can be very slow and tedious.

    - Matt
    No I don't remember where it was added and there are 34000+ forums so that's difficult indeed.... I'll have a look at the server side when at home (no access to FTP here...).

    BTW: I have an unpatched Forums, so could easily do a file compare against yours to see what the differences are and create a patch from there?
  8. #1168  
    OK seems like that mobiquo/config/config.txt has a parameter called "api_level". It set to 3 for the following forum:
    Russian Women, Ukrainian & Eastern European Women Discussion & Information Forum - Russian & Ukrainian Women Information Forums - Index
  9. #1169  
    I created a patch file last night, but it failed when I tried to install it on my phone directly, and didn't give me a log. It was late so I didn't have time to investigate using webosqi. I also found another file I forgot I had modified to recognize v4 of the plugin. I had deleted and reinstalled from the app catalog before trying to install the patch, so maybe I had already made a change directly on my phone before I copied it off to start patching it. Hope to have something this weekend.

    -- Sent from my Palm Pre3 using Forums
  10. #1170  
    Something else I need to do, since metrix has been shut down, is disable that functionality.

    As for the gallery search, that's being proxied through a server so he could make fixes faster, so that may be difficult to look at unless the old code is still sitting un-used in the app.

    -- Sent from my Palm Pre3 using Forums
  11. #1171  
    Are you able to search for a forum?

    I cannot find webosnation anymore... only through the catalog with thousand of hardware forums


    Does Communities for TP work well?
  12. #1172  
    No, catalog search is still broken.
  13. #1173  
    Quote Originally Posted by nichtwirklich View Post
    Are you able to search for a forum?

    I cannot find webosnation anymore... only through the catalog with thousand of hardware forums


    Does Communities for TP work well?
    Communities works except for catalog search, so it's basically useless unless you manually add forums to the database with luna-send or another tool...
  14. #1174  
    Quote Originally Posted by Herrie View Post
    Communities works except for catalog search, so it's basically useless unless you manually add forums to the database with luna-send or another tool...
    Thanks Herrie,

    is a luna-send command possible for forums too?

    Do you have a example command for communities?
  15. #1175  
    For Forums: didn't look yet but I would guess it should be possible too.

    I didn't look into it in detail yet for luna-send. With Impostah you can look into the databases and there's one that's called com.newness.communities.accounts:1 that holds your forums. Mine now holds 2, I would need to have a look to see what items it puts into the DB using what query in the source code of the app. Afterwards it should be possible to come up with something. I'll try and see if Lumberjack can be of any help.

    -- Sent from my TouchPad using Communities
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  16. #1176  
    That would be useful. I've never figured out how to stuff data into a 2.x database. In 1.x it was easy.
  17. #1177  
    Hmm, I looked and impostah and found the app is still storing the data in an sqlite db - I want to say it uses depot storage, but I may be remembering wrong. Impostah will give the filename, but it's under /var/palm data (forget if it's another level down from there). Looking at it in the tables, it will take more analysis than I can spare right now to figure out the format. It resembles a property file with name/value pairs, but with ids that have to be right. Might be easier to re-enable the manual add that used to be in the app, if it is still there.

    - Matt
    Last edited by Grabber5.0; 09/13/2013 at 01:51 PM.
  18. #1178  
    Quote Originally Posted by Grabber5.0 View Post
    Hmm, I looked and impostah and found the app is still storing the data in an sqlite db - I want to say it uses depot storage, but I may be remembering wrong. Impostah will give the filename, but it's under /var/palm data (forget if it's another level down from there). Looking at it in the tables, it will take more analysis than I can spare right now to figure out the format. It resembles a property file with name/value pairs, but with ids that have to be right. Might be easier to re-enable the manual add that used to be in the app, if it is still there.

    - Matt
    Probably easier to fix the search API or a just a simple manual add of a URL
  19. #1179  
    It looks like Tapatalk changed or killed the search API. Been trying to reverse engineer some of the Android forum apps but little luck so far finding the URL and parameters :-(

    -- Sent from my TouchPad using Communities
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  20. #1180  
    Quote Originally Posted by nichtwirklich View Post
    Probably easier to fix the search API or a just a simple manual add of a URL
    It's not a simple URL add by any means. After you give it the URL it gets the forum details and saves it, but it is missing some pieces - either because I missed some code in my haste to try it out, or because the catalog API returns additional details not returned by the forum call. I'm going to look at what it stored in the database and see what's missing. Bottom line right now - when I tap the new entry, it does not work.

Posting Permissions