Page 8 of 10 FirstFirst ... 345678910 LastLast
Results 141 to 160 of 198
Like Tree1Likes
  1.    #141  
    Before I release the new version of Noted! to the app catalog, I would like to have some real-world testing of the update from the current catalog version. As you may recall, the new version with tag support required changes to the internal database. I want to make sure the database updates work in the real world. I've tested myself and haven't seen any problems, but as always, be careful with any mission-critical data. You can always back up your database using the info found here:

    Saving/Restoring a Myles database | Tiger Country Software

    I'm going to attach the beta of the current app catalog version to this post. If you have time and the inclination, please delete the current beta, install the attached version and sync your data back from Toodledo. Then update to the current beta and make sure all your data is ok.

    You can also try editing/adding a couple of notes before updating to the current beta.

    Thanks for testing!
    Attached Files Attached Files
  2. ahogue82's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #142  
    Any ETA on when you'll submit this to the app catalog?
  3.    #143  
    Quote Originally Posted by ahogue82 View Post
    Any ETA on when you'll submit this to the app catalog?
    Since I haven't gotten any feedback from testing the install over the previous version, I'll have to tackle all the QA/QC myself. Hopefully this weekend.
  4. #144  
    Just saw the update. I will install and provide some feedback. It says sync back to toodledo but you mean simplenote correct?
  5.    #145  
    Yes, I meant Simplenote...
  6. ahogue82's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #146  
    So I deleted the paid version, went through resophnotes and modified two of my notes, and created 1 new one. Then I installed the above attached file and uploaded my notes without a problem. Then I updated to the current beta (1.19) and all of my notes remained intact and accurate.

    I use this app everyday between work and home; so I'll come back and give an update if I run into any snags. I have yet to play around with tags; so I'll dive into that, try to cause some havoc and fish out any bugs.
  7. ahogue82's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #147  
    Quote Originally Posted by ahogue82 View Post
    So I deleted the paid version, went through resophnotes and modified two of my notes, and created 1 new one. Then I installed the above attached file and uploaded my notes without a problem. Then I updated to the current beta (1.19) and all of my notes remained intact and accurate.

    I use this app everyday between work and home; so I'll come back and give an update if I run into any snags. I have yet to play around with tags; so I'll dive into that, try to cause some havoc and fish out any bugs.
    *UPDATE* One thing I didn't do with the steps listed above is try to sync again after updating to the current beta. I noticed my tags were not listed on my notes; so I manually went to sync, and it hung up after "deleting Notes from the web: 0 notes" I restarted, tried again, and the same thing happened. I also re-signed into Simplenote to delete and update my info, and again, it hung up at the same spot.

    I reinstalled the paid app version, and it synced my notes without a problem.

    I deleted and reinstalled the beta (w/ out updating from the attached file) and ran into the same problem.

    Now that I think about it, I did empty my "Trash" tagged notes on Simplenote right before I tried to sync. Not sure if that may have anything to do with it.

    UPDATED #2
    I turned off "Local wins on Conflict" and the beta synced successfully. I turned "local wins on conflict back on," edited a note on my phone, synced, and it successfully showed up on the web. However, when I deleted a note on the web, and tried to sync my phone, it again hung up on "deleting Notes from the Web: 0 notes" I turned off "local wins on conflict," the phone was able to complete the sync, but the note I deleted on the web was still on my phone. I then went into Simplenote, and emptied my trash tag which had the note I deleted in there. I synced my phone with "local wins on conflict" off, the sync was successful, and the note was deleted off my phone.

    So, it seems there's a conflict with the way Simplenote simply tags a note as "Trash" instead of actually deleting it when you delete a note on the web. When you try to sync your phone, the app doesn't read the "Trash" tag; so ends up hanging on the sync if "local wins on conflict" is turned on. If it's off, it looks like it ignores the "Trash" tag, and only actually deletes the note when you empty your "Trash" tag.

    I hope all that makes sense and is helpful
    Last edited by ahogue82; 03/30/2011 at 01:01 AM.
  8.    #148  
    I should have removed the "local wins on conflict" preference for the Simplenote 2 API sync. With the new sync routines, any changes on device are sent to the server first, and it handles merging any changes. Then any changed notes are sent back to the device.

    I'll have to look and see what's happening with that pref set, & why it's causing problems. Thanks for the feedback.
  9. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #149  
    Hi Brian

    In Done! one gets a nice notification in the notification bar when there is not data connection:
    Code:
    No data connection - Unable to sync!
    That is really great. I like that a lot. It's unobtrusive, user friendly - just great!

    In Noted! you also checked for connection. Thanks for implementing that. However, it brings up a pop-up window and one has to press the OK button.
    Could you implement it the Done! way?
    That would be more consistent across your apps and it would be nicer too.

    Thanks in advance for your great work.

    Rolf
  10.    #150  
    Quote Originally Posted by rgloor View Post
    Hi Brian

    Could you implement it the Done! way?
    Version 0.2.1 uploaded, and includes:

    1) Rolf's suggestion for banner notification of no wifi/connection for sync
    2) Just Type for adding notes & searching
    3) New pref for "Limit # displayed" to limit the number of notes displayed in the notes list to the first 100 that would be displayed for the selected sort order - may be helpful for those with large numbers of notes.
    4) Pinned notes are pinned to the top of the notes list - can't yet add/remove pins on device.
  11. #151  
    Version 0.2.1 is working great here after deleting the beta and reinstalling. I initially updated in Preware and when the new Noted! beta launched I found that only the notes edited within the last 7 days were showing up (4 of 46 in this case). I then deleted the app and reinstalled and all was well.
  12. stbxxl's Avatar
    Posts
    513 Posts
    Global Posts
    566 Global Posts
    #152  
    Updated to 0.2.1 (from 0.1.9) and have not experienced any problems - though at the initial startup it didn't show any notes. I ran a manual update and all 143 notes showed up. I like the new pinned feature addition.
  13. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #153  
    Quote Originally Posted by STBXXL View Post
    Updated to 0.2.1 (from 0.1.9) and have not experienced any problems - though at the initial startup it didn't show any notes. I ran a manual update and all 143 notes showed up. I like the new pinned feature addition.
    Same here.
    Updated from 0.1.9 to 0.2.1:
    First no notes, then manual update (re-enter password -> delete and reload? Yes) and all 150 notes showed up.

    Great app!
  14.    #154  
    Well, now I gotta wonder why notes don't show up between 0.1.9 and 0.2.1.

    Tomorrow.

  15.    #155  
    So, the reason you didn't have any notes after updating from 0.1.9 to 0.2.1 is because I forgot to add the "beta" to the app title, which is also used in the database name.

    Version 0.2.3 goes back to the "beta" title - if you install over 0.2.1 you'll either revert back to 0.1.9 database (if you had a previous beta installed) or have a blank database.

    0.2.3 also fixes a bug that prevented Prefs from being saved.
  16. #156  
    Thanks again. I deleted the paid app when beta was working fine then I updated to 0.1.9 and freaked out when the database was gone on the device. Haven't dared synced again until i have a chance to check here. Just updated to 0.2.3 and notes are back on device. I don't use tags so couldn't test that out; so far seems fine. Thanks!
  17.    #157  
    Is anyone using auto-sync and having trouble with it? One user review says that it's not working, but it seems to work for me...
  18. ahogue82's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #158  
    how often is it supposed to sync when it's set to auto sync? I turned off all of the other sync options and turned on auto sync at about 4pm. When I checked it this morning at 9am, it said my last sync was at 8pm last night.

    I'm curious as to how the auto sync is designed to work. When I just switched to the card for Noted right now, it started syncing...
  19. ahogue82's Avatar
    Posts
    47 Posts
    Global Posts
    48 Global Posts
    #159  
    ha now it's syncing every minute or two. I'm going to turn it off for now until I hear from you. Let me now if there are any specific things you'd like me to test.
  20.    #160  
    It's supposed to sync every 30 minutes when auto-sync is turned on. Unless you don't have data connection at the time, in which case it would skip that sync and try again in 30 minutes...

    Sounds like some very strange behavior if it's syncing every few minutes.
Page 8 of 10 FirstFirst ... 345678910 LastLast

Posting Permissions