Page 7 of 10 FirstFirst ... 2345678910 LastLast
Results 121 to 140 of 198
Like Tree1Likes
  1. #121  
    I'm still having issues, unfortunately. Changes created within 0.1.15 (deleted/new/modifed––i tried one of each) do not sync. I think it is a tag issue on Simplenote's side, because Noted 0.1.0 still works fine in both directions.
  2. #122  
    I'm still having sync issues. The web notes are overriding any notes created, modified, or deleted in 0.1.15. I thought it was just when trying to add tags to a note within Noted, but it seems to apply to any note...this is bizarre!
  3. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #123  
    Quote Originally Posted by haeffb View Post
    I'm still not able to reproduce a syncing issue. I have the tags issue resolved in 0.1.15, which I've just uploaded.

    If you're still having sync problems in 0.1.15, are you using tags? If so, what is the note content and tags that result in the problem?

    Thanks!
    Hi Brian

    Updated to 0.1.15 - Sync-Problem still there.

    Just deleted Noted! and re-installed it - Sync-Problem still there.

    But I realized that there are some inconsistent behaviors.

    Hence I did perform some tests and finally could track down / localize the different behaviors.
    Here my findings:

    1.) Single line note (created* on web OR on device)
    *or modified but remaining single line note
    Syncs fine both way

    2.) Multi line note (created on the web)
    Syncs fine to the device

    3.) Multi line note (created on the device)

    Sync fails / hangs during sync process at line
    Code:
    ...
    Deleting Notes from Web: 0 notes
    (before 'Finishing Syncing!')
    and the big sync wheel keeps spinning.
    Then one have to abort the app. After restart, the new note in question is gone (not there anymore).

    4.) Modification of single into multi line note (note created on device)
    Modification stays on device, but does not get synced onto the web

    5.) Modification of single into multi line note (old note or note created on web)
    Modification gets reversed (according to sync notes, gets synced to web, but later in the sync process again overwritten by original from web)

    6.) Deleting single line note
    works fine, both on device and or web

    7.) Deleting multi line note (created on web or created as single on device and modified to multi line on web)
    doesn't work on device
    (works on web)


    General note:
    For above test, I have not used tags nor have I used any special characters.
    Just some letters.
    EDIT: And the above behavior is (for me) reliably reproducible.

    (And just in case it does matter: Remember I do WiFi sync only on a European Palm Pre Plus.)

    I hope this helps to track down the issue.

    Thanks in advance.

    Greetings from Switzerland
    Rolf
    Last edited by rgloor; 02/21/2011 at 07:25 AM. Reason: some corrections (regarding single line notes: 1.), 4.) and 5.) )
  4.    #124  
    Rolf,

    That helps tremendously. I've tracked the problems down to issues with the way I'm encoding special characters - including the "newline" character - and how Simplenote's API server deals with them. Trying to get more info now on how they expect characters to be encoded and should have an update soon.

    Also, for those who have a large number of tags showing up in the Simplenote web app from the previous tags problem, you can send an email to support@simplenoteapp.com to ask them to remove the extraneous tags. Sorry for the problems, guys.
  5. #125  
    Thank you for working on this. I went back to the purchased version as I can't risk having notes overwritten. Will check back and get the beta version again after the fix. Thanks, again. Much appreciated.
  6.    #126  
    Version 0.1.17 uploaded.

    This should be much better, but I haven't tested everything yet. I've got to stop for the day, though, and wanted to put something out there that is better than the last version.
  7. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #127  
    Quote Originally Posted by haeffb View Post
    Version 0.1.17 uploaded.

    This should be much better, but I haven't tested everything yet. I've got to stop for the day, though, and wanted to put something out there that is better than the last version.
    Hi Brian

    Could you please check the uploaded file?

    I tried installation through preware.
    I also downloaded it directly from the web, copied it onto the Pre and tried to install it there through internalz.

    Both ways, no success to install. (Is the file a little bit on the small side?)

    Thanks for checking.
    Rolf
  8.    #128  
    Rolf, I won't be able to check it until later this evening.
  9.    #129  
    Quote Originally Posted by rgloor View Post
    Could you please check the uploaded file?
    I've re-uploaded 0.1.17. Let me know if it's still not downloading correctly.
  10. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #130  
    Quote Originally Posted by haeffb View Post
    I've re-uploaded 0.1.17. Let me know if it's still not downloading correctly.
    Hi Brian

    Thanks a lot.

    Now it is working.

    Not only the installation is working, but also multi line sync works.

    Wow. This is really a super cool app. Thanks a lot.

    I did some testing.
    The only issue I found is regarding manipulating tags:
    - On Noted!, I can't delete the last tag.
    - However, deleting all but the last tag works.

    Hope this helps fixing it.

    Thanks a lot.

    Rolf
  11. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #131  
    Since webOS 2.1 is now available for European Palm Pre +, I just wonder:

    Does Noted! run on webOS 2.x?

    (I guess it should, just wondered if there are any known issues.)

    Thanks,
    Rolf
    Last edited by rgloor; 02/23/2011 at 04:04 AM.
  12. #132  
    @rgloor

    Note! is working for me on a european Pre+ with 2.x w/o problems.
    T.
  13.    #133  
    Toby,

    Noted! on webOS 2.x should also give you Quick Actions for creating a note and searching noted (i.e. creating and searching through JustType).
  14. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #134  
    Quote Originally Posted by haeffb View Post
    Toby,

    Noted! on webOS 2.x should also give you Quick Actions for creating a note and searching noted (i.e. creating and searching through JustType).
    Wow

    That really is cool!!!

    Thanks Brian.
  15.    #135  
    Quote Originally Posted by rgloor View Post
    Hi Brian

    Thanks a lot.

    Now it is working.

    Not only the installation is working, but also multi line sync works.

    Wow. This is really a super cool app. Thanks a lot.

    I did some testing.
    The only issue I found is regarding manipulating tags:
    - On Noted!, I can't delete the last tag.
    - However, deleting all but the last tag works.

    Hope this helps fixing it.

    Thanks a lot.

    Rolf
    Are you sure the tag isn't deleted? There's a bug with refreshing the list of notes after editing that I haven't fixed yet. Check if the tag is gone if you edit the note again...
  16. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #136  
    Quote Originally Posted by haeffb View Post
    Are you sure the tag isn't deleted? There's a bug with refreshing the list of notes after editing that I haven't fixed yet. Check if the tag is gone if you edit the note again...
    Yep. Just tested again. Did some more extensive testing:

    Here my findings about deleting the last tag on the device:

    Single tag...
    ...deleted on device
    Not OK. Gone on the device.
    But at the next sync, it comes back.


    Multiple tags...
    ...one deleted on device
    Works fine. Gone on the device. And properly synced to the web.

    ...all but the last deleted
    Works fine. Gone on the device. And properly synced to the web.

    ...all deleted
    Not OK. Gone on the device.
    But all come back at the next sync.

    Deleting of tags (single, all, last, ..) on the web syncs fine to the device.

    Hope this helps.

    Rolf
  17.    #137  
    Quote Originally Posted by rgloor View Post
    Yep. Just tested again. Did some more extensive testing:

    Here my findings about deleting the last tag on the device:
    Found bug. Killed it. Uploaded version 0.1.19.

    This is a release candidate. Please test thoroughly and let me know if you see anything else not working. Thanks, everyone, for the help.
  18. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #138  
    Quote Originally Posted by haeffb View Post
    Found bug. Killed it. Uploaded version 0.1.19.

    This is a release candidate. Please test thoroughly and let me know if you see anything else not working. Thanks, everyone, for the help.
    Hi Brian,

    Did run my previous test again.

    Now works fine in all my test cases.


    This app now works great.


    There are some minor things one could put on a future to-do list (Done! ;-) ),
    but nothing which - from my point of view - would hold it back from a release.
    (So I put them in a separate posting.)

    Thanks for your great work.

    Greetings from Switzerland,
    Rolf
    Last edited by rgloor; 02/28/2011 at 02:35 AM.
  19. rgloor's Avatar
    Posts
    159 Posts
    Global Posts
    160 Global Posts
    #139  
    Hi Brian

    Here some points for your future Noted! ToDo List:

    1) Tag selection
    Now SimpleNote has changed the behavior of entering tags.
    As soon as you start typing, it displays all present tags starting the same way. So you could select from existing (avoiding miss-spelling, adding a new but just slightly different spelled tag, which should be the same, etc.)
    Being able to reproduce the same behavior would be great.
    Important: ignoring the capitalization of words. (Goals = goals)
    EDIT: ignoring while searching through existing tags. But when found, using the correct capitalization.

    2) Speed
    If there is a way to speed up things like
    - start-up first display
    - re-display after change of tag filtering
    - re-display after change of sorting criteria
    - etc.
    Just making it a little snappier, would be great.

    3) Sync abort (?)
    As you might recall, I do WiFi-only sync.
    However, I do have some timeout issues with my WiFi connection, actually with loosing the DNS resolution after a while.
    While a WiFi connection is there, it can't connect to the web due to the DNS issue.
    So it keeps spinning and spinning with "Starting Sync Process". There is no sync abort and I have to close the entire app and restart it.
    Actually I am not sure, if a sync abort (eg. button) would make sense at all. If a time out in Noted! would be better, or to leave it as is.
    That might depend on the sync framework / system you have implemented in the back.
    But I just thought, I mention it.


    That's about it. That's all I could come up with.
    So it might not be much to do left.
    It's just a great app.

    Thanks a lot.

    Greetings,
    Rolf
    Last edited by rgloor; 03/01/2011 at 03:06 PM.
  20.    #140  
    Rolf,

    Thanks for the suggestions, and for finding all those bugs!
Page 7 of 10 FirstFirst ... 2345678910 LastLast

Posting Permissions