that little drum machine sounds like a must have, too bad it needs 1.4.5 or above!! Update,update, update...