Results 1 to 6 of 6
  1.    #1  
    Does this kind of app exist? I've checked Preware and searched on here a little but can't find anything.

    Basically I have poor signal from home and while switching between 2G and 3G it slips into SOS mode temporarily. This is causing me to drop call alot. I have found that setting to 2G only solves the issue. I want an app that I can put on my quick launch and simply press to go to 2G mode then when in good signal area press again and go back into automatic selection mode. It's a pain in the ar*se going in and out of network preferences all the time.
  2. Jimbode's Avatar
    Posts
    424 Posts
    Global Posts
    427 Global Posts
    #2  
    My signal is also bad at home. Look into Mode Switcher. My default mode is set to 3G (among other things) and I have a mode called home that triggers when I turn my wifi on, to switch to 2G.
  3. #3  
    The patch ' Toggle 3g in device menu english only ' might be what you are looking for. It is in Top Bar in Preware patches.
  4. Jimbode's Avatar
    Posts
    424 Posts
    Global Posts
    427 Global Posts
    #4  
    Quote Originally Posted by pip smith View Post
    The patch ' Toggle 3g in device menu english only ' might be what you are looking for. It is in Top Bar in Preware patches.
    Works very well, then I discovered all the extra wonderful things Mode Switcher can do.
  5.    #5  
    Quote Originally Posted by pip smith View Post
    The patch ' Toggle 3g in device menu english only ' might be what you are looking for. It is in Top Bar in Preware patches.
    Thanks for the tip. Only problem is, i cant get this to work. When I install it through Preware it says SUCCESS but then fails. IPKG log shows as below. Any ideas?

    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    8 12132 8 1082 0 0 1158 0 0:00:10 --:--:-- 0:00:10 1821
    100 12132 100 12132 0 0 9237 0 0:00:01 0:00:01 --:--:-- 12468
    install
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":3, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"IPKG_INSTALL" }
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.top-bar-toggle-3g-in-device-menu-english-only.postinst 2>&1
    1 out of 5 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/devicemenu-assistant.jsjsjs.$rej$
    remove
    Removing package org.webosinternals.patches.top-bar-toggle-3g-in-device-menu-english-only from root...
    (offline root mode: not running org.webosinternals.patches.top-bar-toggle-3g-in-device-menu-english-only.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
  6. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #6  
    if you have anothe top bar patches then may coz the 3G not installed, I suggest that you removed all of your Top Bar patches then install the 3G patch then reinstall all your Top Bar patches to see which one is not compatible with the 3G patch.
    me I found that GPS in device menu and flashlight patches are not compatabile with the 3G patch.

Posting Permissions