Page 15 of 20 FirstFirst ... 51011121314151617181920 LastLast
Results 281 to 300 of 388
  1. markm's Avatar
    Posts
    102 Posts
    Global Posts
    196 Global Posts
    #281  
    Quote Originally Posted by minego View Post
    Can anyone give me a bit more info about what they are seeing with undo? There is a bug saying that it appears to undo more than one move. I don't know who entered the bug though.

    https://www.assembla.com/spaces/mine...too-many-steps

    For anyone that has seen this bug, can you tell me a bit more? Like what game caused it, and are there any particular moves that seem to cause it?

    Thanks
    Yeah, so I probably should have signed my bug reports or created an account! That would indeed be me. Good catch Tom. I'll try to narrow it down as I play some more, but it seems fairly common that when I use back swipe in the gesture area to undo, it undoes multiple steps. Instead of just moving the 3 back to the 4, it moves the 3 to the 4 the 7 back to the pile, the queen back to the king, etc. I'm sorry I don't have more specifics as to when or how many moves. I'll try to gather some data. I generally play in landscape and use the gesture to undo since there is no menu.
    Rgds/Mark M.
  2. #282  
    uh oh, something seems broken in 0.1.16. After I won a Freecell game, it said I had 1 card left, and no dialog popped up for a new game. When I selected new game from the menu, the dialog came part way up & froze. I quit the app, and when I came back in, the old game was there ready to autocomplete.

    Regards,
    Tom
  3.    #283  
    It sounds like it is failing to insert the stats for the game you won. Please go into statistics, then choose 'reset' from the menu and try again.

    I had expected it to handle the old stuff a bit better...
  4. #284  
    When I went into stats, there were no stats there (just the stats form with dotted lines in place of data), and when I go to the menu and tap reset, it just freezes. Not sure what else to tell you.

    Regards,
    Tom
  5. markm's Avatar
    Posts
    102 Posts
    Global Posts
    196 Global Posts
    #285  
    Quote Originally Posted by TomJ View Post
    When I went into stats, there were no stats there (just the stats form with dotted lines in place of data), and when I go to the menu and tap reset, it just freezes. Not sure what else to tell you.

    Regards,
    Tom
    Yep, same here. no stats, just dots and reset freezes the game, I tried to play a round of 1 suit Aces Uo to get a quick win and I can't get it to deal. I don't get a deal dialog box and when I manually select New Deal from the menu, I get what looks like 1/2 of the new deal box at the bottom of the screen, but I can't click anything or go back. Seems to be the same in each game.
    Last edited by mmeltser; 06/03/2010 at 09:57 PM.
    Rgds/Mark M.
  6.    #286  
    sorry about that guys. I'm uploading a fix now.
  7.    #287  
    ok, 0.1.17 is up. Again sorry about that.
  8.    #288  
    Quote Originally Posted by mmeltser View Post
    Yeah, so I probably should have signed my bug reports or created an account! That would indeed be me. Good catch Tom. I'll try to narrow it down as I play some more, but it seems fairly common that when I use back swipe in the gesture area to undo, it undoes multiple steps. Instead of just moving the 3 back to the 4, it moves the 3 to the 4 the 7 back to the pile, the queen back to the king, etc. I'm sorry I don't have more specifics as to when or how many moves. I'll try to gather some data. I generally play in landscape and use the gesture to undo since there is no menu.
    Thanks, I'd really appreciate any more info you can give me. I am convinced it is happening, I'm just not sure when.

    I think it may be caused by auto play... For example, if you move a card, which exposes another card that can be auto played to the foundation then that move may not get it's own spot in the history and it should. I'll try to reproduce it as well.
  9. markm's Avatar
    Posts
    102 Posts
    Global Posts
    196 Global Posts
    #289  
    Quote Originally Posted by minego View Post
    ok, 0.1.17 is up. Again sorry about that.
    It may just be me, but I'm seeing the exact same symptoms with stats and new games here. I verified I'm running 0.1.17. I rebooted just to see if that would make any difference -- it didn't. I suppose in one way, not being able to start a new game does address the undo problem??? .
    Rgds/Mark M.
  10.    #290  
    Quote Originally Posted by mmeltser View Post
    It may just be me, but I'm seeing the exact same symptoms with stats and new games here. I verified I'm running 0.1.17. I rebooted just to see if that would make any difference -- it didn't. I suppose in one way, not being able to start a new game does address the undo problem??? .
    Well, I guess my fix didn't work... I'll keep diggin.
  11.    #291  
    I just uploaded 0.1.18, and have verified that this fixes the issue.

    I hadn't been able to reproduce the problem on my device, because I've been testing lots of stuff with the recent stats database changes and had been wiping my databases on my device by hand. There are some weird quirks with HTML5 databases on webos... For example, if you try to create more than a handful of databases it just starts to fail silently.

    Luckily I was able to reproduce the problem on my friend's phone, and after spending a while in the debugger I managed to correct the update code. The old stats databases should now be dropped correctly.

    If you're having any other problems with this please let me know ASAP. I'm very sorry about this. The last thing I want to do is to stop you all from playing solitaire.
  12. #292  
    Quote Originally Posted by minego View Post
    The last thing I want to do is to stop you all from playing solitaire.
    Well, I'm glad to see you have your priorities straight! Off to download 0.1.18....

    Regards,
    Tom
  13.    #293  
    My next goal is to improve the performance. It is really pretty bad at this point. I'm hoping I'll have time this weekend to track down the cause and fix it.
  14. markm's Avatar
    Posts
    102 Posts
    Global Posts
    196 Global Posts
    #294  
    Downloaded 0.1.18 and a quick walkthrough showed each game was able to start a new deal EXCEPT all varieties of Aces Up. The good news is it doesn't freeze anymore and properly generates the new deal dialog box which dismisses when you tap deal. The bad news is the deal is totally blank. I'll do some playing around with the other versions later tonight and see how it behaves, but I had been starting to enjoy grabbing a quick game of Aces Up while waiting for people to show up on a conference call. :-)
    Rgds/Mark M.
  15.    #295  
    Quote Originally Posted by mmeltser View Post
    Downloaded 0.1.18 and a quick walkthrough showed each game was able to start a new deal EXCEPT all varieties of Aces Up. The good news is it doesn't freeze anymore and properly generates the new deal dialog box which dismisses when you tap deal. The bad news is the deal is totally blank. I'll do some playing around with the other versions later tonight and see how it behaves, but I had been starting to enjoy grabbing a quick game of Aces Up while waiting for people to show up on a conference call. :-)
    gah, sorry about that. I had a typo. An r instead of a 4.... It should work in the next version. I'm going to try to get a few other fixes in tonight then I'll post an update.
  16.    #296  
    I've spent a lot of time tonight profiling my code, and have identified a few of the bigger problems with performance. I've got a lot more to do though, so I'll try to upload an update tomorrow. It is very tedious work, but I think it will be well worth it.
  17. markm's Avatar
    Posts
    102 Posts
    Global Posts
    196 Global Posts
    #297  
    Quote Originally Posted by minego View Post
    Thanks, I'd really appreciate any more info you can give me. I am convinced it is happening, I'm just not sure when.

    I think it may be caused by auto play... For example, if you move a card, which exposes another card that can be auto played to the foundation then that move may not get it's own spot in the history and it should. I'll try to reproduce it as well.
    I think your suspicion it's related to autoplay may be right. I entered 1 scenario I was able to capture as a comment in the bug tracker. Basically, I expected an undo to undo 2 autoplay moves and 1 actual move and, instead, it undid the 2 autoplay, and 3 actual moves. I wonder if it is counting the autoplay moves going forward but not counting them when undoing.
    Rgds/Mark M.
  18.    #298  
    Quote Originally Posted by mmeltser View Post
    I think your suspicion it's related to autoplay may be right. I entered 1 scenario I was able to capture as a comment in the bug tracker. Basically, I expected an undo to undo 2 autoplay moves and 1 actual move and, instead, it undid the 2 autoplay, and 3 actual moves. I wonder if it is counting the autoplay moves going forward but not counting them when undoing.
    There are cases when it isn't supposed to count them. For example, in klondike deal 3 if you tap on the deck it should only add one item to the undo chain. An auto play move is supposed to add to the undo chain if it was a move that the player could have done.

    For example, if you move a card, which exposes an A and that automatically moves to the foundation and exposes a 2 which automatically moves on top of that. If you then hit undo it should undo just the 2.

    I think I'll just have to go through and review each case and be sure that they are setting the right flag each time.
  19.    #299  
    A buddy of mine just figured out another cause of the undo problems...

    i figured out how to dupe the too-much-undo. do some regular moves, then grab a card and drag it around but don't wind up doing anything with it. do that N times, and undo will take back N extra "real" moves.
    Shouldn't be too hard to fix. I've ended up being pretty busy with my day job this weekend, so it may be a day or two, but at least I'm on the right track now.
  20. #300  
    Added a couple reports about the clock -- in Freecell it runs very fast (1.5x or more), especially noticeable when autofinishing at the end of the game.

    The second bug report about the clock may not be completely accurate with respect to the time the clock resets to, but it definitely doesn't reset to zero when you restart a previously quit game.

    Regards,
    Tom

Posting Permissions