Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 41
  1. #21  
    If an application has the same package id in both the App Catalog and one of the homebrew feeds (e.g. PreCentral), then that is going to cause problems.

    com.georgo.org.precaching - "Geocaching for webOS" is one such app.

    So it looks like I will need to make Preware decide to install the homebrew version in such circumstances where the package id and the version number are identical.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. #22  
    In a perfect world, different problems would present clearly different symptoms. Sigh.

    This might call for a new thread 'cause it seems my problem differes from kilroy's and, I suspect, Jayrot's.

    It seems my App Catalog _always_ hangs showing "Installing..." after the "Insalled:" notification, regardless of the ap installed or updated. Anyone else?

    Above (10th Feb) I suggested a Luna/launcher rescan to make the hung install/update magically work.

    On poking at that a bit more I've found that if I leave the App Catalog card open instead of tossing it, then the rescan actually unhangs the App Catalog which then continues normally to change the "Installing..." status to "tap to launch" as expected. And the ap icon displays normally and the ap works.

    Curiously, when I trigger a rescan (I'm using Luna Manager) with with App Catalog still open, the UI appears to hang hard for several seconds -- with the tap-ripple animation frozen in mid ripple.

    This appears independent of the application. None of my aps need need update at the moment -- I'm just testing by installing random free aps.

    Anyone else have this form of the "Installed:"/still "Installing..." problem not related to any specific aps?
  3. #23  
    I was initially seeing this issue with YouView, the YouMail WebOS client app. The developer had to modify his app so that it no longer updated through the app store and that seemed to fix the issue. I am also seeing this issue with geocaching for webos. They have not made this change so the problem still persists. It's definitely a problem with the app store, becasue once it is removed from the update process, the problem goes away. This is why installs via quick install don't have issues either. So my suggestion is, if you are seeing this issue, then try to install the app/ipk via quick install.
  4. #24  
    I have confirmed that installing via WOSQI circumvents this problem...it worked for me just now with Geocaching for WebOS. Today, the program would hang on the "Installing..." bit in the app catalog, and I could not install it from Preware. I could actually not install anything from Preware because it said an App Catalog Installation was occurring. I could not even update Preware from Preware b/c of this issue. I encourage people to use WOSQI and hope the problem does not recur and/or is fixed with 1.4 (if it actually exists).
    My Patches
    -Change Number of Bookmarks.patch
    -Change Carrier String and Color of Carrier String and Date/Time.patch
    -Increase Top Bar Font Size.patch

    If you appreciate the work or comments somebody has done, then use the thanks button to let them know!

    "Freedom isn't free"
  5. #25  
    Quote Originally Posted by jmartino2011 View Post
    I have confirmed that installing via WOSQI circumvents this problem...it worked for me just now with Geocaching for WebOS. Today, the program would hang on the "Installing..." bit in the app catalog, and I could not install it from Preware. I could actually not install anything from Preware because it said an App Catalog Installation was occurring. I could not even update Preware from Preware b/c of this issue. I encourage people to use WOSQI and hope the problem does not recur and/or is fixed with 1.4 (if it actually exists).
    Note that if WOSQI does not also include this check, and tries to install something while the app catalog is actually installing one of it's apps in the background, then it will clobber the ipkg status file and both WOSQI and Preware will show no packages installed.

    We really need to resolve why the App Catalog is reporting that it is installing something.

    Please run:

    Code:
    luna-send -n 1 palm://com.palm.appInstallService/status '{}'
    and tell me the output.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  6. #26  
    I originally noticed the problem with Code Breaker. I have also just realized that I still cannot download anything from Preware b/c of the App Catalog is Installing an App error message. I just looked in the app catalog, and I have no programs that need to be updated...not sure what the deal is. As the plot thickens, I just downloaded Super Contacts from the app catalog with no problem.
    My Patches
    -Change Number of Bookmarks.patch
    -Change Carrier String and Color of Carrier String and Date/Time.patch
    -Increase Top Bar Font Size.patch

    If you appreciate the work or comments somebody has done, then use the thanks button to let them know!

    "Freedom isn't free"
  7. #27  
    hey Rod...the output was:

    ** Message: serviceResponse Handling: 2, { "status": { "apps": [ { "id": "com.fellingsoftware.studyprofpocket", "details": { "version": "", "title": "", "vendor": "", "vendorUrl": "", "catalogId": -1, "client": "", "state": "removing" } } ] }, "returnValue": true }

    Not sure what that program is...never had anything installed called Study Professor Pocket or whatever. I had Flashcards Lite a long time ago, but I deleted it months ago.

    btw, how do you know all of these commands? Do you just have them all memorized? Your fund of knowledge is awesome
    My Patches
    -Change Number of Bookmarks.patch
    -Change Carrier String and Color of Carrier String and Date/Time.patch
    -Increase Top Bar Font Size.patch

    If you appreciate the work or comments somebody has done, then use the thanks button to let them know!

    "Freedom isn't free"
  8. #28  
    In case anyone else wants to know how to run the command that Rod posted, open up WOSQI, go to Tools, and open Linux commandline. Then, just copy and paste the code into the bottom text field.
    My Patches
    -Change Number of Bookmarks.patch
    -Change Carrier String and Color of Carrier String and Date/Time.patch
    -Increase Top Bar Font Size.patch

    If you appreciate the work or comments somebody has done, then use the thanks button to let them know!

    "Freedom isn't free"
  9. #29  
    last time clearing cache, cookies and history worked for me (in the browser). then a reset. Anyone try that?
  10. #30  
    Quote Originally Posted by jmartino2011 View Post
    hey Rod...the output was:

    ** Message: serviceResponse Handling: 2, { "status": { "apps": [ { "id": "com.fellingsoftware.studyprofpocket", "details": { "version": "", "title": "", "vendor": "", "vendorUrl": "", "catalogId": -1, "client": "", "state": "removing" } } ] }, "returnValue": true }

    Not sure what that program is...never had anything installed called Study Professor Pocket or whatever. I had Flashcards Lite a long time ago, but I deleted it months ago.
    Hmm - never seen that 'removing' state before. And I don't see any way that I will be able to distinguish that 'hung' removing state from a real removing state :-(

    If Preware was to try and install, update or remove something while the app catalog is *really* removing one of it's packages, then the ipkg database will get corrupted.

    Can you try and track down that package, and then install and remove it to see if that clears it?

    btw, how do you know all of these commands? Do you just have them all memorized? Your fund of knowledge is awesome
    Well, that command is exactly the way that Preware determines when it is safe to do things.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11. #31  
    I've also seen the same issue with YouView. I disabled the Palm-beta feed, installed via the Precentral feed, and then reenabled the Palm-beta feed to get it to work.
  12. #32  
    Quote Originally Posted by rwhitby View Post
    Hmm - never seen that 'removing' state before. And I don't see any way that I will be able to distinguish that 'hung' removing state from a real removing state :-(

    If Preware was to try and install, update or remove something while the app catalog is *really* removing one of it's packages, then the ipkg database will get corrupted.
    Well, Preware won't even let me install anything since I get an error message saying the app catalog is installing something. However, if I did download and uninstall this flashcard program (I located it, btw, it is a palm-beta app...StudyProf FlashCards Pocket, HouseOfPalm, Palm Applications and Games), then it was further ago than just yesterday when my problem started.

    Quote Originally Posted by rwhitby View Post
    Can you try and track down that package, and then install and remove it to see if that clears it?
    I tracked the program down. It is available in the Palm-Beta feed on Preware. The app catalog and preware both show that it is not installed on my phone. WOSQI has no mention of it in Device Management. When I tried to install it from Preware, it opened the Palm-Beta app preview...when I clicked Download for Free, it showed the download bar but never progressed with the download. It seemed to just hang and would not let me even x out the download. I had to throw the card away...restarted my pre for like the 10th time today...will update if anything changes.
    My Patches
    -Change Number of Bookmarks.patch
    -Change Carrier String and Color of Carrier String and Date/Time.patch
    -Increase Top Bar Font Size.patch

    If you appreciate the work or comments somebody has done, then use the thanks button to let them know!

    "Freedom isn't free"
  13. #33  
    I deleted the Geocaching for WebOS app, then reinstalled via WOSQI. It seems to be fine now. There are no other updates available so......
  14. #34  
    Quote Originally Posted by jmartino2011 View Post
    When I tried to install it from Preware, it opened the Palm-Beta app preview...when I clicked Download for Free, it showed the download bar but never progressed with the download. It seemed to just hang and would not let me even x out the download. I had to throw the card away...restarted my pre for like the 10th time today...will update if anything changes.
    I've been able to reproduce a failed install scenario, and am working on a Preware fix for that, but I have been unable to reproduce your scenario. The "removing" state should be temporary, not persistant.

    To clear it, remove the db file in /var/palm/data/com.palm.appInstallService/, and reboot.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  15. #35  
    Quote Originally Posted by rwhitby View Post
    I've been able to reproduce a failed install scenario, and am working on a Preware fix for that, but I have been unable to reproduce your scenario. The "removing" state should be temporary, not persistant.

    To clear it, remove the db file in /var/palm/data/com.palm.appInstallService/, and reboot.

    -- Rod
    thanks for the advice Rod, will try here in a few and will update...one thing I did find was that there is cryptofs data file in internal media for the app, so I did download it. Don't think this would have anything to do with the current issue since there is apparently data in there from other apps I have had previously and deleted...guess I need to do some cleaning up.

    thanks for your help thus far.

    john
    My Patches
    -Change Number of Bookmarks.patch
    -Change Carrier String and Color of Carrier String and Date/Time.patch
    -Increase Top Bar Font Size.patch

    If you appreciate the work or comments somebody has done, then use the thanks button to let them know!

    "Freedom isn't free"
  16. #36  
    Quote Originally Posted by jmartino2011 View Post
    hey Rod...the output was:

    ** Message: serviceResponse Handling: 2, { "status": { "apps": [ { "id": "com.fellingsoftware.studyprofpocket", "details": { "version": "", "title": "", "vendor": "", "vendorUrl": "", "catalogId": -1, "client": "", "state": "removing" } } ] }, "returnValue": true }

    Not sure what that program is...never had anything installed called Study Professor Pocket or whatever. I had Flashcards Lite a long time ago, but I deleted it months ago.
    Preware 0.9.26 (now in the testing feed, use the preware-bootstrap script and accept alpha versions) should fix this.

    Please test it and let me know how it goes.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. #37  
    Quote Originally Posted by rwhitby View Post
    Preware 0.9.26 (now in the testing feed, use the preware-bootstrap script and accept alpha versions) should fix this.

    Please test it and let me know how it goes.

    -- Rod
    Hey Rod, just wanted to let you know that I tried your previous suggestion of deleted the InstallHistory.db file in the path you specified using WOSQI and then restarting, but I still had the same problem afterwards. Of course, I do not know if it actually deleted it or not. I am trying Preware 0.9.26 now...problem solved! I no longer get the Error: Application Catalog is trying to install an app, please try again later.

    Thanks a bunch Rod!
    My Patches
    -Change Number of Bookmarks.patch
    -Change Carrier String and Color of Carrier String and Date/Time.patch
    -Increase Top Bar Font Size.patch

    If you appreciate the work or comments somebody has done, then use the thanks button to let them know!

    "Freedom isn't free"
  18. #38  
    I am stuck with installation failure. The apps I purchased inthe App Catalog would download but not install. I get the "install failed" error. Rebooting my Pre didn't help. I didn't have any patches before. I installed Preware and Migration Helper but to no avail. There is no way to request a refund from Palm. My emails went unanswered. Even worse, I can't even update the apps I already had on my phone. Please help.
  19. #39  
    Quote Originally Posted by mikeoleleforpre View Post
    I am stuck with installation failure. The apps I purchased inthe App Catalog would download but not install. I get the "install failed" error. Rebooting my Pre didn't help. I didn't have any patches before. I installed Preware and Migration Helper but to no avail. There is no way to request a refund from Palm. My emails went unanswered. Even worse, I can't even update the apps I already had on my phone. Please help.
    OK, which of the debugging techniques or solutions earlier in this thread have you tried already, and where are the posted results of those?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  20. #40  
    Hi Rod,
    I did Preware 0.9.26 but don't know how to run preware-bootstrap script. Sorry for my ignorance.
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions