Page 1 of 3 123 LastLast
Results 1 to 20 of 59
  1. ABQMD's Avatar
    Posts
    62 Posts
    Global Posts
    71 Global Posts
       #1  
    Nice changes in Classic 2, including no freezing after sleep now. Bu twhen I tried to AutoUpdate OTA in ePocrates, Classic throws an error at the middle of the sync saying "Illegal Operation: The application <Rx> performed an illegal operation and cannot continue." So nothing actually gets updated. Just earlier today I sync ePocrates without problem in Classic 1.3. So, which program is the issue with, ePocrates or Classic 2? This will be a major problem for us health care professionals that rely daily on Classic and ePocrates.
  2. #2  
    I just tried epocrates update, it crashed classic and totally bricked the emulater. I cannot open classic without it saying error program <> illegal....
    I did safemode then soft reset then hard reset, then uninstall reset phone re-install, and still busted at each stage nada, cannot use classic at all. This is a huge problem, obviously. It even froze my pre when I tried to open classic on my last try.

    really need help here classic.
    also anyone else do not sync epocrates if you can avoid it.
  3. #3  
    All,

    This is incredibly frustrating and to the extent that I am about to take the Palm Pre BACK to Sprint, pay my money and get out of my contract! To start with the WebOS 1.2 and 1.2.1 seemed to stop OTA updates of Epocrates under Classic 1.X Yesterday I upgraded to Classic 2.0 and all I get is the same fatal error message that others get followed by closure of Classic. Any attempt to do an OTA update resulted in the error screen. This error persisted under both Safe mode and normal mode with sound and other extras turned off

    Thinking that something became corrupted with Classic 2.0 and Epocrates I deleted Epocrates and downloaded a fresh copy to Classic 2.0. Now it appears that Epocrates will try to install and then hang at the same fatal error and I am now unable to install it. This is absolutely crazy and I cannot be without Epocrates. Something changed in Classic 2.0 that has made this valuable program useless. Does the Classic representative here have any suggestions regarding this. I will cut and paste this in the Epocrates forum as well.

    Regards,

    Jim
  4. #4  
    We recreated the issue on our side. Also, we’re already on a thread with Epocrates and we’ll be debugging regarding this together.

    Here is what we determined: the update starts and Classic will most likely crash. If it is restarted, it will complete the update and continue working well (sometimes with additional crashes and sometimes without any). But we cannot offer this as a workaround, because this might not happen for all the users – it seems that “resolution” after restart/crash happens only if Epocrates update is stopped/broken at particular files or part of files. We did not manage to “catch” the pattern yet, but again, we’ll probably be able to do this together with Epocrates.

    We will keep you posted.
    Follow us on Twitter

    Hang out with us on Facebook

    Stay Tuned with news and updates on our blog
  5. #5  
    Please say it isn't so. I just got my Pre yesterday and was planning to install ePocrates today. Glad I checked this thread. Guess I'll have to wait and rely on my old Palm T/X just a little longer. To ePocrates: Please get that native WebOS version to us post haste! I need my ePocrates and was hoping to ditch my old T/X.
  6. #6  
    Quote Originally Posted by Classic by MotionApps View Post
    We recreated the issue on our side. Also, we’re already on a thread with Epocrates and we’ll be debugging regarding this together.

    Here is what we determined: the update starts and Classic will most likely crash. If it is restarted, it will complete the update and continue working well (sometimes with additional crashes and sometimes without any). But we cannot offer this as a workaround, because this might not happen for all the users – it seems that “resolution” after restart/crash happens only if Epocrates update is stopped/broken at particular files or part of files. We did not manage to “catch” the pattern yet, but again, we’ll probably be able to do this together with Epocrates.

    We will keep you posted.
    thanks for the work, any ETA is appreciated

    Epocrates is a deal breaker for me, I got the pre because of the this ability, it is required at my school
    There are four lights.
  7. #7  
    Quote Originally Posted by Classic by MotionApps View Post
    We recreated the issue on our side. Also, we’re already on a thread with Epocrates and we’ll be debugging regarding this together.

    Here is what we determined: the update starts and Classic will most likely crash. If it is restarted, it will complete the update and continue working well (sometimes with additional crashes and sometimes without any). But we cannot offer this as a workaround, because this might not happen for all the users – it seems that “resolution” after restart/crash happens only if Epocrates update is stopped/broken at particular files or part of files. We did not manage to “catch” the pattern yet, but again, we’ll probably be able to do this together with Epocrates.

    We will keep you posted.
    I have tried TWO methods now to re-install Epocrates. Method one uses the Install folder under Classic Apps with the Pre in USB mode and that clearly fails just like described above. Method two involves using the native Epocrates installer for Windows and using the HotSync method that we used to use with the old Palm Garnet operatiing system. This seems to install needed files but never gets to the point of being able to install OTA. Once you get to the screen to apply the user name and password and then connect it dumps into a fatal error and crashes.

    My advice to users who have upgraded to Classic 2.0 and WebOS 1.2.1 is that if you already have Epocrates installed, use it and do not worry about OTA updates at this time until this issue is fixed. Do NOT and I repeat, Do NOT uninstall Epocrates and then try to reinstall. It is better to have a functioning version that is slightly out of date than none at all. For me this is a critical issue and, if not fixed within the next week, will result in me terminating my contract with Sprint and going to IPhone. I cannot do without this application at the bedside. Of all the medical applications that I use Epocrates and CodeBlue are the most valuable.

    The other issue I wish MotionApps would address is a way to avoid the nagging "this application is not Classic Certified screen." After about the 100th appearance I am thinking, "enough already." I know. I know.

    God speed in getting this repaired. I would gladly have Epocrates functionality over HotSync functionality.

    Regards,

    Jim
  8. #8  
    I'm getting a similar problem as was noted above. I wasn't using epocrates at the time, though. I had updated to Classic 2, then I wanted to install the new free apps that come with it. As they were downloading, I switched out of Classic for some web browsing. When I switched back to classic, I got the "The application <> performed an illegal operation..." error. I've tried reinstalling Classic, to no avail. Also have done soft and hard resets on the emulator, as well as soft-resetting my phone. I'm gonna subscribe to this thread. hopefully something gets done soon. I'm more than a little irked that I had to pay $30 to get a non-native epocrates on my phone in the first place, so now than I'm without it, it's just over the top.
  9. #9  
    Quote Originally Posted by DrCJ View Post

    Do NOT and I repeat, Do NOT uninstall Epocrates and then try to reinstall.



    God speed in getting this repaired.

    I would gladly have Epocrates functionality over HotSync functionality.

    Regards,

    Jim

    very much agreed. I am not on a clinical rotation now, but in two weeks I absolutely need this for an ID rotation. I really do not want to go back to carrying two devices around. I have an old winmo phone that works, but its slower and less responsive touchscreen wise, plus, its extra bulk.

    If its possible I would take a different version. perhaps a way of rolling pack to post webOS 1.2.1 and pre classicOS 2.0 could be made available?
  10. RoboCAD's Avatar
    Posts
    41 Posts
    Global Posts
    42 Global Posts
    #10  
    I am getting the same error message and I don't have (and have never had) epocrates installed.
    It began after I got BT hotsync to work. Now Classic gives me that same message: "the app <> performed an illegal operation..." even if I'm not in an app but just on a launcher page, after a few minutes of having Classic open.
    Classic is now totally unusable (and I use it all the time for reading iSilo books).
  11. #11  
    i installed my epocrates fine but i couldnt get my John Hopkins ABX Guide OTA update to work.
  12. #12  
    Quote Originally Posted by bulls96 View Post
    i installed my epocrates fine but i couldnt get my John Hopkins ABX Guide OTA update to work.
    Which method did you use to install Epocrates? Did you do the USB install to the Install Folder under Classic app or did you use the Hotsync method? I am interested to see how you did that.

    Also, is this the Skyscape version of Epocrates or an older Palm version?

    Regards,

    Jim
  13. #13  
    Quote Originally Posted by windzilla View Post
    very much agreed. I am not on a clinical rotation now, but in two weeks I absolutely need this for an ID rotation. I really do not want to go back to carrying two devices around. I have an old winmo phone that works, but its slower and less responsive touchscreen wise, plus, its extra bulk.

    If its possible I would take a different version. perhaps a way of rolling pack to post webOS 1.2.1 and pre classicOS 2.0 could be made available?
    The frustration of this update is just enormous. I have NOTHING to fall back on now since I donated my old Treo 750 and this just irritates the living crap out of me. Personally, going from a functional Classic without Hotsync, to one that errors out on almost every application launch is just crazy. The Hotsync is just a small part of the user experience. If the user cannot make the remaining interface work, then the program becomes useless.

    I am appreciative of the Motion App representative member here in this forum, and wonder if Motion App ever bothered to query working physicians regarding their use of mission critical medical applications? This is a major issue since the Classic interface has now rendered many of my applications useless. Imagine a classic cardiac arrest and trying to use a critical program only to error out. This never happened with the previous version of Classic.

    I am going to give Motion App and Epocrates until Friday, October16, 2009 to find some remedy for this situation either as a downgrade to the previous version of Classic or an upgrade that works. If nothing works by then I am going to my local Sprint Store and paying the early termination fee and going to the IPhone. I cannot perform my duties without many of these applications. Fortunately there are working versions on the IPhone including the JHH Antibiotic Guide and Epocrates.

    Regards,

    Jim
  14. #14  
    What the hell... Just finished eating my lunch, and when I went back to check my phone, Classic was running and said that it had updated. Now it works! Unfortunately, I can't find epocrates anywhere. Guess it's time for a reinstall.
  15. #15  
    We’re working together with Epocrates on this and hopefully will be able to address the issue ASAP.

    In the meantime, this is what a user reported to us in Classic Well (Classic Well - MotionApps)

    Fizer70 says:
    “I have ePocrates Essentials (not deluxe). I initially installed it over WiFi and it seemed to lock up during the sync stage at about the 2 minute mark saying that it had done some sort of illegal instruction. The program worked partially with the Rx and Dx working, but Sx and ID as well as some of the add-ons were non-functional due to the database not being present. I tried to do a re-install over the old install by putting the PRC back in the install folder, but it crashed again but this time the app was broken. I did a "Hard Reset" changed the Classic setting to Emulation Mode "Safe" and re-installed the app over WiFi and it installed perfectly and runs well!”

    You can try this workaround while we work on addressing the issue.

    If you decide to try this workaround, please post your results, so that all of users depending on this app can benefit.
    Follow us on Twitter

    Hang out with us on Facebook

    Stay Tuned with news and updates on our blog
  16. #16  
    How do I perform an install over WiFi? Is there a web browser in Classic? Installing over WiFi requires users to navigate to get.epocrates.com. I don't know how to do it in Classic. The epocrate website also states "Please note: Palm Pre requires a Cable Install and is not compatible with Epocrates Essentials Deluxe."

    It's only wrong on one point, and that's the fact taht the deluxe version does work, at least with version 1 of Classic. I just tried downgrading to the free version of epocrates and it still does not work in classic. Get an <autoupdate> error after the install.
  17. #17  
    Quote Originally Posted by Classic by MotionApps View Post
    We’re working together with Epocrates on this and hopefully will be able to address the issue ASAP.

    In the meantime, this is what a user reported to us in Classic Well (Classic Well - MotionApps)

    Fizer70 says:
    “I have ePocrates Essentials (not deluxe). I initially installed it over WiFi and it seemed to lock up during the sync stage at about the 2 minute mark saying that it had done some sort of illegal instruction. The program worked partially with the Rx and Dx working, but Sx and ID as well as some of the add-ons were non-functional due to the database not being present. I tried to do a re-install over the old install by putting the PRC back in the install folder, but it crashed again but this time the app was broken. I did a "Hard Reset" changed the Classic setting to Emulation Mode "Safe" and re-installed the app over WiFi and it installed perfectly and runs well!”

    You can try this workaround while we work on addressing the issue.

    If you decide to try this workaround, please post your results, so that all of users depending on this app can benefit.
    Where are we with the fix. I did a Hard reset and then tried to restore with backup and still no joy. Really frustrating and really not what I had anticipated for this phone or for Classic.

    Regards,

    Jim
  18. #18  
    Quote Originally Posted by DrCJ View Post
    Which method did you use to install Epocrates? Did you do the USB install to the Install Folder under Classic app or did you use the Hotsync method? I am interested to see how you did that.

    Also, is this the Skyscape version of Epocrates or an older Palm version?

    Regards,

    Jim
    i had the setup.prc on my virtualcard, then it updates over wireless.

    and i have the JHABx Guide old version, not the skyscape one.
  19. #19  
    Thanks, I wish I had kept the old JHH ABx Guide. I will try Setup.Prc on the virtual card and see what happens.

    Regards,

    Jim
  20. #20  
    How do you put the setup.prc file on the virtual card? I don't see a folder.
Page 1 of 3 123 LastLast

Posting Permissions