webOS Nation Forums >  Stuff for your webOS Device >  webOS Apps & Games > Email for Dummies!
Email for Dummies!
  Reply
 
Thread Tools Display Modes
Old 07/24/2009, 09:58 AM   #1 (permalink)
Member
 
Posts: 14
...and I'm the dummy in this scenario. So... since getting the Pre, I have not been able to gain access to my work email through Exchange. My IT people gave me the correct server name and domain but still no luck.

I've been reading message boards and found this to be a common problem so I was like... thank God it's not just me! Then I heard about this upcoming update (1.1) that would remedy the issues with EAS.

I got the update last night and quickly went to set-up my email... but I *still* got the same error (blah blah... make sure time and date correct... blah blah).

Am I not doing something correctly?? Please help Pre community... this was one feature that I needed above all else. Thanks in advance!
JackStorm is offline   Reply With Quote
Old 07/24/2009, 10:29 AM   #2 (permalink)
Member
 
ryleyinstl's Avatar
 
Posts: 4,228
What is the error message you are getting? What are your e-mail settings for your connection to the EAS server? Does your company use SSL? If so did you install your companies root certificate on the Pre (if your company is self signing)? Ect..........

Need more info to help you.
ryleyinstl is offline   Reply With Quote
Old 07/24/2009, 11:00 AM   #3 (permalink)
Member
 
Posts: 2
I was waiting for this update so I could finally access my company's email. I fill out the forms for EAS and I get the message "Unable to validate incoming server settings." I have tried variations of the login information. I reset my phone. What does this phone want from me?
Juliane McCann is offline   Reply With Quote
Old 07/24/2009, 12:13 PM   #4 (permalink)
Member
 
Posts: 14
I got the same error message as Juliane... "Unable to validate incoming server settings. Please check the correct date and time."

In regards to the company using SSL... this was the response I got from my IT dept. "We do not plan on getting an SSL cert for that URL. Can't you just bypass the SSL warning?"

They are not very helpful and they are certainly not familiar with and have no interest in helping with the Palm Pre.
JackStorm is offline   Reply With Quote
Old 07/24/2009, 02:26 PM   #5 (permalink)
Member
 
Posts: 27
Quote:
Originally Posted by JackStorm View Post
I got the same error message as Juliane... "Unable to validate incoming server settings. Please check the correct date and time."

In regards to the company using SSL... this was the response I got from my IT dept. "We do not plan on getting an SSL cert for that URL. Can't you just bypass the SSL warning?"

They are not very helpful and they are certainly not familiar with and have no interest in helping with the Palm Pre.
When you enter the mail server URL, change the https to just http. If you're not using SSL (which is stupid, but beside the point), this should work. Just be aware that you're transmitting data in clear text.
richardhkirkando is offline   Reply With Quote
Old 07/24/2009, 02:46 PM   #6 (permalink)
Member
 
Posts: 14
Quote:
Originally Posted by richardhkirkando View Post
...change the https to just http.
I had heard that one before and tried that but no luck. In fact, the error changes to invalid server settings. :-(
JackStorm is offline   Reply With Quote
Old 07/24/2009, 07:11 PM   #7 (permalink)
Member
 
Posts: 174
Quote:
Originally Posted by Juliane McCann View Post
I was waiting for this update so I could finally access my company's email. I fill out the forms for EAS and I get the message "Unable to validate incoming server settings." I have tried variations of the login information. I reset my phone. What does this phone want from me?
Are you using /exchange at the end of the server address? From my experience, the error message you're getting is because the server URL is wrong. Double check that you just have https://servername.company.com

Quote:
Originally Posted by JackStorm View Post
I got the same error message as Juliane... "Unable to validate incoming server settings. Please check the correct date and time."

In regards to the company using SSL... this was the response I got from my IT dept. "We do not plan on getting an SSL cert for that URL. Can't you just bypass the SSL warning?"

They are not very helpful and they are certainly not familiar with and have no interest in helping with the Palm Pre.
Both of you can verify that you have the address correct by opening a browser and going to that address (webmail). it should be https://server.companyname.com/exchange or whatever. Verify that you can log in, and if the connection times out try http. Once you verify that you have the correct URL, just remove the /exchange and you should be okay.

If you're company uses a self signed certificate, you should ask your IT department for one. You MAY be able to download it from the web browser and email it to yourself but it's easier to get it from them.

Let me know if this works or not.
mrsyeltzin is offline   Reply With Quote
Old 07/24/2009, 10:03 PM   #8 (permalink)
Member
 
Posts: 122
I have the same problem. I can go to my webmail (webmail.domain.com) using https:// in the browser and it works well, but when I try to use EAS I get "Unable to validate incoming mail server settings. Check the settings and try again."

I have tried several times with different accounts, but I get the same error everytime. You mention loading a cert. Please explain.

update: I've loaded my PKI certs and the certs from the webmail site into the pre, but still no luck.

Last edited by cshrader; 07/24/2009 at 11:08 PM.
cshrader is offline   Reply With Quote
Old 07/27/2009, 10:56 AM   #9 (permalink)
Member
 
rsl5150's Avatar
 
Posts: 108
I spent 1.5 hours on the phone with PALM yesterday and they told me to get the PKI certs from the IT dept. I'm heading to work now so we will see if that works.
rsl5150 is offline   Reply With Quote
Old 07/27/2009, 02:17 PM   #10 (permalink)
Member
 
Posts: 14
I am still without the ability to connect to my job's exchange server. I tried all the suggestions but to no avail.

Now this is where the "dummy" part from my message title comes in to play... I am still unclear on this whole certificate thing and how to install that. My IT department is completely unwilling to help or support me. mrsyeltzin said that I may be able to download the certificate and put it on the Pre somehow??

Someone please help this dummy! (aka ME)
JackStorm is offline   Reply With Quote
Old 07/30/2009, 02:57 PM   #11 (permalink)
Member
 
Posts: 14
So no help on a installing certificates primer? Anyone... anyone... Bueller??
JackStorm is offline   Reply With Quote
Old 07/30/2009, 03:21 PM   #12 (permalink)
Member
 
Posts: 174
Quote:
Originally Posted by JackStorm View Post
I am still without the ability to connect to my job's exchange server. I tried all the suggestions but to no avail.

Now this is where the "dummy" part from my message title comes in to play... I am still unclear on this whole certificate thing and how to install that. My IT department is completely unwilling to help or support me. mrsyeltzin said that I may be able to download the certificate and put it on the Pre somehow??

Someone please help this dummy! (aka ME)
Sorry - I didnt get an email about this response. So your IT department will not even email you the cert? That's insane because it should take them 2 minutes to do. You should be able to extract it out of your web browser though:

Go to your webmail site, log in and when you view your mailbox, and if you use IE7, click to the right of the address where it says "certificate error" (it should say this since its self signed). A box will drop down (see screenshot) and you will see the option to 'view certificate.' Click on that and you can see the contents of the certificate, which are irrelevant to you but important for your Pre. Click the "Details" tab and then click "Export to file" (see attached image) and in the dialogue box, name it (Exchange or Cert) and pick a file type - I believe .DER will work (first option in the drop down). Once done, it should be on your desktop and show up as a little certificate icon (looks like money or an award). Email that to any account that your Pre has or copy it over via USB (but its easier if you have a personal email account that can download the message).

If you get it via email, you can import the cert yourself by tapping the attachment to download and once downloaded, tap it to bring up the installation dialogue. It will ask you to 'trust certificate' and if you tap that option it will install to your cert store. If this does not work for you, try it in base 64 (the second option in certificate export), but I just tried to install as a DER and it worked for me. Hopefully this helps you out.
Attached Images
File Type: jpg Cert.JPG (27.9 KB, 11 views) Email Attachment
File Type: jpg certcopy.jpg (32.1 KB, 11 views) Email Attachment
mrsyeltzin is offline   Reply With Quote
Old 07/30/2009, 03:57 PM   #13 (permalink)
Member
 
Posts: 174
I just did some testing with this and I've noticed that after the 1.1 update you may need the root certificate as well (as I did in my case). As far as I know that is not something you can pull from a browser, as I dont see it available (when checking under the certificate path). This may require IT intervention.
mrsyeltzin is offline   Reply With Quote
Old 07/30/2009, 04:25 PM   #14 (permalink)
Member
 
Posts: 14
Dang... so the only way to get the root certificate is through my IT dept... then I'm done... they will not help... they are bastards... they don't know about the pre and therefore are not willing to help... guess I'm stuck, right?
JackStorm is offline   Reply With Quote
Old 07/30/2009, 04:33 PM   #15 (permalink)
Member
 
Posts: 174
Try the above method first. I was successfully syncing with exchange until i deleted the account to run this test and then I was unable to connect (got the time and date error). I had to install a root cert (which I already had because on WinMo you need both) so I loaded it on a whim and it worked.

I would download in both DER and base 64 formats from IE and see if either one works. If you send me a private message (once you're over 10 posts I think) with your webmail address I can see if I can extract it for you (I DONT need your username/pass).

Last edited by mrsyeltzin; 07/30/2009 at 04:50 PM.
mrsyeltzin is offline   Reply With Quote
Old 07/30/2009, 10:10 PM   #16 (permalink)
Member
 
Posts: 27
Quote:
Originally Posted by JackStorm View Post
Dang... so the only way to get the root certificate is through my IT dept... then I'm done... they will not help... they are bastards... they don't know about the pre and therefore are not willing to help... guess I'm stuck, right?
Depends on who signed the certificate. If they bought it through someone like Verisign, Godaddy, etc., you can just download the root cert from them.

If its self-signed, you still may be able to get it off your PC from the certificates MMC console. I don't remember exactly how to do that, though.
richardhkirkando is offline   Reply With Quote
Old 07/30/2009, 10:41 PM   #17 (permalink)
Member
 
Posts: 14
Welp... I tried both the DER and base 64 formats but I still get that classic line: "The server's security certificate is invalid, or your date and time is set incorrectly."

What to do... what to do??
JackStorm is offline   Reply With Quote
Old 07/30/2009, 10:46 PM   #18 (permalink)
Member
 
Posts: 14
So it looks like it's 15 posts not 10... four more to go and I will PM you... thanks!
JackStorm is offline   Reply With Quote
Old 07/30/2009, 10:59 PM   #19 (permalink)
Member
 
Posts: 174
Quote:
Originally Posted by richardhkirkando View Post
Depends on who signed the certificate. If they bought it through someone like Verisign, Godaddy, etc., you can just download the root cert from them.

If its self-signed, you still may be able to get it off your PC from the certificates MMC console. I don't remember exactly how to do that, though.
The problem here is that it IS self signed, if it were from an official CA, the root cert would be built into the Pre.
mrsyeltzin is offline   Reply With Quote
Old 07/30/2009, 11:12 PM   #20 (permalink)
Member
 
Posts: 174
Quote:
Originally Posted by JackStorm View Post
Welp... I tried both the DER and base 64 formats but I still get that classic line: "The server's security certificate is invalid, or your date and time is set incorrectly."

What to do... what to do??

Jack,

Go into your cert store (Device Info - More Options - Menu - Certificate Manager) and select the cert you installed (it will be one of the few and have your company name or company server as its name) and open it to view the data. If you scroll down to the common name field, verify that the name of the server matches what you put into the address field for the exchange server. Sometimes it is servername.website.com instead of owa.website.com. This has given me problems in the past.
mrsyeltzin is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0