Page 3 of 7 FirstFirst 1234567 LastLast
Results 41 to 60 of 132
  1. #41  
    Sorry I couldn't help keyhole_s. I removed the .IPK from the above attachment.
  2. jport1975's Avatar
    Posts
    55 Posts
    Global Posts
    56 Global Posts
    #42  
    thx
  3. #43  
    ok , fixed the .json file , if i wanted to change the name of the app , do i just change it in the .jason file ? is there anywhere else i would have to change it ?
  4. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #44  
    would you be able to tell me the commands to delete the tip app?
  5. #45  
    is your pre rooted and do you know vi ?
  6. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #46  
    my pre is rooted
  7. #47  
    Quote Originally Posted by Colonel Kernel View Post
    Sorry I couldn't help keyhole_s. I removed the .IPK from the above attachment.
    Don't even worry about it. It's all good
  8. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #48  
    man i'm lost i created a user account but i dont have access to the palm apps i'm i really lost?
  9. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #49  
    i'm not using the emulator, i'm not sure how to use it, i'm running vista and the pre is plugged in via usb. I'm using putty if that helps.
  10. #50  
    I found a minor bug. If you are trying to enter a number such as 54.08, it will not work. The zero will not register after the decimal and it will just output 548.
  11. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #51  
    Sorry but would anyone be able to tell me out to get root permission to delete the app. through command prompts?
  12. #52  
    This worked for me , I take no responsibility for anyone using it on their phone

    read all instructions before proceeding.

    Putty into your pre.

    When you are in your pre you will see

    root@castle:/#

    1. To remount the file system as read/write:

    mount -o remount,rw /

    2. edit the json file

    vi /var/usr/palm/applications/org.webosinternals.app.tipcalculatorredux/appinfo.json

    use the arrow keys to get to this line .

    "id": "org.webosinternals.tipcalculatorredux",^M

    you will insert ".app" after "webosinternals"

    use the arrow keys to move you cursor to org.webosinternals"cursor here"

    3. Press i to enter insert mode.

    type .app , make sure you don't have any extra characters

    your new line should look like this

    "id": "org.webosinternals.app.tipcalculatorredux",^M

    4. Press <ESC> to exit insert mode and go into command mode.

    5. Save and quit the file that you are editing

    :wq

    6. You should be back at root@castle:/#

    7. Remount the file system as read only

    mount -o remount,ro /

    8. exit Putty

    exit

    to delete the app hold the orange button and press the app icon.

    credit to PREGAME for the solution

    actually i found the real issue. the id was incorrect in appinfo.json you need to change ID to org.webosinternals.app.tipcalculatorredux

    Thanks.

    Note if you make a mistake and need to exit vi without saving the command is

    :q!
    Last edited by itakexrays; 07/11/2009 at 08:57 AM.
  13. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #53  
    Ok this is weird I the line shows the .app already included, and I've tried to delete after restarting the phone with the dev on and off. I'm pretty the program is hurting anything but I don't like anything I can't get rid of. Any other ideas?
  14. #54  
    dont try to delete from the app list in the launcher.

    you must delete it by holding down the orange button on the keyboard and pressing on the tip calculator redux icon.

    then select delete

    make sure that line looks like this

    org.webosinternals.app.tipcalculatorredux

    it works I just deleted it myself.
  15. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #55  
    Ok after I enter vi /var/usr/palm/applications/org.webosinternals.app.tipcalculatorredux/appinfo.json I’m unable to use the arrow keys or it really doesn’t do anything and I follow the instructions to the T. Any suggestions?
  16. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #56  
    Oh okay sorry i just noticed that the word webosinternal is missing the s at the end of it but I cant edit it...
  17. #57  
    ok I will re-install the app and do it myself .. i will make any corrections and let you know
  18. texasjack's Avatar
    Posts
    93 Posts
    Global Posts
    94 Global Posts
    #58  
    maybe this will help, this is what i get:
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    ~
    - /var/usr/palm/applications/org.webosinternal.app.tipcalculatorredux/appinfo.jsjsjs
  19. #59  
    {^M
    "title": "Tip Calculator Redux",^M
    "id": "org.webosinternals.app.tipcalculatorredux",^M
    "version": "1.0.0",^M
    "release_date": "02-Jul-2009",^M
    "vendor": "Brian Jost (Original by Jamie Zawinski www.jwz.org)",^M
    "vendor_email": "",^M
    "vendor_url": "",^M
    "type": "web",^M
    "main": "index.html",^M
    "icon": "icon.png"^M
    }^M


    works fine for me .
    I just deleted , reinstalled , edited and deleted

    but i had to try to delete it twice , before it actually deleted this time ..for some reason..

    This is not my app credit to the ones whom created this app .. Thanks
  20. #60  
    seems like that means the app is deleted and the file is not there anymore ?

    yes i got the same thing only after the app was deleted...

    If you still have the app it works fine.

    but again I had to hold the orange button and click the app and select delete twice for it to delete.
    Last edited by itakexrays; 07/11/2009 at 01:40 PM.
Page 3 of 7 FirstFirst 1234567 LastLast

Posting Permissions