Results 1 to 5 of 5
  1.    #1  
    I'm using HP BlueTooth Keyboard for my Touchpad.
    Keyboard has QWERTZ Layout (German).
    However, when typing on BT Keyboard in my TP i only got QWERTY mode, means when typing Z i got an Y and also the German "Umlaute" are not working.
    On my TP all language settings are set to German. TP touch keyboard also working in QWERTZ, but BT keyboard not

    Any idea how to switch to German QWERTZ so my TP is accepting Keyboard in German layout?
  2. #2  
    I was wondering the same thing about the Spanish layout for the BT keyboard. In a chat with HP I was told that not all of the features are supported - maybe it's possible for preware to come to the rescue? Being to use alternate characters on the keyboard would seem to be a given, but I guess not.
  3. #3  
    this works for me, i've tried it out webos 3.0.2
    finally qwertz on hp touchpad with webos 3.0.2 and bluetooth keyboard
    http://forums.precentral.net/hp-touc...ml#post3156154
    even survived reboot and works in ubuntu-chroot (althou with no german umlauts) too !!!!

    EDIT: just found some minor drawback: the < and > signs are not correctly mapped on my apple bluetooth keyboard, i can't find €

    EDIT: | is right alt-key and ^ or right-alt-key and -
    @ is right-alt-key and q
    for "esc" key press (not hold) Ctrl followed by reight Alt Key with [ (which is number 8 on german apple keyboard is you have replaced the keymap file with the suggestion from the link, and yeah, finally vi works...)
    Last edited by mark_twain; 09/17/2011 at 06:05 AM.
  4. #4  
    Any hints, to solve the starters problem?
    With my new Microsoft BT keyboard with German Map and webOS 3.0.4 Im having the same issue: Z instead of Y and vice versa and no "Umlaute".
    All settings are "German" and "Germany", also having the virtuell keyboard with German map thanks to the homebrew solution?
    Would be very happy, to hear some ideas on this.
    Thanks,
    Thomas
  5. #5  
    Now I got the solution, maybe not to every keyboard, but for the Microsoft one and some others, it is working:
    1. With InternalzPro you have to find the file hid.j in the "var" folder.
    2. Open it.
    3. Change CountryCode to 9 and correct "praserVesion" to "praserVersion".
    4. Save this.
    5. Restart the Touchpad.

    Now, everything is working fine to me: I got the German keyboard map and @ is AltGr+Q.

Posting Permissions