Results 1 to 5 of 5
  1.    #1  
    I just got a Seidio 2600mAh battery and so far I'm amazed. But here is the issue I'm having now. I'm 4 days into it and day 2 and 3 the phone seemed to go all day. And both days late in the night the phone would die when the it said there was still 60 percent left. Then the phone would turn off and I would have to plug it in. Once it started to charge the phone would come on an would display 8%. Anybody else have this issue. Is it a fluke? Is the phone getting used to the new battery?
  2. #2  
    Probably a bad battery. I had one and Seidio replaced it. Just call them.
  3. #3  
    Quote Originally Posted by jordoncarlsen View Post
    I just got a Seidio 2600mAh battery and so far I'm amazed. But here is the issue I'm having now. I'm 4 days into it and day 2 and 3 the phone seemed to go all day. And both days late in the night the phone would die when the it said there was still 60 percent left. Then the phone would turn off and I would have to plug it in.
    Check out the Dr. Battery thread and download the app. See what the battery health shows, you can try calibrating the battery but some Seidio batteries are rip-offs. You don't get what you pay for. The 2600mAh batteries are only 2300 mAh, but from what you are describing, yours definitely has problems and is probably defective.

    Personally, I wouldn't purchase anything from Seidio, chances are you will get screwed, like the people in this thread did.
  4.    #4  
    It's seems like the phone is operating normally now. No more suden drop. This battery is great. I was always having to scramble to charge the phone by around 3 p.m. with the original 1150 mah battery. Now I can go almost 2 days on a full charge with the 2600 mah. It was just hard for me to justify investing $50 in the battery when a new palm device is on the horizon. But after the 1ghz overclock and this battery I'm real happy with the phone now.
  5. #5  
    You should have a year warranty on it. Return that batt it's defective. I'm using a mugen 1400.. with no issue at all.

Posting Permissions