Results 1 to 10 of 10
  1.    #1  
    I just purchased my Touchstone today, so maybe this is normal behavior, but when I put my Pre Plus on the Touchstone, it was about 75-80% full. It was charging for more than an hour, and it only charged up to 95%. Plus, when I took the phone off of the Touchstone, the phone seemed particularly warm.

    Is this normal? Does it normally take a long time to charge up on the Touchstone? Does it normally heat up your phone?

    I'm glad I only paid $20 for the thing at Radio Shack. If I'd paid full price, I'd be irritated.
  2. #2  
    The TS usually charges at a similar rate to the usb plug in so should have been faster to charge and the heat does not sound right.
    Try putting the pre on the TS, make sure it goes to the lock screen and stays on the lock screen, make sure it is not cycling between the charging notification.
  3. #3  
    If that doesnt work just return it to radio shack and get another one
  4. #4  
    It is normal for your phone to get warm when using the TS. As far as it not charging completly, try taking off the back and putting it back on, perhaps it wasn't making good contact.
    Last edited by vza33; 05/12/2010 at 06:29 PM.
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  5. #5  
    Mine just stopped working the other day =(
  6.    #6  
    I think I may have figured out the "not charging to 100%" issue. I downloaded the patch that forces the battery indicator to show actual battery charge instead of the GUI version, and the actual battery charge seems to run 4-5% lower than the GUI version. That could explain it.
  7. #7  
    definitely will get warm. If you ise it on the touchstone and have all the radios on, it will get warm.
  8. #8  
    It probably charged up to 100% and then stopped charging. When your Pre drops below 95% it will begin charging again. It is normal for the phone to get warm when on the TS charger.
  9.    #9  
    Quote Originally Posted by netwrkr9 View Post
    It probably charged up to 100% and then stopped charging. When your Pre drops below 95% it will begin charging again. It is normal for the phone to get warm when on the TS charger.
    Ah ... there's a reasonable explanation. I get it now. Thanks!
  10. mhous33's Avatar
    Posts
    99 Posts
    Global Posts
    108 Global Posts
    #10  
    My touchstone worked great for just over the 30 day return limit. Now it charges to 95%, then starts decreasing the longer it stays on.
    I ordered a pre plus a couple weeks ago and sent it back because it wouldn't charge on this touchstone at all. The TS just made a weird clicking noise when i put the pre plus on it, then worked fine when i put the pixi plus on it. Wonder if the pre plus somehow messed up the TS?
    I like the convenience of the TS, but i think i like the speed and reliability of a direct plugin better, even with the hard to open usb cover lol. Testing now to make sure it still goes to 100% with the wall charger.

Posting Permissions