Page 2 of 2 FirstFirst 12
Results 21 to 24 of 24
  1. #21  
    We have a total of 5 touchstone chargers in our family and for almost a year now we have never had a problem with any of them, so if you are having issues, take the defective unit back, simple.
  2.    #22  
    Like I stated earlier, I changed my ts once but to no avail. I am now away from home for up to a month so will not be able to change anything until then, so am relying on my ts solution, which is working great.
    by the way, I folded some sellotape about 5 times on itself and then stuck one strip to the p and one to the m using sellotape. This works great for me
  3. #23  
    This may be some what unrelated but I think it falls under the same category. My wife and I both have TS and they started switching between charging and not charging rapidly. The solution was to install a surge protector and plug them into that instead of the wall directly.
  4.    #24  
    Quote Originally Posted by beantastic View Post
    This may be some what unrelated but I think it falls under the same category. My wife and I both have TS and they started switching between charging and not charging rapidly. The solution was to install a surge protector and plug them into that instead of the wall directly.
    Thats interesting, its worth a try for some people. However I did thoroughly check my electrics, Made sure that the TS was passing a steady current and voltage through the back door of the pre and it was, still dont understand why my pre was playing up when it has got the tap on the p and m. Might try a surge plug sometime though, see if does make a difference for me.
Page 2 of 2 FirstFirst 12

Posting Permissions