Results 1 to 8 of 8
  1.    #1  
    I ordered 2 touchstones recently and they work great. I decided to order another one for the office. Just got it. It seems the phone has to be in a perfect spot on the touchstone for it to charge otherwise I get the charging battery notification popping up and down. I have to keep moving it till its right. The other touchstones I have work just fine. Is there something wrong with this new one?
  2. #2  
    I just got a pair of Touchstones the other day. One worked perfectly from the start and the other acted very goofy doing the same thing yours is doing. The goofy one would also lose cell service when I placed my phone on it to charge.

    After doing some research on the forum here I noticed that many people stated that a Touchstone behaving in the manner you described most likely had bad hardware and you should go back to the store or contact Palm for a new one. Mostly because I am lazy and stubborn I waited to return it and had two days of goofy problems with the thing and ever since then it has worked fine. I would say if it keeps up, and you are not as lazy as I am, try to exchange it for one that works properly.
  3.    #3  
    Quote Originally Posted by pkisme View Post
    I just got a pair of Touchstones the other day. One worked perfectly from the start and the other acted very goofy doing the same thing yours is doing. The goofy one would also lose cell service when I placed my phone on it to charge.

    After doing some research on the forum here I noticed that many people stated that a Touchstone behaving in the manner you described most likely had bad hardware and you should go back to the store or contact Palm for a new one. Mostly because I am lazy and stubborn I waited to return it and had two days of goofy problems with the thing and ever since then it has worked fine. I would say if it keeps up, and you are not as lazy as I am, try to exchange it for one that works properly.
    Im just as lazy as you are I only bought all these touchstones cuz my old man got a pre plus and i have a pre. The issue happens with his pre plus. if I put my pre on this problem touchstone, it works just fiiine for me. Weird huh?
  4. #4  
    Take em back. They are not working properly
  5.    #6  
    Quote Originally Posted by stu5797 View Post
    Take em back. They are not working properly
    it will work fine for one phone but the other one not so good. I thought maybe it's the back but that works on my other touchstones.
  6. katsnuts's Avatar
    Posts
    59 Posts
    Global Posts
    71 Global Posts
    #7  
    After I pulled about half my hair out on this one...I bought a new charger to connect into my Touchstone and it solved the problem.

    If you have a faulty charger (bad wires, inconsistent charge, etc.) the Touchstone freaks out. Even if you can normally charge the Pre by plugging it into the same charger, Touchstone is very "touchy" with certain chargers.

    Try out a different mini-usb connection and it should work...the BRAND NEW charger solved all my problems regarding this topic.

    JB
  7.    #8  
    Quote Originally Posted by katsnuts View Post
    After I pulled about half my hair out on this one...I bought a new charger to connect into my Touchstone and it solved the problem.

    If you have a faulty charger (bad wires, inconsistent charge, etc.) the Touchstone freaks out. Even if you can normally charge the Pre by plugging it into the same charger, Touchstone is very "touchy" with certain chargers.

    Try out a different mini-usb connection and it should work...the BRAND NEW charger solved all my problems regarding this topic.

    JB
    This problem touchstone works just fine with my pre. It doesnt work well with my dads pre. I dont think it can be the back of his pre because that phone work just fine on 2 other touchstones. This is one weird situation.

Posting Permissions