Results 1 to 15 of 15
  1.    #1  
    I've had to replace my Pre once, about 2 weeks after purchase, the microphone on the device went out and I replaced it for a new one.

    But I've had to replace the car charger three times. It is the Sprint "PRE" charger that glows yellow when plugged in. The problem is always the same, the charger works for a few days, the yellow glow goes out.... the charger doesn't work. Now, on my 4th charger, after a fews days of use... the charger dies. I've had two chargers on one phone, two on the other. Four dead chargers. So I don't think it is the phone, maybe not the charger? Could it be the voltage on my VW bug? or something else? Should I buy a PALM Pre charger... or do you think it will suffer the same fate as the SPRINT PRE chargers?

    Now I do keep the charger plugged in all the time? Can this be a problem?
    I used to always keep my Centro charger plugged in... never has been a problem.

    Your opinions would be greatly appreciated.
  2. #2  
    I had to replace my first charger due to loose fitting with the Pre slot. Between the Pre issues, and the charger I was just about to call it quits.

    My charger hasn't died though. Maybe check if it's plugged in tightly.
  3. #3  
    for the car charger to work, screen on the Pre must be OFF before plugging the charger in.

    again, turn screen off first, wait 5 seconds, then firmly plug charger in.
  4. #4  
    I use an ac inverter. I've not had a single problem with it regardless of the screen being on or off. Costs just about the same and gives me none of the problems that people are describing.
  5. #5  
    Is it an old VW Bug (like 1960s)?

    If old VW, then it might be ignition noise killing the charger. This would cause large spikes on the 12-14 volts. Maybe bad points and/or capacitor?

    Or another possibly is a bad voltage regulator (>14Volts)? This can be checked with a volt meter. FWIW - I had a bad voltage regulator on one of my vehicles, and it caused some strange problems.
  6. #6  
    The LIGHT on my car charger has died, after flickering for a few days, but it still charges my Pre, so I don't care.
  7. #7  
    Quote Originally Posted by trim81 View Post
    for the car charger to work, screen on the Pre must be OFF before plugging the charger in.

    again, turn screen off first, wait 5 seconds, then firmly plug charger in.
    My only problem with the Sprint charger is that sometimes it takes a lot of tries (plugging/unplugging) to get it to register the Pre. This is probably my problem ^.

    I did pick up a friends Cobalt the other day, and put some unit bearings on it at my buddies trans shop the other day. She had a Rant I think, and had the micro USB car charger. The Sprint light had stopped working from leaving the charger plugged in all the time, but the charger still charged my phone.
  8. IMethos's Avatar
    Posts
    487 Posts
    Global Posts
    497 Global Posts
    #8  
    my charger died. it flickers for days and then it dies and wont charge the phone anymore. i just had it exchanged. hopefully this one works!
  9. #9  
    Quote Originally Posted by chrisgloor View Post
    Should I buy a PALM Pre charger... or do you think it will suffer the same fate as the SPRINT PRE chargers?
    I think there were posts here a while back that the Palm chargers had issues.

    Is the plug you're using always hot, even when the car is off?
  10. #10  
    Quote Originally Posted by Lucidlore View Post
    I use an ac inverter. I've not had a single problem with it regardless of the screen being on or off. Costs just about the same and gives me none of the problems that people are describing.
    Found this post via search. What rating is your inverter? I have a 175 Watt inverter in my car, and I seem to be having some issues charging it. Any tips?

    Anyone can respond, I didn't want to start a new thread if this one already existed.

    Thanks.
  11. #11  
    I got a charger at the dollar store $6 works fine and it came with a bunch of misc tips that can use for other phones.
  12. #12  
    Quote Originally Posted by a dumb cat View Post
    Found this post via search. What rating is your inverter? I have a 175 Watt inverter in my car, and I seem to be having some issues charging it. Any tips?

    Anyone can respond, I didn't want to start a new thread if this one already existed.

    Thanks.


    Amazon.com: Xantrex Technologies 851-0178 XPower 175-Watt Micro Inverter: Home Improvement

    I use this Xantrex to charge my Pre without issue. It charges even with gps going, something usb wouldn't do. I have had it a few years. I have also used 1800 watt Xantrex inverters (hardwired to batteries) in a bigtruck running computers, fridges, and power tools. I give them two thumbs up.
  13. #13  
    I have the Palm car charger. It's kind of prcy but I haven't had any trouble with it.
  14. art_sjc's Avatar
    Posts
    66 Posts
    Global Posts
    68 Global Posts
    #14  
    Quote Originally Posted by trim81 View Post
    for the car charger to work, screen on the Pre must be OFF before plugging the charger in.

    again, turn screen off first, wait 5 seconds, then firmly plug charger in.
    That's kind of a ridiculous requirement for a car charger. Any idea why it's needed?
  15. Cubs Win's Avatar
    Posts
    71 Posts
    Global Posts
    86 Global Posts
    #15  
    I just ordered a Sprint OEM car charger for the Pre from the Amazon Marketplace last night and received an order cancellation today indicating that Sprint had issued a recall on the item. I guess I'll hold off for awhile and see if they release an updated model.

Posting Permissions