webOS Nation Forums >  Homebrew >  TouchPad Patches > Synergy Messaging Plugins for the Touchpad
Synergy Messaging Plugins for the Touchpad
  Reply
Like Tree30Likes

 
Thread Tools Display Modes
Old 08/03/2012, 07:22 AM   #161 (permalink)
Member
 
Posts: 6
Ok... Further messing showed that if i leave the touchpad without internet connection for a long time (at night for example) then it won't reconect. Contacts are shown as online, but in fact they aren't
tonellobello is offline   Reply With Quote
Old 08/03/2012, 09:49 AM   #162 (permalink)
Member
 
Posts: 18
Quote:
Originally Posted by steven_farkas View Post
i would love this as well, but i think the requirement for certificates may pose a problem? (then again maybe not, I'm no dev! )

for a workaround, I use officetalk in android. at the moment its the only way I know to use OC on the touchpad
hi just realized...

oddly, i am able to log in to my organization's Office Communicator on linux without a class b certificate.

i also do have a class b installed onto the veer and touchpad but it seems that they have added anything.

cheers!
__________________
Long Live Web0S!

Zire 71 > Tunsgten T|X > Tungsten T|3 > Treo 650 > Treo 680> HP Veer 4G && HP Touchpad
illuniel-webos is offline   Reply With Quote
Old 08/12/2012, 12:28 PM   #163 (permalink)
Member
 
stickerboy's Avatar
 
Posts: 101
Yes! Finally MSN that works on my Pre3 - just need to wait on my touchpad recharging to test it there. Awesome work!
__________________
|| Flickr || Twitter ||
stickerboy is offline   Reply With Quote
Old 08/12/2012, 02:31 PM   #164 (permalink)
Member
 
Posts: 4
Could you possibly add Steam support to this? OpenSteamWorks supposedly now works without the need to run a Steam client in the background.

pidgin-opensteamworks - Steam Friends plugin for Pidgin (libpurple) - Google Project Hosting

-God Ginrai
God Ginrai is offline   Reply With Quote
Old 08/14/2012, 02:01 AM   #165 (permalink)
Member
 
Posts: 5
Quote:
Originally Posted by filmor_ View Post
As discussed in Synergy Messaging Plugins (WebOS 2.X) I've been working on a new implementation of the Messaging plugins for the Touchpad. This post is the first release milestone (TADA). It adds account templates for ICQ, MSN, Facebook, generic Jabber, Groupwise and Yahoo.

Don't expect this program to not eat your head. I give absolutely no warranties whatsoever (besides saying that I still have my head and it works for me).

Updates:
The newest version fixed some weirdness in adding the buddy list, should have improved performance on that a bit and especially partially fixed the Mojo validator to actually make use of what you enter in the text fields. Not many changes this time, but I'm on a vacation next week and wanted to get at least these few out

There are some quirks left that I intend to fix, although I'd really appreciate patches for this:
- Localisation is missing (need some gettext mage on this one )
- cyrus-sasl doesn't work properly currently, thus some XMPP servers (like Google Talk) could be problematic
- Modifying accounts has to be implemented (though that should be trivial)
- The Mojo validator doesn't show error dialogs
- Groupwise using SSL doesn't seem to work

The sources are at https://github.com/filmor/webos-messaging
The ipkg is at https://github.com/downloads/filmor/....9.3_armv7.ipk
This should be compatible with the Touchpad (3.0), Pre 3 and Veer (v 2.2).

Have fun and please help

If you want you can show your appreciation for this by donating
https://www.paypal.com/cgi-bin/websc...=NT9EDMPZT8Y6C
Sorry, is it possible you could also add the QQ? I am from China, one developer from China did revise this & add QQ . It is quite good for saving power. But now it is not working now. The attached file for your reference which could be used in Veer( 2.1.2, pre 3 , pre 2). You know more then 5-6 hundreds billions person use QQ in China. Though in China , not many people use Webos phone.

look forward to your good news. Thanks.
kelpan is offline   Reply With Quote
Thanked By: sshaka
Old 08/16/2012, 03:55 AM   #166 (permalink)
Member
 
steven_farkas's Avatar
 
Posts: 362
Quote:
Originally Posted by illuniel-webos View Post
Hi all,

just wondering if anyone was able to get Microsoft Office Communicator/Lync working with this?

I noticed that it is missing a 'domain' field still. but it now has the 'sign in' button which was not present in the old plugin,


Thanks!
how do you ever get to a login page? I don't even have it in the list of accounts to choose following installing of the plug in...
__________________
All webos, all the time!
HP Touchpad, Touchpad 4G, Panda Veer, pre3, and pre2
steven_farkas is offline   Reply With Quote
Old 08/16/2012, 01:58 PM   #167 (permalink)
Homebrew Developer
 
Posts: 222
Maybe he's (like I myself have been) mistaking MSN for Office Communicator? It's coming btw, I just need to find the time to test and finish 0.9.4.
filmor_ is offline   Reply With Quote
Liked by renater likes this.
Old 08/17/2012, 01:02 PM   #168 (permalink)
Member
 
steven_farkas's Avatar
 
Posts: 362
Quote:
Originally Posted by filmor_ View Post
Maybe he's (like I myself have been) mistaking MSN for Office Communicator? It's coming btw, I just need to find the time to test and finish 0.9.4.
ok, no worries! FYI, its had a name change and is now called Microsoft Lync
__________________
All webos, all the time!
HP Touchpad, Touchpad 4G, Panda Veer, pre3, and pre2
steven_farkas is offline   Reply With Quote
Old 08/17/2012, 03:57 PM   #169 (permalink)
Member
 
grasshoper's Avatar
 
Posts: 536
Is it normal that msn won't connect ? I get an unknown error in red. I use LunaCE btw...
__________________
Proud Veer and Touchpad owner
grasshoper is offline   Reply With Quote
Old 08/24/2012, 05:41 AM   #170 (permalink)
Member
 
Posts: 5
Any updates about Whatsapp integration to Synergy?

I found a Whatsapp Java App, thats also run an Windows, maybe this can support some developing.
Java WhatsApp port - Page 34 - maemo.org - Talk
leafymind is offline   Reply With Quote
Old 08/24/2012, 08:35 AM   #171 (permalink)
Homebrew Developer

 
Posts: 3,366
There are plenty of other threads specifically regarding that. Short answer: I have it working, but WA has apparently disabled new device registration for anyone but iOS and Android, so it's probably not happening until someone figures out how that system works.
__________________
Author:
Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
Quote:
(1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
GO OPEN WEBOS!
People asked me for a donate link for my non-catalog work, so here you are:
eblade is offline   Reply With Quote
Old 08/28/2012, 01:31 PM   #172 (permalink)
Member
 
Posts: 46
Quote:
Originally Posted by eblade View Post
TWA has apparently disabled new device registration for anyone but iOS and Android, so it's probably not happening until someone figures out how that system works.
wouldn't it be possible to simulate an Android/iOS registration, with the correct data snippet from wireshark?
do you register the whazzap way as an symbian or is there another way?

however the problems this is awesome news hearing that it is actually possible as soon as we/you/meego guys solve the registration problem.

EDIT:
they actually fixed it in the whatsapi
https://github.com/vkotovv/WhatsAPI/...f64a59f4ff9fb6

Last edited by krushaaa; 08/29/2012 at 11:26 AM.
krushaaa is offline   Reply With Quote
Old 09/02/2012, 02:21 PM   #173 (permalink)
Member
 
Posts: 44
Someone else had the problem that every jabber resource is an extra contact?
e.g. i send a message to user1@jabberserver.com and get the answer from user1@jabberserver.com/laptop. Makes it impossible to chat :/
mumbassa is offline   Reply With Quote
Old 09/03/2012, 05:58 AM   #174 (permalink)
Member
 
HelmutsKohl's Avatar
 
Posts: 99
Quote:
Originally Posted by mumbassa View Post
Someone else had the problem that every jabber resource is an extra contact?
e.g. i send a message to user1@jabberserver.com and get the answer from user1@jabberserver.com/laptop. Makes it impossible to chat :/
That issue is already known. I've had the same problem with Gtalk. Hope that there will be another release that is able to ignore the resource.
HelmutsKohl is offline   Reply With Quote
Old 09/03/2012, 06:01 AM   #175 (permalink)
Member
 
Posts: 44
Quote:
Originally Posted by HelmutsKohl View Post
That issue is already known. I've had the same problem with Gtalk. Hope that there will be another release that is able to ignore the resource.
thanks for the info
mumbassa is offline   Reply With Quote
Old 09/05/2012, 06:04 AM   #176 (permalink)
Homebrew Developer
 
Posts: 222
Actually I wasn't aware of this particular problem. Sadly I'm quite occupied with work and my thesis, but I'll try to fix this in the coming release or the one after that sometime this month.
filmor_ is offline   Reply With Quote
Old 09/06/2012, 05:13 PM   #177 (permalink)
Homebrew Developer
 
Posts: 222
A small request to all of you:

Please PLEASE use the issue tracker on github (https://github.com/filmor/webos-messaging/issues), I'm a *really* forgetful person and it happens that I see some issue posted here, try to work on it, fail and then forget it. This is not how it should be

I'll add some issues now, just look if yours is already one of those. If not please add one and if you don't like to create some sort of account (although OpenID should work) at least PM me in the form "subect:[Issue] blabla, text:link to your post". Aim for completeness, mention every little buggy and annoying thing. Especially since I don't have much free time to work on this currently it's much easier and much more efficient to work by some list than just hack around a bit.
filmor_ is offline   Reply With Quote
Old 09/26/2012, 08:43 AM   #178 (permalink)
Member
 
Posts: 5
wuhuuu... whatsapp:
http://forums.webosnation.com/webos-...ent-webos.html

now just the synergy integration left ^^
leafymind is offline   Reply With Quote
Old 10/05/2012, 01:21 PM   #179 (permalink)
Member
 
b3d0u1n's Avatar
 
Posts: 64
Whenever I see an ipkg my first response is to open up a terminal and install it. For some reason I had to install through the preware app, though. Maybe I should have used ipkg-opt not ipkg? I've been away from webOS for a while.

After sorting that out I added an MSN account that refused to connect; I attempted to switch to an HTTP connection in the account settings but was met with a blank screen instead. Once I removed the account and added it again, this time with HTTP selected, things went reasonably well.
b3d0u1n is offline   Reply With Quote
Old 11/22/2012, 01:56 PM   #180 (permalink)
Homebrew Developer
 
Posts: 222
Just uploaded a new version at https://github.com/downloads/filmor/....9.4_armv7.ipk that links statically against libmojodb. It should work on all webOS 2 phones now.
filmor_ is offline   Reply With Quote
Thanked By: wMarck90
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0