webOS Nation Forums >  Homebrew >  TouchPad Patches > Synergy Messaging Plugins for the Touchpad
Synergy Messaging Plugins for the Touchpad
  Reply
Like Tree30Likes

 
Thread Tools Display Modes
Old 11/24/2012, 08:49 PM   #181 (permalink)
Member
 
Posts: 167
Quote:
Originally Posted by filmor_ View Post
Just uploaded a new version at https://github.com/downloads/filmor/....9.4_armv7.ipk that links statically against libmojodb. It should work on all webOS 2 phones now.
Thanks That's an awesome update. Updated Touchpad and Pre3 (I'll boot up my Pre2 and try it too)
MiDoJo is offline   Reply With Quote
Old 11/26/2012, 07:34 AM   #182 (permalink)
Homebrew Developer
 
Posts: 222
Sorry, still have to work on that apparently webOS 2 doesn't seem to provide either gnutls or nss.
filmor_ is offline   Reply With Quote
Old 11/26/2012, 08:30 AM   #183 (permalink)
Member
 
jcmarcos's Avatar
 
Posts: 878
Quote:
Originally Posted by filmor_ View Post
Quote:
Originally Posted by filmor_ View Post
Just uploaded a new version at https://github.com/downloads/filmor/....9.4_armv7.ipk that links statically against libmojodb. It should work on all webOS 2 phones now.
Sorry, still have to work on that apparently webOS 2 doesn't seem to provide either gnutls or nss.
So it means I shouldn't have upgraded to that new "0.9.4" version?
__________________
Pre 3 on GSM Jazztel: UberKernel, Muffle logging & friends, Mode Switcher, Advanced System Menus & Prefs, and then some more.

Proudly choosing the loser side since 1982: Commodore VIC-20, C-64, Amiga 1000 & 3000, bPlan Pegasos & MorphOS, Psion Revo, Palm Pre...
jcmarcos is offline   Reply With Quote
Old 11/27/2012, 05:16 AM   #184 (permalink)
Homebrew Developer
 
Posts: 222
No, it just means that it will not work for webOS 2.1 either, Pre 3 and Touchpad still work (and I think I added one or two protocols in the meantime, but I'm not sure).
filmor_ is offline   Reply With Quote
Liked by jcmarcos likes this.
Thanked By: jcmarcos
Old 12/03/2012, 02:05 PM   #185 (permalink)
Member
 
Posts: 65
Hi guys, I need your help.

My TP is running LunaCE 4.9.5. I'm struggling with the MSN account. It shows a yellow triangle with an exclamation sign inside. When I click it to remove the account it goes to a blank page. How I can fix that?

Thanks
edwineel is offline   Reply With Quote
Old 02/22/2013, 07:01 PM   #186 (permalink)
Member
 
sshaka's Avatar
 
Posts: 172
filmor_: Many thanks for this invaluable patch...it works for my HP Pre 3 w/webOS 2.2.4 perfectly!!! Facebook, Messenger...A GREAT WORK: I did my small donation right now!!!
__________________
El Sendero del Samurai: Lealtad, Paz Interna, Paciencia y Meditar a los pies de Buda

Samsung Galaxy S4 + Jailbreak / HP TouchPad 4G + CM10 / iPod Touch 5 + Jailbreak 6.1.3
sshaka is offline   Reply With Quote
Old 02/25/2013, 02:27 AM   #187 (permalink)
Member
 
jcmarcos's Avatar
 
Posts: 878
Quote:
Originally Posted by sshaka View Post
filmor_: Many thanks for this invaluable patch...it works for my HP Pre 3 w/webOS 2.2.4 perfectly!!! Facebook, Messenger...A GREAT WORK: I did my small donation right now!!!
Oh my! I have 0.9.4 installed and, since long ago, I'm unable to login in Messenger (that's the only service I need from this plugins). As always, there's not much information: In the "friends" section of the stock messaging app, I attempt to change my status to "available", but it takes forever. Then, when I attempt to login from the "preferences and accounts" screen, it just shows a little colored error text, saying "Unknown error".

Eeeeeeerm... I've just tried now, and it works! What? I think Microsoft is having a hard time, making the switch to Skype.

Oooops! This worked indeed, after a full reset (battery was flat this morning). But now I'm unable to login again, now it seems it doesn't even attempt: No spinning circle, nothing happens when I change status back from offline to available. Something got stuck in the plugin?
__________________
Pre 3 on GSM Jazztel: UberKernel, Muffle logging & friends, Mode Switcher, Advanced System Menus & Prefs, and then some more.

Proudly choosing the loser side since 1982: Commodore VIC-20, C-64, Amiga 1000 & 3000, bPlan Pegasos & MorphOS, Psion Revo, Palm Pre...
jcmarcos is offline   Reply With Quote
Old 03/02/2013, 02:51 PM   #188 (permalink)
Member
 
Posts: 1
Please add Gadu-Gadu
arteqw is offline   Reply With Quote
Old 03/23/2013, 03:30 PM   #189 (permalink)
Member
 
Posts: 1
Hello, I have a phone HP Veer 2.24 and messenger plugin 0.94.Fanks for good plug.There is a connectivity problem with jabber - not work connection security , read "template load failed: .../templates/row-list.html".If it is possible to fix it?
maratxxxxxx is offline   Reply With Quote
Old 06/10/2013, 12:58 PM   #190 (permalink)
Member
 
sshaka's Avatar
 
Posts: 172
I love this patch!!! Thanks again!!!
__________________
El Sendero del Samurai: Lealtad, Paz Interna, Paciencia y Meditar a los pies de Buda

Samsung Galaxy S4 + Jailbreak / HP TouchPad 4G + CM10 / iPod Touch 5 + Jailbreak 6.1.3
sshaka is offline   Reply With Quote
Old 07/12/2013, 10:36 PM   #191 (permalink)
Member
 
Posts: 65
Quote:
Originally Posted by edwineel View Post
Hi guys, I need your help.

My TP is running LunaCE 4.9.5. I'm struggling with the MSN account. It shows a yellow triangle with an exclamation sign inside. When I click it to remove the account it goes to a blank page. How I can fix that?

Thanks
Hi guys, I uninstalled the LunaCE 4.9.5 and I still have the same issue. Any advise?
edwineel is offline   Reply With Quote
Old 09/06/2013, 04:16 AM   #192 (permalink)
Member
 
sshaka's Avatar
 
Posts: 172
Quote:
Originally Posted by edwineel View Post
Hi guys, I need your help.

My TP is running LunaCE 4.9.5. I'm struggling with the MSN account. It shows a yellow triangle with an exclamation sign inside. When I click it to remove the account it goes to a blank page. How I can fix that?

Thanks
I have the same error here, not only with MSN but also with Facebook Chat!!! Even I can't login to the Facebook Chat in my Pre3, but I can do with MSN in the same device!!!???
__________________
El Sendero del Samurai: Lealtad, Paz Interna, Paciencia y Meditar a los pies de Buda

Samsung Galaxy S4 + Jailbreak / HP TouchPad 4G + CM10 / iPod Touch 5 + Jailbreak 6.1.3
sshaka is offline   Reply With Quote
Old 09/06/2013, 04:25 AM   #193 (permalink)
Member
 
sshaka's Avatar
 
Posts: 172
Quote:
Originally Posted by filmor_ View Post
No, it just means that it will not work for webOS 2.1 either, Pre 3 and Touchpad still work (and I think I added one or two protocols in the meantime, but I'm not sure).
Hi!!! Is there any chance for an update!!!??? Because I can't loging anymore nor in my TouchPad neither my Pre3 (only MSN)

PLEASE!!!
__________________
El Sendero del Samurai: Lealtad, Paz Interna, Paciencia y Meditar a los pies de Buda

Samsung Galaxy S4 + Jailbreak / HP TouchPad 4G + CM10 / iPod Touch 5 + Jailbreak 6.1.3
sshaka is offline   Reply With Quote
Old 09/09/2013, 01:43 PM   #194 (permalink)
Member
 
hrminer92's Avatar
 
Posts: 951
Quote:
Originally Posted by illuniel-webos View Post
Hi all,

just wondering if anyone was able to get Microsoft Office Communicator/Lync working with this?

I noticed that it is missing a 'domain' field still. but it now has the 'sign in' button which was not present in the old plugin,


Thanks!
I haven't. The old plugin does seem to work on my phone, but it is showing everyone offline. It doesn't' work on my Touchpad. The new version just stays on the sign in screen with the wait circle spinning.

Last edited by hrminer92; 09/11/2013 at 01:55 PM.
hrminer92 is offline   Reply With Quote
Old 09/17/2013, 11:54 AM   #195 (permalink)
Homebrew Developer
 
Posts: 222
Regarding the MSN login issues: The protocol is not supported anymore from Microsoft's side, there's nothing I can do for you in this regard. However, all of the accounts should have been able to be converted to Skype, which works natively both on the Touchpad and on the Pre 3.

I haven't worked on the plugin for quite some time, since it mostly (apart from some minor annoyances I haven't found a way around yet) works for me. I did some work on the Pre 2, SIPE (= Lync IIRC) and Groupwise support, but I've been pretty busy with uni and work. Although it might be too late for many of you I'm going to sit down in November (after handing in my last thesis) and fix the remaining bugs as well as adding support for the aforementioned. If anyone wants to browse through the code (C++ or Javascript), it's been online on Github since the beginning
filmor_ is offline   Reply With Quote
Liked by MAMISHO likes this.
Thanked by eKeith, MAMISHO
Old 12/29/2013, 12:26 AM   #196 (permalink)
Member
 
Posts: 81
I really appreciate the work you've put into this!

Unfortunately I can't get the google talk plugin to connect - I can add the account ok but when I try to connect in the messaging app it just tries for a while and then times out.

This is how I set up the plugin:

googleid: andrew@domain.com (my google apps domain)
password: my password
Allow plaintext auth...: left unticked
BOSH URL: left blank
Connect server: talk.google.com
(Then there's "template load failed: ../templates/row-list.html - not sure if that's normal?)
File transfer proxy: proxy.eu.jabber.org (though I understand that file transfers aren't working between gmail and libpurple users).

Once that's filled in I can click "sign in" and a few seconds later I get asked to create the account, but it never seems to be able to connect in the messaging app.

If needed I can attach the logs here or submit to the issues register? I didn't want to create a new issue right away in case I'm doing something obviously wrong/easily fixed :-)

Cheers,
Andrew

Edit: Forgot to add - I'm using a Pre3 running 2.2.4, freshly doctored.
llama233 is offline   Reply With Quote
Old 01/07/2014, 03:19 PM   #197 (permalink)
Member
 
Posts: 6
Thank you very much for this plugin. Works great so far. Maybe requesting only the user name in templates like facebook instead of the full e-mail (@chat.facebook.com) would make the user experience smoother.

I donated a small amount to show you my appreciation.

Regards,
Dimitris K
denom is offline   Reply With Quote
Old 02/05/2014, 06:25 AM   #198 (permalink)
Homebrew Developer
 
davodego's Avatar
 
Posts: 49
Hi,
my problem is, in an koversation in Jabber between two webos devices the plugin maks a reccource id to the adress with 30 numbers (xxxx@jabber.org/82764920175614630925641687299346526). Every new konversation the plugin creates an new id number, and the device can't associating with the contact on the Buddy list.
Is there a way to turn this off?

Excuse my bad englich.

Greetings from Thüringen, Germany...
Daniel
davodego is offline   Reply With Quote
Old 02/08/2014, 05:41 PM   #199 (permalink)
Homebrew Developer
 
davodego's Avatar
 
Posts: 49
Quote:
Originally Posted by davodego View Post
Hi,
my problem is, in an koversation in Jabber between two webos devices the plugin maks a reccource id to the adress with 30 numbers (xxxx@jabber.org/82764920175614630925641687299346526). Every new konversation the plugin creates an new id number, and the device can't associating with the contact on the Buddy list.
Is there a way to turn this off?

Excuse my bad englich.

Greetings from Thüringen, Germany...
Daniel
Ok, after a few test i see the Jabber-Server is adding this Ressource number. So the question is, is there a way to add a spezific ressource to the Plug-in?
davodego is offline   Reply With Quote
Old 05/07/2014, 05:46 AM   #200 (permalink)
Homebrew Developer
 
Posts: 222
Quote:
Originally Posted by davodego View Post
Ok, after a few test i see the Jabber-Server is adding this Ressource number. So the question is, is there a way to add a spezific ressource to the Plug-in?
I didn't really understand how this is done in Pidgin, it's not an extra configuration field (otherwise it would show up in the account creation screen). Have you tried using a username of bla@blubb.com/Resource?

Quote:
Originally Posted by denom View Post
Thank you very much for this plugin. Works great so far. Maybe requesting only the user name in templates like facebook instead of the full e-mail (@chat.facebook.com) would make the user experience smoother.
That should be an easy fix, I'll look into this.

Quote:
Originally Posted by llama233 View Post
If needed I can attach the logs here or submit to the issues register? I didn't want to create a new issue right away in case I'm doing something obviously wrong/easily fixed :-)
Please do so. Are you able to connect using Pidgin itself?

Problem is, although I'm still using my Touchpad my Pre3's battery died (kind of, I can use it only for about 4 hours) so I'm on a Nexus now :/
I'll reactivate it for Wifi only though
filmor_ is offline   Reply With Quote
Thanked By: MiDoJo
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0