Page 12 of 20 FirstFirst ... 27891011121314151617 ... LastLast
Results 221 to 240 of 397
Like Tree44Likes
  1. #221  
    Quote Originally Posted by ShiftyAxel View Post
    I can probably modify it via smb.conf- do you have any suggestions for settings?
    yes, after looking through your source code it's surely a samba configuration tweak. I don't have any experience with samba but take a look at Make Samba Go Faster - Amahi (mainly SO_RCVBUF/SO_SNDBUF) and pick a value to your liking.

    Later edit: other users can add

    socket options = SO_RCVBUF=131072 SO_SNDBUF=131072 TCP_NODELAY

    OR:

    socket options = IPTOS_LOWDELAY TCP_NODELAY
    write cache size = 262144

    OR:

    strict allocate = no

    to their smb.conf [global] section to try if large file transfer is ok. (I am unable to try myself right now)

    Later - later edit: it can be a problem of the samba build also. You can search for samba copy large file timeout on google and you will see that is common. Some folks suggest: Build samba with the "--with-aio-support" option.

    Please look into this pre-allocation of disk space (it pre-creates a file filled with 0s) as it affects copy performance also (it's like copying each file 2 times: pre-create on the TP and then replace the bytes with the ones received)
    Last edited by rioachim; 03/10/2012 at 03:24 AM.
  2. BlueRQ's Avatar
    Posts
    39 Posts
    Global Posts
    43 Global Posts
    #222  
    hi to everyone!

    @ShiftyAxel... here are the HP Pre3 icons, and background images... sorry for the delay...
    t
    he official pre3 icon size is 96, and the background for the pre 3 is 485 in both, the glowing wifi and the wifi off version...

    also, here's the missing hp touchpad wifi off version of the background...

    in a moment i'll upload the others...

    RQ

    PS: hope all of you guys support any of my open webos logo in the voting process...
    Attached Images Attached Images
    Attached Files Attached Files
  3. #223  
    Earlier in the thread, ShiftyAxel mentioned that node.jsjsjs $is$ $what$ $WiFi$ $File$ $Sharing$ $uses$ $to$ $execute$ $commands$. $Which$ $gives$ $me$ $the$ $thought$ $that$ $it$ $might$ $be$ $useful$ $to$ $monitor$ $the$ $operation$ $of$ $node$.$js$ $to$ $see$ $if$ $that$'$s$ $where$ $things$ $are$ $going$ $south$ $on$ $my$ $Pre$+ $vis$-$a$-$vis$ $WFFS$. $Anyone$ $have$ $suggestions$/$techniques$ $along$ $those$ $lines$ ??
  4.    #224  
    @rioachim Cool, thank you. I'll have a look into and push out an updated smb.conf on next release.

    @bluerq Looking good though due to packaging restrictions I can only use one of them for the actual app icon, any thoughts on that? Also is there any chance you could smooth/blend the edges of the wifi icon when it's off? The white highlight in the lower-right corner looks kind of harsh.

    @Stan 'tail -f /var/log/messages' shows you the logs from the whole system which might reveal something, but it's quite cluttered and hard to read. Not to mention that webOS throws up loads of errors that are safe to ignore as part of normal use :s
    webOS Ports' UI Architect & luna-sysmgr guru.
  5. #225  
    I have three TouchPads and I have had no trouble in getting Wifi File Sharing to work on two of them. But, for the life of me I cannot figure out why it won't work on the third TouchPad. Other than this 'third' TouchPad being a 16GB TouchPad, there is no difference between the three TouchPads. All three have Uberkernel and all the same patches installed. I have tried uninstalling/installing. Rebooting Windows/TouchPad and all combinations of settings.in WiFi File Sharing. Although, the two 32GB one's don't always show up in WIndows Explorer, I am always able to at least manually 'Map' them. But with the 16GB TouchPad I am not able to even do that. Any ideas what could be the problem?
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  6. BlueRQ's Avatar
    Posts
    39 Posts
    Global Posts
    43 Global Posts
    #226  
    @ShiftyAxel, ok, I see what you mean.. The right corner, right?... I'll check the edges... But it is weird 'cause they are the same wifi as the one in the glowing touchpad, I just changed the colors... And what do you think of making an icon of just the wifi signal? I think that will solve the problem of the icon on different devices, and I think will look better that in the pre3, for example, you will not see a touchpad in the icon hahaha... What you think???

    RQ
  7. #227  
    This looks epic. I got the first iteration, and that was awesome! But, looking at the new version, it looks sick!
    can't wait to get this!
  8. #228  
    I tried adding all the following lines (to /opt/etc/samba/smb.conf):

    socket options = SO_RCVBUF=65536 SO_SNDBUF=65536 TCP_NODELAY IPTOS_LOWDELAY
    strict allocate = No
    strict sync = No
    read raw = No
    write raw = Yes
    max xmit = 65536
    use sendfile = Yes
    dead time = 15
    getwd cache = Yes
    otlocks = No
    refresh = 1
    aio read size = 16384
    aio write size = 16384
    write cache size = 65535

    but samba still insists to first create the file filled with 0s and then copy, resulting in a timeout for files >500mb.
    @ShiftyAxel, what samba version are you installing? 2.x or 3.x?

    workaround to avoid timeout (but not to sppeed up file transfer): see attachment
    Attached Files Attached Files
    Last edited by rioachim; 03/11/2012 at 11:24 AM.
    Auk#WN likes this.
  9.    #229  
    @Sanjay Hmm, that's odd. Does the in-app WiFi icon light up on the non-working TP?

    @bluerq Yeah, it's just a bit stark. And just the WiFi icon sounds like a great idea, it's good to be device-agnostic wherever possible

    @rioachim Cool, I'll add that in for the next version. I'm installing Samba 3.0, 3.5 is too big to fit in the optware filesystem and 2.x doesn't work with OSX Lion.
    webOS Ports' UI Architect & luna-sysmgr guru.
  10. #230  
    Quote Originally Posted by ShiftyAxel View Post
    @rioachim Cool, I'll add that in for the next version. I'm installing Samba 3.0, 3.5 is too big to fit in the optware filesystem and 2.x doesn't work with OSX Lion.
    don't add anything of that list. it doesn't do any good, something else must be the cause.
  11.    #231  
    I was thinking the .zip attachment- or does that not work either? I haven't had chance to download and look at it yet.
  12. #232  
    Hello!

    I installed the Wifi File sharing on HPTP with 3.0.5 OS and it installed OK.
    When I turn in on, the WIFI icon lites up but I can not see anything on my
    Win XP computer.
    Please help me how to get it working and what I need to do on my WinXp machine
    to see my TP?

    Thanks.
  13. #233  
    I read the first post again carefully and got it working.

    I need to map Touchpad as a drive on the PC and then open the drive and write to that drive.
    It then works as documented.

    Thanks for this great Apps. It saves time not to hook up the TP via USB cable.
  14. #234  
    @Shifty:

    The display of the internal IP somewhere on the screen would be a valuable implementation. Subnet mask (and maybe external IP, although it wont be needed for LAN troubleshooting) would be a plus. They can be faded somehow so as to keep w/ the simple, dark layout.

    These pieces of info will help diagnose connectivity issues and facilitate mapping via IPs (no need to check the router client list, which is not always accessible or easy for the average person).

    Later on, some PING functionality will seal the whole deal.
  15. cartogary's Avatar
    Posts
    20 Posts
    Global Posts
    22 Global Posts
    #235  
    I guess I'm with Sanjay on this one. App fails to install thru Preware or WOSQI.

    Preware says it downloads but after Luna restart, no app icons, and doesn't appear in the installed lists. No flashing wifi icon, it just aint happenin'. It'd be nice to have tho'.

    32 TPad, 3.05
  16. BlueRQ's Avatar
    Posts
    39 Posts
    Global Posts
    43 Global Posts
    #236  
    @ShiftyAxel... when i arrive home, iŽll send you the pres and the veer...
    and the icon hahha....

    and to all...

    vote for me in the finals for the open webOS logo!!!
    http://www.webosnation.com/open-sour...ding-finalists

    RQ
  17. #237  
    Quote Originally Posted by ShiftyAxel View Post

    @OhanaUnited So just to confirm you have both WiFi File Sharing and Easy Samba installed? What happens if you open My Computer, click 'Map Network Drive' (may be in a submenu somewhere) and enter \\<Device Name>\Public?
    Nothing shows under "Map Network Drive". How do I find the Device Name?
  18. #238  
    Quote Originally Posted by jhussain1 View Post
    When I turn in on, the WIFI icon lites up
    Sorry for disturbing with a silly question but I don't see that icon lit (rubbing latest version. I take the chance to say that I've seen it working (just folder listing, had little time) on a Windows 8 Consumer Preview, no less!
    Pre 3 on GSM Jazztel: UberKernel, Muffle logging & friends, Mode Switcher, Advanced System Menus & Prefs, and then some more.

    Proudly choosing the loser side since 1982: Commodore VIC-20, C-64, Amiga 1000 & 3000, bPlan Pegasos & MorphOS, Psion Revo, Palm Pre...
  19. #239  
    I am trying to install WiFi File Sharing on my TouchPad but the install fails to install the prerequisite "Easy Samba" Package. The error message suggests that I need to do an "ipkg Update"

    Please help

    begin
    Nothing Interesting.
    verify
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 8588 100 8588 0 0 19332 0 --:--:-- --:--:-- --:--:-- 30453
    identify
    org.webosinternals.optware
    install
    {"returnValue":true , "ticket":1, "subscribed":true}
    { "ticket":1 , "status":"STARTING" }
    { "ticket":1 , "status":"CREATE_TMP" }
    { "ticket":1 , "status":"VERIFYING" }
    { "ticket":1 , "status":"IPKG_INSTALL" }
    { "ticket":1 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    stop: (781362/298430197) Unknown job: org.webosinternals.optware
    Creating 128MB optware filesystem ...
    32768+0 records in
    32768+0 records out
    134217728 bytes (128.0MB) copied, 9.468084 seconds, 13.5MB/s
    mke2fs 1.41.4 (27-Jan-2009)
    Filesystem label=optware
    OS type: Linux
    Block size=1024 (log=0)
    Fragment size=1024 (log=0)
    32768 inodes, 131072 blocks
    6553 blocks (5.00%) reserved for the super user
    First data block=1
    Maximum filesystem blocks=67371008
    16 block groups
    8192 blocks per group, 8192 fragments per group
    2048 inodes per group
    Superblock backups stored on blocks:
    8193, 24577, 40961, 57345, 73729
    Writing inode tables: 0/16 1/16 2/16 3/16 4/16 5/16 6/16 7/16 8/16 9/1610/1611/1612/1613/1614/1615/16done
    Creating journal (4096 blocks): done
    Writing superblocks and filesystem accounting information: done
    This filesystem will be automatically checked every 38 mounts or
    180 days, whichever comes first. Use tune2fs -c or -i to override.
    rmdir: '/var/opt': No such file or directory
    (781392/990162045) org.webosinternals.optware: goal changed
    completed
    Nothing Interesting.
    begin
    Nothing Interesting.
    verify
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    84 81150 84 68805 0 0 57352 0 0:00:01 0:00:01 --:--:-- 66671
    100 81150 100 81150 0 0 66355 0 0:00:01 0:00:01 --:--:-- 76919
    identify
    mobi.optware.ipkg-opt
    install
    {"returnValue":true , "ticket":2, "subscribed":true}
    { "ticket":2 , "status":"STARTING" }
    { "ticket":2 , "status":"CREATE_TMP" }
    { "ticket":2 , "status":"VERIFYING" }
    { "ticket":2 , "status":"IPKG_INSTALL" }
    { "ticket":2 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    Nothing Interesting.
    completed
    Nothing Interesting.
    begin
    Nothing Interesting.
    verify
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 4846 100 4846 0 0 30068 0 --:--:-- --:--:-- --:--:-- 47509
    identify
    com.shiftyaxel.easysamba
    install
    {"returnValue":true , "ticket":3, "subscribed":true}
    { "ticket":3 , "status":"STARTING" }
    { "ticket":3 , "status":"CREATE_TMP" }
    { "ticket":3 , "status":"VERIFYING" }
    { "ticket":3 , "status":"IPKG_INSTALL" }
    { "ticket":3 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/com.shiftyaxel.easysamba.postinst 2>&1
    Downloading http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz
    wget: can't connect to remote host (140.211.169.161): Connection timed out
    Downloading http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz
    wget: can't connect to remote host (140.211.169.161): Connection timed out
    Downloading http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz
    wget: can't connect to remote host (140.211.169.161): Connection timed out
    An error ocurred, return value: 3.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /opt/ipkg-ExNtCJ http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz'
    ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /opt/ipkg-ExNtCJ http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz'
    ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -q -P /opt/ipkg-ExNtCJ http://ipkg.nslu2-linux.org/feeds/op...le/Packages.gz'
    Nothing to be done
    An error ocurred, return value: 4.
    Collected errors:
    Cannot find package samba.
    Check the spelling or perhaps run 'ipkg update'
    remove
    Removing package com.shiftyaxel.easysamba from root...
    (offline root mode: not running com.shiftyaxel.easysamba.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
    Last edited by Wheel_nut; 03/13/2012 at 08:57 AM. Reason: Added Error Log
  20. #240  
    @shiftyaxel

    I'm still having problems, but its on the computer side of things. The service works great on one of the three computers that I tried it on, but the other two show it, and refuse to connect. I am able to ping my touchpad ip, but that's it. Any ideas?
    **Developer of Pandora Tablet for Touchpad** (Click to Download)



    @drewksparks_dev on Twitter

    Devices: Palm Pre 2 and 32gb Touchpad

    I'm a webOS freak, according to my mother.

Posting Permissions