Results 1 to 5 of 5
  1. tastypre's Avatar
    Posts
    4 Posts
    Global Posts
    26 Global Posts
       #1  
    Using http://forums.precentral.net/hp-touc...-hulu-fix.html

    I cannot seem to get past the verification script that runs:
    CompassLearning Odyssey System Check

    The first 4 checks - Browser/Java/Flash/Cookies is all that is needed for my childrens school levels, so this is all that needs to be working.

    Can you go there on your touchpad and see what I mean? Using the change-user-agent script, i've tried all sorts of combinations but it will not get past alert "Your browser does not meet the minimum requirements. Please update your browser. Will not contine checking.'

    Its almost like its checking something else first (what could it be?), then checking the user agent, because it says i'm using Safari, but version is unknown. I've tried a user agent as simple as Firefox/3.5.1, and still says version unknown.

    I bought 2 of the touchpads for my 5 and 8 year old, in hopes they could use for the schooling. Any help would be greatly appreciated!

    I spent all of last night getting Ubuntu running. I'm able to login and do lessons, but the flash seems unstable and wonky, and not usable using gnash.

    update: doing some googling on what types of info can be obtained,perhaps they are checking other things such as
    screen resolution (determined using javascript) (I think the Touchpad is 1024x768, pretty standard)
    Browser plugins, plugin versions and MIME types (determined using javascript)
    System fonts (determined using flash or java applets and javascript)

    Not sure how to tell exactly what is the hangup.

    update 2: Advanced Browser give same results. Wishful thinking.
    Last edited by tastypre; 10/05/2011 at 02:01 PM.
  2. tastypre's Avatar
    Posts
    4 Posts
    Global Posts
    26 Global Posts
       #2  
    please help :'(
  3. bearda's Avatar
    Posts
    68 Posts
    Global Posts
    301 Global Posts
    #3  
    Strangely enough going there on my desktop with Chrome on a 64-bit Linux system also fails.

    You said that the site requires Java. Does the WebOS browser have a JVM?
  4. bearda's Avatar
    Posts
    68 Posts
    Global Posts
    301 Global Posts
    #4  
    OK, it looks like this thing is trying to use (among other things):
    - Java
    - Silverlight
    - Quicktime

    I don't think any of those are going to be happy on a TouchPad.

    I will say that it looks like it's looking for not only the browser in the User Agent string, but the operating system as well. Firefox 7.0.1 on my Linux machine fails saying the browser version is unknown. Firefox 7.0.1 on my Windows7 laptop passes the browser test fine (but then fails for a bunch of other plugins). Try changing the user agent string to say it's running as a windows machine.
  5. tastypre's Avatar
    Posts
    4 Posts
    Global Posts
    26 Global Posts
       #5  
    With ubuntuchroot, and installing apt-get install browser-plugin-gnash, it passes. Its just that in ubuntu, the flash must not be well supported, as things happen out of order, and stop working. So, if it works in Ubuntu, seems like it would work in Webos.

    Perhaps I am wrong in assuming Webos supports Java? Doing some reading, it appears WebOS no longer includes a Java VM. Do you think this site requires it?

Posting Permissions