Results 1 to 9 of 9
  1.    #1  
    I have the unlocked GSM Treo Pro and Garmin will load fine as long as its after a soft reset.

    If I run Garmin, then close it, then try to open it (even with nothing else running in the background), 9 times out of 10 it will freeze the entire device and require a soft reset.

    I've tried a fresh install of Garmin, the stock WM6.1 and a GSM WM6.5 ROM, all with the same behavior.

    Garmin works fine on the same card in my Fuze (Touch Pro), so its not the card or the Garmin files. I also don't believe its GPS related because I can open and close Google Maps all day and have it set to Use GPS.

    Does the Treo Pro just not have enough memory, or is there something else causing it?

    While I don't use Garmin very often, its nice on trips to turn it off while we're at a stop and take it with me, then turn it back on when we get back in the car.
  2. #2  
    If you are using the Garmin software you must use a GPS 'enabler' to "bootkick" start the GPS system before Garmin will run

    http://discussion.treocentral.com/tr...-xt-no-go.html
  3.    #3  
    I'm not sure this is true for the GSM version. After a soft reset it will load up fine and will lock onto a GPS signal without doing anything else.

    If I then close it and reopen it, it will usually freeze up the whole phone before it loads the safety warning. I'll see the Garmin splash screen and that's it. I can't click on start or anything and have to soft reset. After I soft reset, it works fine again as long as I don't close it and reopen it.
  4. #4  
    They say it is the GSM version that needs the "bootkick" - I think I read somewhere, some time ago, that the GPS system times out after a certain delay. That may explain why yours works after a soft reset but not again after a software shutdown - the GPS system times out after you close the Garmin app.

    Everything I have ever read about the Garmin system running on the Treo Pro says you need that "bootkick".
  5. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #5  
    Are you running QuickGPS?
  6.    #6  
    Yes I am NRG. I tried deleting the xtra.dat files before and redownloading them and it didn't help (I read that somewhere).

    So far the GPS Starter trick seems to have worked. It still takes about twice as long to start as it did on my Touch Pro, and it acts like it freezes before the safety warning pops up, but so far it has loaded about 5 times without a soft reset.
  7. #7  
    Hey mindfrost82, can you try something for me?

    On your Treo Pro go to:

    Start Menu -> Settings -> Personal (tab) -> Phone -> Services (tab) -> Location Setting [hit Setting Button to call up details]

    Is it in the ON setting?

    If not, set it to ON then hit OK. Then try Garmin again and see if it locks on faster. If it does, next try starting Garmin without using the GPS Starter kickstart program and see if it still works.

    Please report the results here. Setting the Location Setting to "ON" allows A-GPS (assisted GPS) activity - GPS programs can use cell phone tower location to speed GPS lockons. I have found that Google Maps will work with the setting OFF but only with a very slow initial lockon, while Bing will not work at all with the setting OFF. I am thinking that Garmin may have some of the same issues.
  8. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #8  
    Quote Originally Posted by mindfrost82 View Post
    Yes I am NRG. I tried deleting the xtra.dat files before and redownloading them and it didn't help (I read that somewhere).

    So far the GPS Starter trick seems to have worked. It still takes about twice as long to start as it did on my Touch Pro, and it acts like it freezes before the safety warning pops up, but so far it has loaded about 5 times without a soft reset.
    Yeah, you can't redownload them, you need the teplates that are located on a thread on PPCGeeks. Search for "QuickGPS freeze", you should find it that way.
  9. jbb
    jbb is offline
    jbb's Avatar
    Posts
    35 Posts
    Global Posts
    43 Global Posts
    #9  
    Quote Originally Posted by mindfrost82 View Post
    I have the unlocked GSM Treo Pro and Garmin will load fine as long as its after a soft reset.

    If I run Garmin, then close it, then try to open it (even with nothing else running in the background), 9 times out of 10 it will freeze the entire device and require a soft reset.

    I've tried a fresh install of Garmin, the stock WM6.1 and a GSM WM6.5 ROM, all with the same behavior.

    Garmin works fine on the same card in my Fuze (Touch Pro), so its not the card or the Garmin files. I also don't believe its GPS related because I can open and close Google Maps all day and have it set to Use GPS.

    Does the Treo Pro just not have enough memory, or is there something else causing it?

    While I don't use Garmin very often, its nice on trips to turn it off while we're at a stop and take it with me, then turn it back on when we get back in the car.
    I have a unlocked GSM Treo Pro and used to have the same issue like yours.
    Try this in Garmin:
    Tools->Settings->System->Remote GPS (or click upper-left satellite signal bar)
    check if your setting is 'GPS Intermediate Driver'. If not, change it to that.

    I can now use Garmin directly without having to use other GPS software to activate GPS unit first.

Posting Permissions