Results 1 to 17 of 17
  1.    #1  
    I hope that someone might be able to give me a suggestion. I am having a very odd problem with my GPS. I have the same issue with google maps, tomtom7, and garmin apps.

    I can not get a gps lock, and garmin and tomtom show no gps device. If I do a soft reset the unit will get a lock on 7+ sat in under a min. Then about 1 min later I loose all connection and the apps are again no longer able to talk to the gps. I can reset the unit and the whole process will repeat.

    It is almost like the gps is going into a power save mode.

    I know that tomtom has to have the gps primed, but garmin and google maps have always worked well for me in the past.

    I am using the standard com port 4/4800 with win set to handle gps connections.

    I am hoping that someone might know a fix. My next step is to do a hard reset, but I don't really want to do that after getting my phone the way I like it.

    Help please
  2. #2  
    I am having the same issue. Hard reset did not solve it. After hard reset the same issue happened with the version of MS Live that comes stock with the STP.

    edit - I installed latest version of Google Maps after hard reset and same issue. Will work correctly after reset for about 30-60 seconds then signal lost and same issue all over again.
  3. #3  
    Does google maps come on the Sprint Treo Pro? or do you have to download it?
    My Phone & My Wife's Phone Two Unlocked GSM Treo Pro's

  4. #4  
    Downloaded and installed. GPS issue was there after hard reset just using MS Live and Sprint Navigator. Downloaded Google Maps and installed - same issue. Hard reset and used Sprite backup from several different dates and same issue on all. Does not appear to be a software issue. Would appear that it is hardware issue.
  5. #5  
    Same Here, exact issues, all of the above, same time span! I'm on Alltel/Verizon. Locking up left and right, phone wants NOTHING to do with GPS and ANY app that has anything to do with GPS.
  6.    #6  
    Quote Originally Posted by palandri View Post
    Does google maps come on the Sprint Treo Pro? or do you have to download it?
    You have to download it, but it is free from Google.
  7.    #7  
    Quote Originally Posted by davidck65 View Post
    I am having the same issue. Hard reset did not solve it. After hard reset the same issue happened with the version of MS Live that comes stock with the STP.

    edit - I installed latest version of Google Maps after hard reset and same issue. Will work correctly after reset for about 30-60 seconds then signal lost and same issue all over again.
    Well I will be holding off on the hard reset for now then. :P
    I wish I had a clue was was causing this.
    I would say I had a bad gps radio, but we get a connection for ~1min after a soft reset.
  8. #8  
    This issue is also being discussed at PPCGeeks. It appears this is too circumstantial for it to be a hardware failure as many are having the exact same issue within the past day or two. I believe my issue started yesterday before the time change, so not sure if the DST change had anything to do with it.
  9. #9  
    This seems identical to the problem I started having on the 30th, and posted earlier, except I lost all email service too until deleting the existing mailboxes and re-creating them on the Alltel (or whomever's) servers.

    You are not alone.
  10. #10  
    I've done 4 hard resets and restored backups from as far back as two months, and still have the same issues each time. This last time I hard reset, with nothing else on the phone, I installed Bing and Google Maps (separately) and immediately experienced the lockups and the phone restarting itself. So about 2 hours ago I restored my most recent backup, went in and turned the phones "Location Setting" to off, and using MemMaid disabled any and all gps related startups and the phone has been just fine since. So it's most definately GPS problem.
  11.    #11  
    I fooled around with this problem today, and I am getting an occational lockup when I try to launch a gps app. The more noteworthy thing is that the unit has started rebooting it's self about every other time when searching for sats.
  12.    #12  
    Quote Originally Posted by davidck65 View Post
    This issue is also being discussed at PPCGeeks. It appears this is too circumstantial for it to be a hardware failure as many are having the exact same issue within the past day or two. I believe my issue started yesterday before the time change, so not sure if the DST change had anything to do with it.
    davidck65, can you post a link to the thread at ppcgeeks so we can follow it too?
  13. #13  
    Quote Originally Posted by Wizardknight View Post
    davidck65, can you post a link to the thread at ppcgeeks so we can follow it too?
    There are actually 2 threads.

    Help!! Locking up - PPCGeeks

    The gps stopped working - PPCGeeks
  14. #14  
    Can anyone try to verify what I have found? First soft reset, then turn off the cellular radio by holding the button on the top of the phone next to the ringer switch. Then use a GPS program such as Garmin XT that does not require an internet connection. I found that with the radio off I could connect with a GPS signal consisently and quickly with TomTom 7, IGo8, GPS Tuner, TrackyPro, Delorme Street Atlas Handheld, BackCountry Navigator, and Garmin Mobile XT. I tried each one successively twice and locked on to GPS without any reboots or issues. As soon as I soft reset and turned on the cellular radio I was able to lock on with Bing but before I could try another program my phone reset on its own. This happened twice. This would appear to be some sort of network issue since with the radio turned off - not connected to the network - GPS works.
  15. #15  
    alrighty.......i turned off the radio with the button on top of the phone. started GPS test and went 3D. Once it was 3D i turned the radio back on with the button on top of the phone and started google maps. it found me quickly and tracked me until i closed the program 5 minutes later.

    i didn't change any dates or adjust time or any settings any where. what i stated above is all i did after a soft reset.
  16. #16  
    I think I have fixed the issue thanks to these threads:



    Does GPS ever just 'go bad'? - PPCGeeks

    HELP!!! GPS software causing reboot and/or freezing - PPCGeeks



    Seems this issue is not limited to the Treo Pro. Here is what worked for me. I downloaded the xtra.bin file from this thread Does GPS ever just 'go bad'? - Page 6 - PPCGeeks (post 59) and the program FileDate.exe from this thread HELP!!! GPS software causing reboot and/or freezing - Page 10 - PPCGeeks (post 92). I extracted the xtra.bin file to my desktop and changed the created, modified, and accessed dates to today using Filedate.exe. I then backed up the xtra.bin file from My Device\Windows just in case I needed it to some other folder on my laptop. I then copied the modified xtra.bin file from my desktop to My Device\Windows and My Device\Temp folders. Then I started QuickGPS and went to Menu\Options and unchecked all boxes and then soft reset. Since then, even after several soft resets, I have been able to use GPS in ALL my GPS enabled software including:

    Google Maps

    Bing

    BackCountry Navigator

    Garmin Mobile XT

    GPS Tuner

    iGO 8

    Delorme Street Atlas Handheld 2009

    TomTom 7

    TrackyPro

    Sprint Navigation



    Hope this works for others also.
  17. #17  
    Wow, THANK YOU! This "fix" is working perfectly for me so far. I've been running all my GPS apps off and on for about 3 hours now and so far no issues...

Posting Permissions