Results 1 to 15 of 15
  1.    #1  
    To start off, I have a suspicion this may be a problem of carrier changes, but you're the experts and maybe I will be very surprised!

    My Treo Pro has been working wonderfully for the 3 months I have had it - bought from Alltel. October 17 or thereabouts was our switchover to Verizon due to their purchase of Alltel. A few coverage issues (like a day's outage and horrible signal for a couple others) but otherwise everything worked fine. As far as I can tell, it was set up for standalone, internal GPS operation.

    On Friday the 30th, email died and GPS became very flaky. Coincidentally (?) the phone has started to freeze up rather frequently.

    Fearing a registry corruption, I restored to a backup from 3 days earlier. Same problems. 7 days earlier: same problems. 2 weeks earlier: same. 3 MONTHS earlier: same. Now I am seeing a trend. I tried hard reset, setup the Alltel mail application again (newly downloaded) and at least I got email back. So, I tried this with the later backups, settling on the 2 week old backup and, after reinstalling the mail, it seems to be working again. So, I presume there was some kind of a server change.

    The problem is with the GPS. I never had major problems with it, and could switch between four different GPS derived applications seamlessly. Now, any application will start and run successfully THE FIRST TIME after a soft reset. Forget it after that. I have tried registry tweaks, and found only a couple posts similar to what is going on but they were for a GSM vs. CDMA Treo Pro, and were encountered by developers using SDKs to write software. Not my case as I am just an appliance operator here!!

    It is not a total loss as at least I can run ONE application, but before I had no problems at all, and if I leave the application for some reason, wanting to come back to it, then I have to soft reset again.

    The GPS worked so well for me that it always beat my Garmin 196 in both the number of satellites received and startup times (when using QuickGPS).

    Anyone have any idea what may have happened or what else I need to check? I know from reading here that Verizon's position is that it does not support the Treo Pro, so I am certainly on my own here (even though I am still waiting for the Alltel rebate to show up in my mailbox!)

    Any guidance welcome.
  2. #2  
    I am having the same GPS issue with the Sprint Treo Pro starting about 3-4 days ago. Only difference is I cannot maintain a signal with even 1 program for longer than a minute. Hard resetting and only using the stock Sprint GPS programs - MS Live and Sprint Navigator does not fix it - problems the same.
  3. #3  
    Same Here, exact issues, all of the above, same time span! I'm on Alltel/Verizon. Could it be because of the time change? I'm at a loss! Locking up left and right, phone wants NOTHING to do with GPS and any app that has anything to do with GPS.
  4. #4  
    I noticed that after any app has issues identifying GPS that if I go into external GPS settings and try to change anything my phone locks up. Seems as if even WM can't locate the GPS hardware once the signal is lost.
  5. #5  
    No custom ROM here. I've done 4 hard resets and restored backups from as far back as two months, and still have the same issues each time. This last time I hard reset, with nothing else on the phone, I installed Bing and Google Maps (separately) and immediately experienced the lockups and the phone restarting itself. So about 2 hours ago I restored my most recent backup, went in and turned the phones "Location Setting" to off, and using MemMaid disabled any and all gps related startups and the phone has been just fine since. So it's most definately GPS problem.
  6. jac6695's Avatar
    Posts
    125 Posts
    Global Posts
    127 Global Posts
    #6  
    Quote Originally Posted by JsrxJsr View Post
    No custom ROM here. I've done 4 hard resets and restored backups from as far back as two months, and still have the same issues each time. This last time I hard reset, with nothing else on the phone, I installed Bing and Google Maps (separately) and immediately experienced the lockups and the phone restarting itself. So about 2 hours ago I restored my most recent backup, went in and turned the phones "Location Setting" to off, and using MemMaid disabled any and all gps related startups and the phone has been just fine since. So it's most definately GPS problem.
    Wow, my STP had this problem starting last Thursday (ironically the same day my new Touch Pro 2 came in the mail). I did 3 hard resets with the last time not installing Garmin or Google Maps, and everything seemed fine until Friday afternoon I swapped to the TP2.
    James

    VZW: 700W>700WX>Centro>Samsung Saga> now with Sprint: Touch Pro>Treo Pro>Touch Pro 2
  7. #7  
    I have done a hard reset to Sprint stock 1.04 rom with the same problems. Also, hard reset and several different Sprite backups from 1 week, 2 weeks, 1 month and 2 months ago individually with the same problems. Leads me to believe it is in no way a software issue. I would assume it to be hardware except that it has happened to so many different people all within the past 2-3 days - too much of a coincidence for me considering people report being on different carriers also. So, what's left in common? Either hardware or something wrong on the satellite end?
  8. #8  
    Can anyone try to verify what I have found? First soft reset, then turn off the cellular radio by holding the button on the top of the phone next to the ringer switch. Then use a GPS program such as Garmin XT that does not require an internet connection. I found that with the radio off I could connect with a GPS signal consisently and quickly with TomTom 7, IGo8, GPS Tuner, TrackyPro, Delorme Street Atlas Handheld, BackCountry Navigator, and Garmin Mobile XT. I tried each one successively twice and locked on to GPS without any reboots or issues. As soon as I soft reset and turned on the cellular radio I was able to lock on with Bing but before I could try another program my phone reset on its own. This happened twice. This would appear to be some sort of network issue since with the radio turned off - not connected to the network - GPS works.
  9. #9  
    I think I have fixed the issue thanks to these threads:



    Does GPS ever just 'go bad'? - PPCGeeks

    HELP!!! GPS software causing reboot and/or freezing - PPCGeeks



    Seems this issue is not limited to the Treo Pro. Here is what worked for me. I downloaded the xtra.bin file from this thread Does GPS ever just 'go bad'? - Page 6 - PPCGeeks (post 59) and the program FileDate.exe from this thread HELP!!! GPS software causing reboot and/or freezing - Page 10 - PPCGeeks (post 92). I extracted the xtra.bin file to my desktop and changed the created, modified, and accessed dates to today using Filedate.exe. I then backed up the xtra.bin file from My Device\Windows just in case I needed it to some other folder on my laptop. I then copied the modified xtra.bin file from my desktop to My Device\Windows and My Device\Temp folders. Then I started QuickGPS and went to Menu\Options and unchecked all boxes and then soft reset. Since then, even after several soft resets, I have been able to use GPS in ALL my GPS enabled software including:

    Google Maps

    Bing

    BackCountry Navigator

    Garmin Mobile XT

    GPS Tuner

    iGO 8

    Delorme Street Atlas Handheld 2009

    TomTom 7

    TrackyPro

    Sprint Navigation



    Hope this works for others also.
  10. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #10  
    Just got this issue. It seems replacing the "xtra" file worked.
  11. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #11  
    Happy to report no issues w/ GPS today, and heavy use.
  12. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #12  
    Anybody brave enough to try this fix for other phones?

    HTC Releases 2016 SMS Patch for Sprint Touch Pro2, Touch Pro & Diamond
  13. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #13  
    I guess I will man up and try it.
  14. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #14  
    Backing up now.
  15. NRG
    NRG is offline
    NRG's Avatar
    Posts
    3,657 Posts
    Global Posts
    3,670 Global Posts
    #15  
    The Touch Pro version won't even install. I suspect it is the same for the rest of them.

    "Incorrect Device or version or previously installed. This HotFix will only support HTC Touch Pro ver2.01.651.6. 0x10"

Posting Permissions