Quote Originally Posted by kaptainchump View Post
I'm almost positive this is from a PRL update or problem. I remember back when I had the treo 650, my phone would go into roaming when i went into my bedroom. If it wasn't on roam, it would be at 0 bars.

After I updated the PRL thinking I would get better service, my service actually got worse. Now I couldn't make my phone roam and it would STAY on 0 bars. It would try so damn hard to stay on that 0 bars that I couldn't get the friggin thing to roam after the update.

THIS WAS FROM THE PRL UPDATE
The PRL can control when you're on Sprint, but the basic way the phone functions is always the same.

If it's on "automatic" (not forced home or forced roaming), then it will always TRY and be on Sprint's network even with just 1 bar.

If you did a PRL update and it added a new tower, or took away a roaming option, or changed a roaming tower's roaming level, then it could cause something like this. There's also some global options on how it handles roaming.

You can try and mess around with the PRL now that we have the ability to upload our own. Worst case scenario you have to go back to a default PRL. It's rather complex though, and doesn't look like there's much (if any) PRL "hacking" going on out there.


Some people find they have better service with a newer PRL, some with an older, the vast majority it doesn't make a difference. But the PRL doesn't effect the phones preference to be on Sprint wherever possible....though it can change WHERE it can be on the network.