Is it just me or is there an issue with google and the Treo Pro.

Each time I goto google, it directs me to the mobile version up comes google.es
So I change the language option on the bottom of the internet explorer screen to english manually then try to download google maps and I'm back in Spanish.

AND if I goto msn.com I'm in English!