Page 1 of 2 12 LastLast
Results 1 to 20 of 24
  1.    #1  
    Hello,
    I would like to use the built-in GPS with Windows Live Search or Google Maps. When I goto Google Maps, it just says "Seeking GPS Satellites" and never finds any. With Live Search, it does about the same thing.

    Has anyone gotten the built-in GPS to work with one of these and how?

    Thanks
  2. kmg
    kmg is offline
    kmg's Avatar
    Posts
    11 Posts
    #2  
    In live search, go to settings and tell it that GPS is COM4
    kmg
  3.    #3  
    When I do that and then goto change to current GPS position, it times out and says it cant communicate with the GPS. What are your settings like under External GPS in the WinMo settings?
  4.    #4  
    On second thought, I tried it again and after 3 minutes it finally worked. Thanks.

    Do you know why its so slow? (and as for the internet connection, im on ATT 3G, so thats not it).
  5. #5  
    Quote Originally Posted by chapmanjw View Post
    On second thought, I tried it again and after 3 minutes it finally worked. Thanks.

    Do you know why its so slow? (and as for the internet connection, im on ATT 3G, so thats not it).
    It's so slow the first time because you're using a cold start. The gps chipset needs to find the initial position and lock the signal. It goes faster when you are outdoors with good satellite reception. This is independent of your gsm/edge/... signal.

    There's a QuickGPS application you can run to download the initial gps data from the internet, although I've never seen proven effect of it. On my previous phone (HTC P3600) this didn't work, and I get the feeling the Treo Pro is the same.
    Click here for more Treo Pro Tricks
  6. waldo15's Avatar
    Posts
    522 Posts
    Global Posts
    565 Global Posts
    #6  
    There are a few things to try speeding up the lock process:

    - use QuickGPS as suggested above.
    - sometimes you need to "jumpstart" your GPS before you can use it with GM/WL. I use an app called GPS test to do it
    - make sure the phone is set to use aGPS. This will speed up the process significantly as well. I have not played with my Pro just yet (on Monday I will!) but with my Tilt I had to manually enable the aGPS function.
  7. #7  
    QuickGPS did the trick for me. Google maps in Sat mode was very cool. I'n having a lot of fun with the Pro today
  8. #8  
    What settings are people using? I'm really struggling with GPS. I can get Live Search and Google Maps to work using Settings/External GPS set to let Windows manage GPS and Live Search set to use GPS Intermediate Driver and Google Maps using Managed by Windows setting. I can't get either to work using Com4 and I can't get another program to work at all.

    Any help much appreciated.
  9. #9  
    Sorry your having trouble caebase. I used the default Com4. Same settings as you. It should work. Did you try QuickGPS first? That seemed to make a difference with me. I do it each time I use Google maps. It only takes a second or two. If I leave it open using Sat view I can drive all over town and if I look at the map it shows right where I'm at.
  10. bacon225's Avatar
    Posts
    26 Posts
    Global Posts
    124 Global Posts
    #10  
    I can't get the GPS to lock on at all using Google Maps or Live Search
    I have my settings like this.
    Settings are:
    The gps program port is com4,
    hardware port is none with baud rate 4800
    and access is set to manage gps automatically.
    Also tried using GPS today makes no difference.
    What am I doing wrong.
  11. #11  
    Are connected to PowerVision? I could never get GoogleMaps to find my location without first connecting to Sprint's network. The problem was GoogleMaps won't initiate the connection to Sprint on its' own. I'd have to open a connection with the browser first.
  12. bacon225's Avatar
    Posts
    26 Posts
    Global Posts
    124 Global Posts
    #12  
    Update it is an Alltel phone if that makes a difference.
  13. #13  
    Try opening a browser session first, then start GoogleMaps see if that kickstarts it.

    Your settings are correct.
  14. bacon225's Avatar
    Posts
    26 Posts
    Global Posts
    124 Global Posts
    #14  
    Quote Originally Posted by furiousyellow View Post
    Try opening a browser session first, then start GoogleMaps see if that kickstarts it.

    Your settings are correct.
    I did try that and the same thing.
    The last thing I have done now is a hard reset and reload Google and Live.
    Still no luck at all.
  15. #16  
    Wow!

    I didn't realize there were so many similar Gps threads.

    Thanks for finding an existing thread rather than starting a new one.

    On my Gsm Treo Pro I have Google Maps set "Managed by Windows"

    For WLS I have COM4

    Under Start Menu -> Settings -> System -> External GPS:

    GPS Program port: COM4
    Hardware: None
    Baud: 4800
    Access: 'Manage GPS automatically'
    Last edited by berdinkerdickle; 04/07/2009 at 02:27 PM.
    Just call me Berd.
  16. #17  
    Quote Originally Posted by oVan View Post
    It's so slow the first time because you're using a cold start. The gps chipset needs to find the initial position and lock the signal. It goes faster when you are outdoors with good satellite reception. This is independent of your gsm/edge/... signal.

    There's a QuickGPS application you can run to download the initial gps data from the internet, although I've never seen proven effect of it. On my previous phone (HTC P3600) this didn't work, and I get the feeling the Treo Pro is the same.
    Where do you get the QuickGPS? It's not on my Treo Pro.....I had it on my Touch Pro, but I can't find it on the Treo Pro.....
  17. #18  
    Quote Originally Posted by cybermonkey View Post
    Where do you get the QuickGPS? It's not on my Treo Pro.....I had it on my Touch Pro, but I can't find it on the Treo Pro.....

    It's on the GTP.
    I don't know why it's not on the STP.

    I just googled.
    Got some hits for ppcgeeks and xda-developers:
    QuickGPS cab - Google Search
    Just call me Berd.
  18. #19  
    This may seem silly, but I had to make sure my Alltel Treo Pro was not set to 911 only to get the GPS working on Google Maps. I've had no problems since.

    Goto: Settings > Phone > Services Tab > Location Settings.
    Sanyo 7800 (Sprint) > Dell Axim > Motorola E815 (Alltel) > Motorola Q (Alltel) > HTC PPC6800 (Alltel) > Palm Treo Pro (Alltel)
  19. bacon225's Avatar
    Posts
    26 Posts
    Global Posts
    124 Global Posts
    #20  
    Quote Originally Posted by jtraveler View Post
    This may seem silly, but I had to make sure my Alltel Treo Pro was not set to 911 only to get the GPS working on Google Maps. I've had no problems since.

    Goto: Settings > Phone > Services Tab > Location Settings.
    That's it THANKS THANKS AND THANKS again.
    I had went to the phone settings but did not that check box I had to scroll down to see it.
    It is all working perfect now.
    Thanks again
Page 1 of 2 12 LastLast

Posting Permissions