Page 4 of 9 FirstFirst 123456789 LastLast
Results 61 to 80 of 164
  1. #61  
    Got mine today. Just charged it up. I like that it charges all the way to 100% using the a/c charger unlike the Palm battery.
  2. #62  
    Quote Originally Posted by hannip View Post
    Got mine today. Just charged it up. I like that it charges all the way to 100% using the a/c charger unlike the Palm battery.
    Please post thoughts on its performance compared to the OEM battery.

    Cosmo
  3. #63  
    Quote Originally Posted by cosmopilot View Post
    Please post thoughts on its performance compared to the OEM battery.

    Cosmo
    Let him run it for more than a few hours first.



    Like a week. Seriously.
  4. #64  
    Quote Originally Posted by Ebag333 View Post
    Let him run it for more than a few hours first.



    Like a week. Seriously.
    Actually, I was hoping for a performance update before he even opened the box it came in. I guess I'm too late to request that info though...maybe the next person could comment whether or not the battery powers the phone from 2 or 3 feet away as well.
  5. #65  
    Quote Originally Posted by cosmopilot View Post
    Please post thoughts on its performance compared to the OEM battery.

    Cosmo
    Been using mine for 4 days now. I'm getting 15-20% better performance.(Imagine that ) I used to get home from work and be at 40%, now I am at 55-60%. For what its worth.
    Pilot 1000 -> Pilot 5000 ->Palm Pilot Professional -> HP 620LX -> TRG Pro -> Palm V -> Palm Vx -> Palm M505 -> Palm i705 -> Palm Tungsten|T -> Samsung i500 -> Treo 600->Treo 650 -> Treo 600-> Treo 700p ->Centro ->Treo 800w + Redfly C8n -> Palm Pre -> HP Touchpad
    R.I.P Palm 1996-2011
  6. #66  
    my non scientific results . I pretty much have the same usage anwhen I get home from work its usually around 50 percent ( in the 50s) now its in the 70's so it is showing a 15 percent difference. I usually charged every other day and I figure with my usage I can go about three days without a charge so I consider this the battery the 800w should have come with. , My usage is as follows. about 2 hours on the net. I check email all day. maybe 15-20 text. 2-3 phone calls maybe 15 minutes.and I listen to 3-4 songs on pocket tunes. (new Metallica album out tommorow so I may need to charge every day now .LOL).
    This battery is a must have.
  7. #67  
    hey sedio any word on when these will be back in stock?
    700WX -> 800W -> Touch Diamond -> Pre?
  8.    #68  
    Quote Originally Posted by 2k4mach View Post
    hey sedio any word on when these will be back in stock?
    Sorry guys. Hurricane Ike is coming this way and we had to make some preparations today. We're expecting another shipment anytime, but FedEx has told us that they'll be closed tomorrow, and that the hurricane will cause a backlog next week. As soon as I get some information I'll be sure to pass it along.

    Thanks,
  9. #69  
    Is anyone having issues with the 1350 battery and screen backlighting? After the battery has been charged (both usb and ac), 800W works for a short while, then the screen goes dark, and eventually crashes causing the need for a soft reboot. The regular battery works well except for occasional not fully charging. Does anyone have a solution?
  10. #70  
    Quote Originally Posted by rwhillyer View Post
    Is anyone having issues with the 1350 battery and screen backlighting? After the battery has been charged (both usb and ac), 800W works for a short while, then the screen goes dark, and eventually crashes causing the need for a soft reboot. The regular battery works well except for occasional not fully charging. Does anyone have a solution?
    Wow, I have experienced on a few ocassions the exact problem you've discribed. Only difference is I'm still using the OEM Battery (1150mA). So maybe it's not the battery - but has something to do with the 800w firmware.
  11. 2_hotty's Avatar
    Posts
    114 Posts
    Global Posts
    123 Global Posts
    #71  
    ...waiting for these batteries to be back in stock....
  12. #72  
    Still not getting the 15% increase in battery life. Lasts less than the stock battery (didn't think that was possible).
  13. #73  
    Quote Originally Posted by rwhillyer View Post
    Is anyone having issues with the 1350 battery and screen backlighting? After the battery has been charged (both usb and ac), 800W works for a short while, then the screen goes dark, and eventually crashes causing the need for a soft reboot. The regular battery works well except for occasional not fully charging. Does anyone have a solution?
    Quote Originally Posted by wagadesa View Post
    Wow, I have experienced on a few ocassions the exact problem you've discribed. Only difference is I'm still using the OEM Battery (1150mA). So maybe it's not the battery - but has something to do with the 800w firmware.
    I was having that problem with my first Treo 800w using the OEM battery. The fix was to get a replacement.
  14.    #74  
    Quote Originally Posted by nsxprime View Post
    Still not getting the 15% increase in battery life. Lasts less than the stock battery (didn't think that was possible).
    NSX,

    It's not possible unless something is wrong with your phone or individual battery. Please send your original order and contact information to forum@seidio.com. I'll get you information on receiving a refund or replacement...whichever you prefer.

    Thanks,
  15. #75  
    Quote Originally Posted by seidioseidio View Post
    NSX,

    It's not possible unless something is wrong with your phone or individual battery. Please send your original order and contact information to forum@seidio.com. I'll get you information on receiving a refund or replacement...whichever you prefer.

    Thanks,
    It's already in the mail on the way back. Hopefully I just got a defective one.
  16. damigs's Avatar
    Posts
    535 Posts
    Global Posts
    536 Global Posts
    #76  
    Is everyone still turning off GPS and/or Location privacy with new extended battery or leaving it on as it came out of box during these test?

    I cannot function if I leave Location Privacy on / GPS driver on with stock battery.

    so just curious..
  17. #77  
    Quote Originally Posted by rwhillyer View Post
    Is anyone having issues with the 1350 battery and screen backlighting? After the battery has been charged (both usb and ac), 800W works for a short while, then the screen goes dark, and eventually crashes causing the need for a soft reboot. The regular battery works well except for occasional not fully charging. Does anyone have a solution?
    Quote Originally Posted by wagadesa View Post
    Wow, I have experienced on a few ocassions the exact problem you've discribed. Only difference is I'm still using the OEM Battery (1150mA). So maybe it's not the battery - but has something to do with the 800w firmware.
    Quote Originally Posted by darnell View Post
    I was having that problem with my first Treo 800w using the OEM battery. The fix was to get a replacement.
    I fixed this problem with my phone. Couldn't accept that I have a defective 800w. I did a hard reset and erased everything. No problem with the backlighting since yesterday evening (26hrs). Problem solved - must be something I installed that didn't agree with the Operating System.
    I had the following programs installed:
    SPB Mobile
    Celio Redfly
    Opera Mobile 8.65
    Dataviz Doc2Go

    I'll load these back one at a time to see if either of them is the true culprit.

    Sorry to high-jack this post - but I do not believe this problem has anything to do with the Siedio 1350mAh battery......
    Visor Phone, Treo 180, Treo 270, Nokia 3650, Treo 650, Treo 680, Treo 800w
  18. ehehat's Avatar
    Posts
    343 Posts
    Global Posts
    347 Global Posts
    #78  
    Quote Originally Posted by rwhillyer View Post
    Is anyone having issues with the 1350 battery and screen backlighting? After the battery has been charged (both usb and ac), 800W works for a short while, then the screen goes dark, and eventually crashes causing the need for a soft reboot. The regular battery works well except for occasional not fully charging. Does anyone have a solution?
    When i first read this i thought "no way a battery is causing this." Well, i just got mine. After having the same software on my device for weeks with no problems at all, as soon as i put the new battery in and charged it i started having backlight issues.i mean immediately after and this was the only change to my device made in several weeks. dont see how a battery could do that but also dont see how it could be anything else.
    Devices used: Palm VIIx - Tungsten T - Tungsten T3 - HP ipaq 4155 - Tungsten T5 - BB 7520 - Treo 650 - Treo 700wx - Treo 755p - Q9c - BB 8130 - Treo 800w - HTC Touch Pro - BB 8330 - BB 8520 - HTC HD2 - Palm Pre
  19. #79  
    Quote Originally Posted by ehehat View Post
    When i first read this i thought "no way a battery is causing this." Well, i just got mine. After having the same software on my device for weeks with no problems at all, as soon as i put the new battery in and charged it i started having backlight issues.i mean immediately after and this was the only change to my device made in several weeks. dont see how a battery could do that but also dont see how it could be anything else.
    I just got my batter yesterday and I have noticed the same thing happening now. This has to have something to do with the battery as I didn't change anything else since yesterday.
  20. ndsc's Avatar
    Posts
    3 Posts
    #80  
    Quote Originally Posted by ehehat View Post
    When i first read this i thought "no way a battery is causing this." Well, i just got mine. After having the same software on my device for weeks with no problems at all, as soon as i put the new battery in and charged it i started having backlight issues.i mean immediately after and this was the only change to my device made in several weeks. dont see how a battery could do that but also dont see how it could be anything else.
    Ditto. I could have written this response myself. Got mine yesterday, immediately had the backlight problem, replaced it with my original battery, and the problem went away.

Posting Permissions