Results 1 to 3 of 3
  1.    #1  
    Just upgraded (at least I hope it turns out to be UP), from Treo 755p to 800w. My battery power drops 2% every 5 minutes. That's with EVERYTHING turned off except my connection to the Sprint network so I can make phone calls! If I turn that off then the battery level stays constant. At the advice of Sprint, I've set my phone to Home Network only.

    Is this simply a problem with Sprint EVO network, does it consume this much power? Or is there some setting or patch I need that will save the day and keep me from switching back to my 755p?
  2. #2  
    ...and you have no programs installed and no email fetching at all?

    Because that would be important to know.

    Try a hard reset and don't install anything and then watch your battery and see if it's the same.

    If it is, the phone is bust. If it's a lot better, user error/wrong configuration.

    WMExperts: News, Reviews & Podcasts + Twitter
  3. #3  
    Quote Originally Posted by DanWoo View Post
    Just upgraded (at least I hope it turns out to be UP), from Treo 755p to 800w. My battery power drops 2% every 5 minutes. That's with EVERYTHING turned off except my connection to the Sprint network so I can make phone calls! If I turn that off then the battery level stays constant. At the advice of Sprint, I've set my phone to Home Network only.

    Is this simply a problem with Sprint EVO network, does it consume this much power? Or is there some setting or patch I need that will save the day and keep me from switching back to my 755p?
    I don't have an 800w, but I had a similar problem with my 755p.

    I took it to Sprint and, if I remember correctly, they replaced my battery one time and my 755p another. Then I stopped having the problem.

    I wouldn't suggest waiting for a patch. For some odd reason, it stopped doing it with the newer battery but I think the problem eventually resurfaced - besides, it was a problem drawing on the network (and thus, the battery power) unnecessarily.

    I lost battery power so quickly I couldn't even get the phone to power on long enough to look up my a number to call for assistance (from another phone, of course). So, I hope you don't get kinda stranded, like me.

    Good luck.
    * Stuck patches? Partial erase worked for me.
    * Stuck virtual keyboard? Partial erase AND folder deletion worked for me.

Posting Permissions