I kept wondering why my phone would keep telling me I was roaming when connecting to my 3G network and finally figured out that I needed to change the country code and area code settings under dialing rules in connections. Took care of that and now I don't get the crazy roaming message everytime I connect. However, how do you do this for the phone?

I thought that maybe changing the settings under dialing rules would fix this, but it doesn't and "my country" is not listed in the regional settings. I know the phone is set to "roaming" because the ring tone is the one for "roaming" not the one I set for known and unknown caller. Of course technically I'm not roaming since my SIM card is local, but this makes it difficult to set up my known and unknown caller ring tones and remove that +(country code) everytime I receive a call or sms.

Can anyone tell me how to fix this? Thanks in advance